Disaster strikes - SeaMonkey removed from ports tree

On a different subject, have you considered making this port official?
SeaMonkeys build process still depends on Python 2.7, which port has set an EXPIRATION_DATE on 2020-12-31 (so it should have been deleted long ago - "almost one year no update" was enough to kick of the SeaMonkey port, while an update was known to be around). You won't have luck to add a new port that depends on a port that has to be deleted.

Getting rid of that dependency is a known todo in the developers discussions, but I wouldn't expect this to be solved soon. Also: I don't want to be an official port manager - I'm not loading up on any more ballast for now. If you want to: Go for it.
How useful is browser?
Well, there are "web programmers" that are checking for the browser itself instead of the render engine, so some pages tell you you should update your browser to the latest version while using the latest version. Some are failing with their JavaScript because of buggy browser detections - instead of simply writing standard compliant code (there is really no need to add special code for special browsers since many, many years); Over the last months f.e. deepl.com didn't work (now it works again), and YouTubes "Studio" says you should use another browser… but: it works (but I'm using only a few features it offers, so maybe…). But such examples are rare.
I'm using the SeaMonkey browser for a part of my daily work: creating huge, extensive web applications. I am fully satisfied with it.
I think something has changed with the most recent ports tree

[00:02:24] Warning: (www/seamonkey): Error: www/seamonkey depends on nonexistent origin 'devel/autoconf213' (moved to devel/autoconf2.13); Please contact maintainer of the port to fix this.
[00:02:27] Error: Fatal errors encountered gathering initial ports metadata
I had trouble finding documentation on allowed characters in a ports name. Dashes are allowed.
But I was unsure that dots were. Nothing in /usr/ports/Mk/bsd.port.mk for help.

In current porters handbook:
Chapter 2. Making a new port
There is no talk of port name at all let alone naming convention.

I had a look at an old FreeBSD 4.4 manual for guidance on PORTNAME.
That seems to indicate that version was not in PORTNAME.
What happened? Multiple program versions overtook the old system?
Adding the dot does the trick, the port is updated.

Spend yesterday a lot of time with the new SeaMonkey beta version (and found the autoconf change myself); From the release notes of 2.53.13b1: "Starting the switch from Python 2 to Python 3 in the build system." While that sounds great it still needs Python 2.7, and the build fails… (to be more specific: I'm able to build a Firefox binary with it, but the configure step already fails to handle the "comm/suite" option). I think I'll have to write a bug report today.
Still not on the mainpage, and: My tests are running since ~1 hour.

It still uses Python 2.7 for the build process, and: Python won't be dropped - instead the efforts not to rely on 2.7 have been started.
yes, my mistake, the python 2.7 is dropped. but you are saying you've checked exactly the last version and it still requres 2.7 to build?
No. From https://www.seamonkey-project.org/releases/seamonkey2.53.13/: "Starting the switch from Python 2 to Python 3 in the build system." The cunfigure-step still executes the python 2.7 binary. To get rid of it will take some time.

Anyway, port upgraded: https://jmos.net/download/ports-20220711.tar.xz

I see. Thank you for the explanation and thank you for the port. It's the good news they are still working on seamonkey. I recently tried to switch to kmail and it crashed all the time. It was a good client long ago though.
I see you have a newer version.
Thank You.

Because I am getting senile I am going to post my make command for using packages for this port.
make install-missing-packages
make build-depends-list | cut -c 12- | xargs pkg install -A -y
make reinstall
Just built your package and .mach had issue with cbindgen missing.
So I did pkg install rust-cbindgen and then it proceeded to build.

First I tried on FreeBSD 12.3 but I descided to upgrade to FreeBSD 13.1 but the error persisted there too.
I really appreciate your work. Nice website work as well.
I only upgrade every 4-6months but it is amazing how badly the web is broken before I update.
Ridiculous that a web browser has a span of 6 months of usefulness.

Shame on you web developers.
Path fails building 2.53.16 on FreeBSD 13.2

===>  Patching for seamonkey-2.53.16
===>  Applying FreeBSD patches for seamonkey-2.53.16 from /usr/ports/www/seamonkey/files
2 out of 2 hunks failed--saving rejects to js/src/old-configure.in.rej
===>  FAILED Applying FreeBSD patch-js_src_old-configure.in
===> FAILED to apply cleanly FreeBSD patch(es)  patch-js_src_old-configure.in
*** Error code 1

make[1]: stopped in /usr/ports/www/seamonkey
*** Error code 1

make: stopped in /usr/ports/www/seamonkey

===>>> make build failed for www/seamonkey
===>>> Aborting update

===>>> There are messages from installed ports to display,
       but first take a moment to review the error messages
       above.  Then press Enter when ready to proceed.