FreeBSD Hosting/Shared/VPS etc.

No. I'd say it's closely related to the topic of this thread. Why do some people want a VPS? They want privacy and/or anonymity, therefore they set up services like tor(1) on these VMs.
I absolutely agree with you. people (literate and able to reason logically) do not want to be manipulated (with the help of "social networks", aka facebook, etc) and be at the mercy of massons-Satanists.
 
You're forgetting the IMEI number of the phone.
That identifies the modem module inside my laptop. Thus I wrote: change the modem module. And of course the laptop, due to the uuid. Besides that -- the hardest part would be to change one's habits... We can be identified by our online activities.
Not sure about German laws but in the Netherlands you're registered and your IP plus identity is sent to a government agency (CIOT; sorry Dutch only). No provider will openly admit this but they're bound by law to do this (I've worked for a couple of hosting providers).
Our laws should be very much the same because they have to comply to EU laws. You set up a tor(1) proxy, I do so, our friend X does, he uses yours, you use mine & I use X's. And we select the final proxy in the chain carefully. Voilà. The whole tor(1)-proxy & VPN thing is a matter of trust. And we have Freifunk ;)
 

neel

Developer
The reality is that unlike the 2000s and early 2010s, finding a FreeBSD VPS isn't too hard anymore. Not as easy as Linux, but still.

Now, even megaclouds like Amazon, Google, and Microsoft have FreeBSD Images, and many Tier-2 providers like DigitalOcean, OVH, Vultr, etc. do as well. There are still many providers who don't, such as Scaleway, or make it hard, like Linode.

In the past, it was niche providers who offered FreeBSD VPSes. In the 2000s, it was mostly small Jail hosts like JohnCompanies. By the early 2010s it was from providers like BuyVM when full hardware hypervisors came, but at a premium when compared to the then-common OpenVZ and Xen. Then, bigger providers didn't even touch FreeBSD in any form, and FreeBSD on AWS then was literally a fantasy.

It's much easier now since megaclouds have FreeBSD options, unless you hate yourself and go with Oracle. And smaller providers have gone all-KVM, making it easier to run FreeBSD or any BSD.

Disclaimer: I work at Microsoft, but not on Azure or Hyper-V.
 
Alright, I did now throw some money into that one-armed-bandit.
And I am very curious what will happen next (never had anything to do with hosting before).
I've got some servers from them, mostly xeon 4c/8t RAM >= 16GB from sth about 2 years and they're works fine. They have some FreeBSD iso for install but latest one i have to install via ISO mounted via net (some of panels let do this) or I install that what they have and after fresh installation do immediately upgrade to version that i need.
 
Last edited:
First impressions:
------------------

After the piece is delivered, there is an option "reinstall", where various OS are offered, among them FreeBSD. There one has to fill in a username and a password.

Soon it answers to ping, and also to ssh, as something called "poneybsd" - but no login appears to be possible.
Then choosing "Boot mode" -> "boot in normal mode" -> "Boot" seems to reboot, and now it appears with the configured hostname and one can login (new ssh host key). One can also su to root.

FreeBSD 11.3-RELEASE-p13 #0: Tue Sep 1 06:56:51 UTC 2020 root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64
Slightly late, but properly patched. Not too bad as a starting.

There is no firewall active, and lots and lots of hackers appear in auth.log. (My home IP is actually located at Hetzner - and it's not as bad there.)

I didn't find a console - maybe there is none provided?

The disk is partitioned as
2G -root-
3G swap
227G /usr
227G /var
472G -empty-
using MBR, 1 partition and a disklabel.

Without console that will be difficult to change. (The linux images have a partition dialogue in the web interface.)

There is an option "request ipmi session", but that does just create a ticket.

Power off with "halt -p" works.

"Boot in rescue mode" results in a helptext: one gets told a username and password to connect with ssh. New host key. It's poneybsd again. The password does not work (booted FBSD-11.0). Now booting FBSD-10.1 - here the password works.
Helptext says "use sudo command for root privs", but there is no sudo installed:

>Feb 1 01:10:19 poneybsd pkg: indexinfo-0.3.1 installed
>Feb 1 01:10:19 poneybsd pkg: readline-7.0.3_1 installed
>Feb 1 01:10:19 poneybsd pkg: libffi-3.2.1_2 installed
>Feb 1 01:10:19 poneybsd pkg: gettext-runtime-0.19.8.1_1 installed
>Feb 1 01:10:24 poneybsd pkg: python27-2.7.15 installed
>Feb 1 01:10:24 poneybsd pkg: py27-setuptools-40.4.3 installed
>Feb 1 01:10:25 poneybsd pkg: py27-pip-9.0.3 installed

Hmm, that doesn't help me much.

System looks like this now:
Code:
Filesystem 1K-blocks   Used   Avail Capacity  Mounted on
/dev/md0       61319  52481    3933    93%    /
devfs              1      1       0   100%    /dev
tmpfs        3439404     24 3439380     0%    /tmp
tmpfs        3667768 228388 3439380     6%    /usr
tmpfs        3502216  62836 3439380     2%    /var/db/pkg
tmpfs        3457124  17744 3439380     1%    /var/cache/pkg

Not sure how that tmpfs trick is done, but the system's disk stays closed and one could now work it over - if one had rights to do so.

>Aide et documentation : http://documentation.dedibox.fr
>Console de gestion : http://console.dedibox.fr

I don't speak french. :(

One can also boot a Linux as the rescue mode - and then, wow, that has a sudo!
Alright, giving it a second try - the 11.0 rescue image now allows login, and voila, there is a sudo! :)

So lets explore the production installation:
The initial root password that one has provided for installation is now placed into a file in /tmp. World readable.

The sshd_config allows root login.

> ifconfig_igb0="DHCP"

Oh well, if they insist...

resolv.conf:
> nameserver 127.0.0.1
> local_unbound_enable="YES"

In a compute center??

Lets look at the disk:
Code:
  9 Power_On_Hours          -O--C-   038   038   000    -    27520
12 Power_Cycle_Count       -O--CK   100   100   000    -    62
192 Power-Off_Retract_Count -O--CK   100   100   000    -    24
193 Load_Cycle_Count        -O--C-   085   085   000    -    153703
194 Temperature_Celsius     -O----   125   125   000    -    48 (Min/Max 21/61)
240 Head_Flying_Hours       -O--CK   040   040   000    -    26557
241 Total_LBAs_Written      -O--CK   100   100   000    -    51734732237
242 Total_LBAs_Read         -O--CK   098   098   000    -    171273057725

Current Temperature:                    48 Celsius
Power Cycle Min/Max Temperature:     44/48 Celsius
Lifetime    Min/Max Temperature:     21/61 Celsius
Specified Max Operating Temperature:    42 Celsius
Under/Over Temperature Limit Count:   0/0

And I thought only I had an overtemp problem here at my location (now no longer, I built a sufficient fan array controlled by the smart data).

Next point: where are we actually located?
This would equate to the (in)famous AS12876, better known as poneytelecom.eu...

Next item: The CMOS-wallclock. It's just broken, empty, out-of-order. (See the thread about unbound.)

So far, so good. I mean, what do we expect as dedicated server hosting for 5.50€ a month? It seems they are sold out now, and I'm really happy I got one, and I hope it will not break during the next, say, five years or so.
 
There is Inleed (in Sweden) https://inleed.com/server-hosting/vps/. You chose which ISO you want and you get it (just give them the link to the .iso). You install everything from scratch (if you want).

You can encrypt the disk in ZFS yourself, change (host-root) pass so only you can access it (normally you can’t do this in many hosting) etc. etc. You have really good control over your VPS.

Not the cheapest one, but stable. From €25 for 2 Xeon CPUs, 8GB ram and 100 GB SSD, 1gbps link and 1 IPv4. Fast and good support. You can specify what you want, and you get it.

And No, i don’t work there! :) I had a FreeBSD VPS there as a remote test server for a year.
 
I have used Tilaa for 4 years now. Was happy so far, but for the last 2 months routing between Amsterdam and Estonia goes via USA. Ping is up from 40ms to 100+ ms and I also get lag and packetloss of up to 20%.

So I no longer recommend Tilaa and want to switch provider.

Requirements: Be inside EU, support FreeBSD, good connection to Estonia. And sensible price too.

EDIT: Finally got honest answer from Tilaa support:
"Unfortunately, our upstream-provider has informed us that they cannot solve this issue. We're looking into other options to resolve this issue; however, these will probably not be very short term."

So I will probably move.
 
Last edited:

SirDice

Administrator
Staff member
Administrator
Moderator
Don't know about their connection to Estonia but I moved from Tilaa to TransIP a couple of years ago. I had other reasons to switch (not related to anything Tilaa did or didn't do).
 
Can't access that without an account / being logged in.
In their rescue system they were supporting both Linux and FreeBSD. Yesterday I notice that they remove FreeBSD support. Here is their reply:

the FreeBSD Rescue has been running as a permanent beta version for quite some time and has caused continuous problems with several server models.

We were not able to fix these issues, even with support from FreeBSD maintainers.

Because of this and due to the low number of FreeBSD users, we have dropped FreeBSD Rescue Support.

For data recovery you can use the Linux Rescue System, which also offers an install script für OpenZFS.

If you require FreeBSD images, you will have to request an image via USB Stick + KVM.

Thank you very much for your understanding.
 
What do we learn here? Never trust Germans. 👿😜

Jokes aside, what does this mean exactly? They still support FreeBSD (where "support" means: "Yeah, you can run that here") but they only provide a hands-free rescue system for Linux? Or did they drop FreeBSD support entirely (at least, officially for new customers)?

I would be really interested to know what kind of "continuous problems with several servers models" they were experiencing which they weren't able to fix "even with support from FreeBSD maintainers"? Would they be willing to elaborate on that?
 
What do we learn here? Never trust Germans. 👿😜

Jokes aside, what does this mean exactly? They still support FreeBSD (where "support" means: "Yeah, you can run that here") but they only provide a hands-free rescue system for Linux? Or did they drop FreeBSD support entirely (at least, officially for new customers)?

I would be really interested to know what kind of "continuous problems with several servers models" they were experiencing which they weren't able to fix "even with support from FreeBSD maintainers"? Would they be willing to elaborate on that?
In their control panel there was an option to load FreeBSD from RAM (mfsBSD). With this you could start a FreeBSD installation or do a fsck.
Now they remove FreeBSD rescue system and only Linux left there as an option. So to do a FreeBSD installation I build a mfsBSD with DHCP enabled and now I have to boot in Linux rescue mode, then I have to run dd if=/root/mfsbsd.img of=/dev/nvme0n1 bs=1024, then reboot and it boots in my mfsBSD. Then I can complete the FreeBSD installation. Also now to do a fsck I have to request them to connect KVM and run the fsck in single boot mode which is a waste of time for both them and for me.

For me their FreeBSD rescue system was very reliable and I don't believe they had issues with it either. I guess they remove it just to avoid the small extra effort to keep it. It's something that was low maintenance, they had to upgrade it once per year when a new FreeBSD version was released.

Screenshot 2022-06-21 at 17.36.03.png
 
I was also unpleasantly surprised by this. Moreover, some lines of dedicated servers in Hetzner were incompatible with FreeBSD before, and the rescue mode was initially disabled there. But now Hetzner preferred to turn off FreeBSD (rescue) globally, even where it worked well.

It looks like a worldwide conspiracy against FreeBSD hosting. Perhaps the FreeBSD Foundation should consider setting up their own independent hosting ;-) :-/

2022-07-14 upd: This HOWTO may be helpful for installation of FreeBSD via Linux Rescue in Hetzner/OVH.
 
Last edited:
Top