MATE Compton transparency issue.

So I installed mate DE and compton, but whenever I bring up a terminal I get this weird transparent after on all of my open windows. example in the file I attached.
 

Attachments

  • 2021-03-11-193840_1280x800_scrot.png
    2021-03-11-193840_1280x800_scrot.png
    335.7 KB · Views: 112
If it's not apparent in the screenshot, Firefox becomes transparent once I bring up the terminal.
 

SirDice

Administrator
Staff member
Administrator
Moderator
Please don't use generic titles like "I need help" or "why does this happen?". Many people only scan thread titles and such a generic title gives no insights what the question or issue might be. So a lot of people are just going to skip your thread.

I've set a more appropriate title.
 
I didn't know that x11-wm/picom was a thing. Is that now the recommended thing for MATE instead of Compton? Is there also graphical interface to configure it? I'm having some trouble with Marco and wondering if a switch to another window manager would be better.
 
Please don't use generic titles like "I need help" or "why does this happen?". Many people only scan thread titles and such a generic title gives no insights what the question or issue might be. So a lot of people are just going to skip your thread.

I've set a more appropriate title.
yeah sorry my bad.






Compton is widely configurable, you should create your own ~/.config/compton.conf and set whatever behaviour you want.

I agree with you that default settings include too much transparency. You can copy/paste them from https://github.com/chjj/compton/blob/master/compton.sample.conf and change the parameters you don't like. You can also use x11/compton-conf if you want a graphical interface.
thanks, just dont know what to change to make this weird transparent thing not happen.
 
just wanna say i figured it out by editing the compton.conf file to have full opacity. thanks yall.
 
Top