fnoyanisi

Active Member

Reaction score: 101
Messages: 225

Hi,

I was using x11/mate as my desktop manager and recently decided to install x11/gnome3. There are some issues I have been struggling with;
1 ) GNOME insists using x11-fm/caja instead of x11-fm/nautilus as the main file manager
2 ) x11-fm/nautilus uses large icons, that I don't like. When I try to resize icons, x11-fm/nautilus crashes all the time.

Any suggestions are welcome

Thanks in advance..
 

cpm@

Moderator
Staff member
Moderator
Developer

Reaction score: 948
Messages: 2,140

Regarding your first question:

First, be sure that you have installed these files:
Code:
% la /usr/local/share/applications/nautilus*
/usr/local/share/applications/nautilus-autorun-software.desktop
/usr/local/share/applications/nautilus-classic.desktop
/usr/local/share/applications/nautilus-connect-server.desktop
Then run the following command xdg-mime default nautilus*.desktop inode/directory

Read xdg-mime(1) manpage for details.
 
OP
fnoyanisi

fnoyanisi

Active Member

Reaction score: 101
Messages: 225

I have those application files installed, but running the mentioned xdg-mime(1) command produces an error message
Code:
~ % ll /usr/local/share/applications/nautilus*
-rw-r--r--  1 root  wheel  2999 Jan 28 17:55 /usr/local/share/applications/nautilus-autorun-software.desktop
-rw-r--r--  1 root  wheel   439 Jan 28 17:55 /usr/local/share/applications/nautilus-classic.desktop
-rw-r--r--  1 root  wheel  4715 Jan 28 17:55 /usr/local/share/applications/nautilus-connect-server.desktop
~ % xdg-mime default nautilus*.desktop inode/directory
zsh: no matches found: nautilus*.desktop
I also tried to create an nautilus.desktop file by modifying the contents of another *.desktop file and used xdg-mime(1) to assign that application file I created as the default handler for inode/directory, but it did not work :(
 
OP
fnoyanisi

fnoyanisi

Active Member

Reaction score: 101
Messages: 225

For googlers or people having the same issues...

I managed to fix the first problem by editing ~/.config/mimeapps.list file. One need to find the line below and update it accordingly (make sure you have proper *.desktop file in place)
Code:
inode/directory=nemo.desktop
For the second problem about x11-fm/nautilus, I created a bug report in bugzilla. Seems like using x11-fm/nemo instead of x11-fm/nautilus is a better solution for now.
 

cpm@

Moderator
Staff member
Moderator
Developer

Reaction score: 948
Messages: 2,140

I'm sorry. I guessed that I explained it properly o_O

You only need to run this command with each *.desktop file
Code:
% xdg-mime default nautilus-autorun-software.desktop inode/directory
% xdg-mime default nautilus-classic.desktop inode/directory
% xdg-mime default nautilus-connect-server.desktop inode/directory
It's necessary to disable caja desktop handling using the following command
Code:
$ gsettings set org.mate.desktop.background show-desktop-icons false
$ killall caja
Also you can test the result xdg-open $HOME
 
OP
fnoyanisi

fnoyanisi

Active Member

Reaction score: 101
Messages: 225

I'm sorry. I guessed that I explained it properly o_O

You only need to run this command with each *.desktop file
No worries, my bad... I should have tried it in the first place....

As I mentioned, since there is an issues with x11-fm/nautilus, I decided to use x11-fm/nemo instead. The good news is, somebody has picked up the case already and was able to reproduce the problem (partially).
 

cpm@

Moderator
Staff member
Moderator
Developer

Reaction score: 948
Messages: 2,140

Well, if you want to use x11-fm/nautilus as default file manager.

Change in $HOME/.config/mimeapps.list
Code:
[Default Applications]
inode/directory=org.gnome.Nautilus.desktop
 

cpm@

Moderator
Staff member
Moderator
Developer

Reaction score: 948
Messages: 2,140

Please, consider if you want to know the most important changes, they are kept track of them on the NEWS file and you have the roadmap in the wiki of nautilus.
 
Top