Xorg && joystick not working

ma

New Member

Reaction score: 2
Messages: 18

Hello,

My son wants to play flightgear on his laptop and I have installed him a joystick. The kernel is FreeBSD CURRENT r292778-amd64 with Xorg 7.7.2 ... all compiled from ports. I have installed also the uhidd driver module and the device /dev/uhid0 is there after attaching the joystick THRUSTMASTER T-FLIGHT STICK X.
For Xorg I installed the driver xf86-input-joystick-1.6.2_4.

The configuration in xorg.conf is:

Code:
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Joystick0" "SendCoreEvents"
EndSection
...
Section "InputDevice"
        Identifier  "Joystick0"
        Driver      "joystick"
        Option      "Device" "/dev/uhid0"
        Option "MatchIsJoystick"   "on"
         Option "DebugLevel"        "1"
         Option "StartKeysEnabled"  "True"
         Option "StartMouseEnabled" "True"
         Option "MapButton1"        "button=1"
         Option "MapButton2"        "button=2"
         Option "MapButton3"        "button=3"
         Option "MapButton4"        "none"
         Option "MapAxis1"          "mode=relative    axis=+1x  deadzone=5000"
         Option "MapAxis2"          "mode=relative    axis=+1y  deadzone=5000"
         Option "MapAxis3"          "mode=relative    axis=+1zx deadzone=5000"
         Option "MapAxis4"          "mode=relative    axis=+1zy deadzone=5000"
         Option "MapAxis5"          "mode=accelerated axis=+1x  deadzone=5000"
         Option "MapAxis6"          "mode=accelerated axis=+1y  deadzone=5000"
         Option "MapAxis7"          "mode=none"
EndSection

On start of Xorg the device is seen, but not accepted:

Code:
...
[   341.061] (II) LoadModule: "joystick"
[   341.062] (II) Loading /usr/local/lib/xorg/modules/input/joystick_drv.so
[   341.062] (II) Module joystick: vendor="X.Org Foundation"
[   341.062]    compiled for 1.17.4, module version = 1.6.2
[   341.062]    Module class: X.Org XInput Driver
[   341.062]    ABI class: X.Org XInput driver, version 21.0
...
[   341.364] (II) Using input driver 'joystick' for 'Joystick0'
[   341.364]    Option "Device" "/dev/uhid0"
[   341.364]    Option "MatchIsJoystick" "on"
[   341.364]    Option "DebugLevel" "1"
[   341.364]    Option "StartKeysEnabled" "True"
[   341.364]    Option "StartMouseEnabled" "True"
[   341.364]    Option "MapButton1" "button=1"
[   341.364]    Option "MapButton2" "button=2"
[   341.364]    Option "MapButton3" "button=3"
[   341.364]    Option "MapButton4" "none"
[   341.364]    Option "MapAxis1" "mode=relative    axis=+1x  deadzone=5000"
[   341.364]    Option "MapAxis2" "mode=relative    axis=+1y  deadzone=5000"
[   341.364]    Option "MapAxis3" "mode=relative    axis=+1zx deadzone=5000"
[   341.364]    Option "MapAxis4" "mode=relative    axis=+1zy deadzone=5000"
[   341.364]    Option "MapAxis5" "mode=accelerated axis=+1x  deadzone=5000"
[   341.364]    Option "MapAxis6" "mode=accelerated axis=+1y  deadzone=5000"
[   341.364]    Option "MapAxis7" "mode=none"
[   341.364]    Option "SendCoreEvents"
[   341.364]    Option "driver" "joystick"
[   341.364]    Option "identifier" "Joystick0"
[   341.364] (**) Option "SendCoreEvents"
[   341.364] (**) Joystick0: always reports core events
[   341.365] (EE) PreInit returned 11 for "Joystick0"
[   341.365] (II) UnloadModule: "joystick"
...

What is missing or wrong in the configuration?
Thanks

matthias
 
Top