Using FreeBSD as Desktop OS

knightjp

Active Member

Reaction score: 31
Messages: 174

Did you put nvidia_load="YES" and nvidia-modeset="YES" in /boot/loader.conf?
I did put nvidia_load="YES" in the file, but not the other one. You think that was my issue? I never had to put that in before for fluxbox.
 

rigoletto@

Daemon
Developer

Reaction score: 1,170
Messages: 2,217

n it and generate the xorg.conf file.
Why? A xorg.conf file should no be necessary anymore.

Remove that file and create a new one in xorg.conf.d with this content (you can call the file 20-nvidia.conf or something like that):
Code:
Section "Device"
   Identifier     "nVidia Card"
   Driver         "nvidia"
   VendorName     "nVidia Corporation"
   BoardName     "GeForce GT 1050"
EndSection
 

knightjp

Active Member

Reaction score: 31
Messages: 174

nvidia-xconfig should take care of that.
I already did that. After that it is the same result. This has me baffled. I can't understand it. The instructions are clear and I followed them explicitly.
 

rigoletto@

Daemon
Developer

Reaction score: 1,170
Messages: 2,217

MarcoB I use a nvidia card and I do not have a xorg.conf, just the one setting the driver to be used.
 

MarcoB

Well-Known Member

Reaction score: 114
Messages: 391

Strange, I also have a Nvidia card (Quadro 600) but that doesn't work without an xorg.conf.
 

rigoletto@

Daemon
Developer

Reaction score: 1,170
Messages: 2,217

Mine is a GT 630. I just need to have the "Device" section in xorg.conf.d and this nvidia-modeset_load="YES" on /boot/loader.conf to have it running. However, I also add hw.vga.textmode="1" to /boot/loader.conf otherwise I can't switch from X to console.

There may have just a few parameters you actually need to have the card working instead of a entire xonf.conf file.
 

MarcoB

Well-Known Member

Reaction score: 114
Messages: 391

Ok but I don't have a xorg.conf.d file. So it doesn't matter much I guess.
I also have the textmode set in loader.conf. This is because of a bug in the driver.
 

rigoletto@

Daemon
Developer

Reaction score: 1,170
Messages: 2,217

xorg.conf.d is a directory [/usr/local/etc/X11/xorg.conf.d] what can just be created. :)
 

MarcoB

Well-Known Member

Reaction score: 114
Messages: 391

Sorry, said it wrong. I do have the directory of course, but no file in it.
 

scottro

Daemon

Reaction score: 570
Messages: 1,561

In the old days, xorg.conf, usually a pretty long file, was put into /etc/X11. Nowadays, (VERY generally speaking) that xorg.conf usually isn't necessary (though with NVidia, on both Linux and FreeBSD, I use it. But, on say, a laptop with a supported Intel card, (meaning a fairly old laptop by now, unless you use CURRENT), there won't be the /etc/X11/xorg.conf
file.

Still, you might want to add a little part of a xorg.conf file to, say, support a synaptics touchpad. In such a case, you can now use /usr/local/etc/xorg.conf.d and create say, a file with a name like 50-synaptics.conf. (The most important part is the .conf at the end.) That will be a really short file with something like
Code:
Section "InputDevice"
    Identifier      "Mouse0"
    Driver          "mouse"
    Option          "Protocol"      "auto"
    Option          "Device"        "/dev/sysmouse"
    Option          "ZAxisMapping"  "4 5 6 7"
EndSection
TL;DR
Sometimes you just need a few lines from a standard xorg.conf file in which case, you can use /usr/local/etc/X11/xorg.conf.d/<number>something.conf
 

knightjp

Active Member

Reaction score: 31
Messages: 174

OK... I think I found the issue. its nvidia-xconfig..

After the initial install I did the following in the same order.
Code:
pkg install nano sudo xorg
Code:
 nano /etc/rc.conf
insert 
hald_enable="YES"
dbus_enable="YES"
linux_enable="YES"
then reboot
Code:
pkg install nvidia-driver nvidia-settings
nano /boot/loader.conf
insert--
nvidia_load="YES"
Reboot
Code:
startx (to check everything works)
pkg install openbox menumaker
nano ~/.xinitrc
add 
exec openbox-session
Reboot
Code:
startx (to check if everything is working well)
Everything was working with the exception of my second monitor.
So I thought that nvidia-xconfig would be the issue and I never created any xorg.conf file..
With that, I installed nvidia-xconfig and after the reboot, I ran it and then "startx"..
I got a error and xorg failed to start.
I then did a reboot and it was the same result.

Any ideas?
 

MarcoB

Well-Known Member

Reaction score: 114
Messages: 391

Did you place the /.root/xorg.conf.new file, that nvidia-xconfig created, in /etc/x11?
 

achix

Well-Known Member

Reaction score: 49
Messages: 293

Mine is a GT 630. I just need to have the "Device" section in xorg.conf.d and this nvidia-modeset_load="YES" on /boot/loader.conf to have it running. However, I also add hw.vga.textmode="1" to /boot/loader.conf otherwise I can't switch from X to console.

There may have just a few parameters you actually need to have the card working instead of a entire xonf.conf file.
thanks for the pointer to hw.vga.textmode="1" . I was scratching my head why can't I have some meaningful text display in 1-8 screens, but got some cryptic garbled text in return.
 

MarcoB

Well-Known Member

Reaction score: 114
Messages: 391

Yeah this bug is there since quite some time. It's a Nvidia bug or a vt bug but since the driver is closed source the FreeBSD camp probably has a hard time solving it.
 

knightjp

Active Member

Reaction score: 31
Messages: 174

Did you place the /.root/xorg.conf.new file, that nvidia-xconfig created, in /etc/x11?
No.... I didn't do that. Maybe that is the thing that I forgot.. Interestingly enough, I didn't have to do that for Fluxbox. Both monitors worked perfectly after doing the nvidia-xconfig command.
 

Beno Kurniawan

New Member

Reaction score: 2
Messages: 13

Dear knightjp , as mentioned by lebarondemerde , if you installing nvidia-driver, this means your card is supported by recent nvidia driver (not legacy). Shouldn't you use nvidia-modeset_load="YES" instead of nvidia_load="YES" on /boot/loader.conf? Then you also would need hw.vga.textmode="1" to switch between x and console.
 

knightjp

Active Member

Reaction score: 31
Messages: 174

Dear knightjp , as mentioned by lebarondemerde , if you installing nvidia-driver, this means your card is supported by recent nvidia driver (not legacy). Shouldn't you use nvidia-modeset_load="YES" instead of nvidia_load="YES" on /boot/loader.conf? Then you also would need hw.vga.textmode="1" to switch between x and console.
Thanks for the reply. I'm no expert - just an amateur at best. So all of this is actually new to me.
 

Beno Kurniawan

New Member

Reaction score: 2
Messages: 13

Hi knightjp ,

Same here, I also not an expert. I start to learn in a hardway, get up as often as my falls. Install on my daily production laptop, blank screen, unable to solve problem, unable to take important docs on external ntfs drive, uninstall. Switch to another OS, experimenting on VM. Gaining more confidence, install again and so on.
All in all, handbook, faqs and forums are my best friend and source of knowledge. There were lots of developers, moderators, and members which actively helping each other and we could learn together here.
 

Trihexagonal

Daemon

Reaction score: 1,131
Messages: 1,805

I have 2 Thinkpad T61 running FreeBSD 11.1-RELEASE-p8 that both use the Nvidia Quadro NVS 140M and the x11/nvidia-driver-304. I'm using one now. To get mine up and running using ports and ports-mgmt/portmaster:

I compile the driver and linux emulation. ports-mgmt/portmaster wants to install linux emulation with the build IIRC.

Have x11/nvidia-xconfig generate an /etc/x11/xorg.conf file. There shouldn't be a need to post mine.

Use this in my /boot/loader.conf:
Code:
linux_load="YES"
nvidia_load="YES"
nvidia-modeset_load="YES"
And this in my /etc/rc.conf:
Code:
linux_enable="YES"
Whether or not all these are deemed as necessary it's what I do to get mine running and works every time.
 

drhowarddrfine

Son of Beastie

Reaction score: 1,622
Messages: 3,666

I'm using x11/nvidia-driver-340 on a GeForce 9600GT for several years. I haven't touched it except for upgrading since I built this workstation four(?) years ago. It's the only not-brand-new component in the system.
 

knightjp

Active Member

Reaction score: 31
Messages: 174

When talking about Desktop environments, KDE has always been one of my favorites. I like Gnome3, but it has never really caught my eye...
Having seen this video - Why I love Unity, I wonder if anyone has been able to port the Unity project to FreeBSD. I know that its not a favorite, but it seems to have some pretty cool features.
 
Top