• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved system stuck on bios splash after reboot only

farrok

New Member


Messages: 3

#1
Firstly, I couldn't find an answer for this specific problem, so I apologize when this is a common problem.

Recently I installed FreeBSD again on a new laptop (Thinkpad T470 20HES2SF00). On my desktop, the OS runs without problems with Xorg.

I have chosen FreeBSD 12.0-CURRENT for that, because I need support for the iwm 8265 device + kabylake support via drm-next-kmod.

Booting into the OS after the installation works (I use ZFS + GELI encryption), but when I reboot via reboot(8) or shutdown -r now I'm stuck on the BIOS splash screen.

Shutting down the computer and do a fresh boot works as expected, only rebooting doesn't work. The OS before (void linux, and well the preinstalled windows 10) didn't have that problem. Furthermore, the reboot is stuck only when fully logged in on the system before, rebooting from the FreeBSD bootloader works without problems.

FreeBSD 11.1-RELEASE is stuck on reboot too.

BIOS is version 1.30. Boot order is primary the SSD (I deactivated all others to test) UEFI boot, tried with/-out secure boot and old bios boot too.

Is this a known problem? How can i fix it? Or how can I debug the problem, I would be thankful for some pointers.

FreeBSD is pretty new to me, using it for some month as a second system on my desktop computer, but using GNU/Linux for over a decade and use the terminal extensively, so I hope I'm not completely incapable to fix the problem with some help!

Hope it was understandable and thanks in advance!
 

sko

Well-Known Member

Thanks: 129
Messages: 295

#4
We have a bunch of ASRock NUCs whose UEFI randomly/often hangs at reboot. Same behaviour with 2 ASUS desktop ("gaming") mainboards although on one of them got considerably better after a BIOS/UEFI upgrade.
All of them have other issues with UEFI (like randomizing/"forgetting" boot settings/order or taking _very_ long to POST if a USB drive is plugged in), so I suspect the overall quality of the Firmware on these boards is just crap. OTOH FreeBSD seems to trigger buggy reboot behaviour with UEFI far more often than other OS - I've tested one of the NUCs with devuan linux and could reproduce the hangs only on every ~3rd-4th reboot compared to nearly every reboot with FreeBSD (11.0 and 12.0/TrueOS).
 

farrok

New Member


Messages: 3

#5
unfortunately, already updated to newest bios without fixing the problem.

Edit: not solved entirely, but at least for me.

reinstalled the system, without encryption. added it after the installation.
now reboot works as expected.
i don't know if the first install was broken or not, but seems like it, or there is an error in the installer with encryption on zfs with geli?

for the future here the important computer data:
Model: Thinkpad T470 20HES2SF00 (kabylake gen.; unchanged hardware from base model)
BIOS (UEFI): 1.42(N1QET67W)
ECP: 1.27(N1QHT45W)

OS: FreeBSD 12.0-CURRENT
 

wostok

New Member


Messages: 2

#6
I have the same reboot-issue here with a T470p with zfs but no encryption.

model: Thinkpad T470 20J6001AGE
os: 11.1-RELEASE-p6