Steamuxulation redux

$ env WINEPREFIX=$HOME/.wine-test /opt/steam-utils/bin/lsu-wine-env wine64 winecfg
Segmentation fault

While I don't have this issue, I do observed that there below error in your log:
wine: '/usr/home/steamdev/.steam/steam/steamapps/compatdata/280790/pfx' is a 64-bit installation, it cannot be used with a 32-bit wineserver.

I play 64bit games with the steam native proton and 32bit with emulators/wine-proton.
Have you tried Creativerse with the steam native proton? I suppose emulators/wine-proton won't work for Creativerse as the game is 64bit.
 
While I don't have this issue, I do observed that there below error in your log:


I play 64bit games with the steam native proton and 32bit with emulators/wine-proton.
Have you tried Creativerse with the steam native proton? I suppose emulators/wine-proton won't work for Creativerse as the game is 64bit.

I've tried many games: Alan Wake, Heroes of might and magic III HD, Age of Conquest, etc.

What version of FreeBSD do you have?
 
Hello everyone who can help with the proton setup? I install a clean fresh FreeBSD 12.2 then run the autoinstall script. You can download it too, the code is open.
Then I do 1-9 steps in utilities (this is also my script) but proton doesn't work.
2021-03-02.png


As a result, I have a proton listed on Steam

Безымянный.png

You can try installing manually without utils, just type in the terminal:
Bash:
~$ cat utils
Bash:
~$ sudo su steamdev
...
In general, what am I doing wrong, maybe the proton 5.13.2 >> 5.13.4 packages got lost?
 
Last edited:
I thought we had already established this involves a Wine segfault. Why do you want me to review unrelevant steps again?
Sorry, it's just that other people say what works for them, but how? - I am using the same version of the latest version of FreeBSD. So is this a bug in the wine package? i386-wine-devel doesn't fit - I've checked.
 
I just dropped a yet another workaround (can't help myself, sorry) into steam-utils. This one deals with Unity games crashing on startup with a stack overflow error. Typically they print something like "Stack overflow in unmanaged: IP: 0x801911013, fault addr: 0x7ffffffe7c58". To check whether this might be applicable to your games run grep -i "stack overflow" ~/.config/unity3d/*/*/*.log. Then in Steam set the launch options to LD_PRELOAD=${LD_PRELOAD}:unityfix.so %command%.
FYI, unityfix.so has been renamed to monofix.so and now contains one more workaround. The table at https://github.com/shkhln/linuxulator-steam-utils/wiki/Compatibility has been adjusted accordingly.
 
Readme tells you to install wine-proton twice specifically to make it work in WoW64 mode. Is it broken for 64-bit games somehow?
Hi Alex,

I found that actually if I test with Creeper World 4 Demo, the 64 bit game works. So it just the wine that may not work with some games. And I think its normal. No matter what, I just want to let anyone knowing that proton is actually working.
 
Does anyone know a way to run games? Doesn't work on FreeBSD 13 (error: only one instance game can be run ...), but on FreeBSD 12.2 it worked fine:
Bash:
sudo su steamone -c 'steam "steam://run/730"'
sudo su steamtwo -c 'steam "steam://run/730"'
?
 
Last edited:
Does anyone know a way to run two CSGO games? Doesn't work on FreeBSD 13 (error: only one instance game can be run ...), but on FreeBSD 12.2 it worked fine:
Bash:
sudo su steamone -c 'steam "steam://run/730"'
sudo su steamtwo -c 'steam "steam://run/730"'
?
I'll bite. Why are you using 'sudo su <user>'? Just use one of them.
 
I'll bite. Why are you using 'sudo su <user>'? Just use one of them.
sudo su - just comforteble.

I express great respect to those who somehow developed Steam on FreeBSD🤗
FreeBSD 13 BETA2 - VAC work perfect!!!

I spent a lot of time - on FreeBSD 12.2 VAC work so bad.

Top games!!!

 
Last edited:
It's pretty easy to detect Linuxulator or my preloaded shared objects. Steam (VAC) already sends home this information every 20 minutes or so.
 
Обнаружить Linuxulator или мои предварительно загруженные общие объекты довольно просто. Steam (VAC) уже отправляет домой эту информацию каждые 20 минут или около того.
🤔
 
Last edited:
It's not comfortable, it's just wrong, "sudo user" will do the exact same thing.

Thanks, I didn't know, I need to check
OUCH!
[admin@ ~]$ sudo steam -c steam
Steam doesn't appear to be installed for user root. Perhaps you forgot to run steam-install?
[admin@ ~]$ sudo steamdev -c steam
sudo: steamdev: command not found
[admin@ ~]$ sudo su steamdev -c steam - WORK
 
Thanks, I didn't know, I need to check
OUCH!
[admin@ ~]$ sudo steam -c steam
Steam doesn't appear to be installed for user root. Perhaps you forgot to run steam-install?
[admin@ ~]$ sudo steamdev -c steam
sudo: steamdev: command not found
[admin@ ~]$ sudo su steamdev -c steam - WORK
Because -c is a su flag, not a sudo one. The correct is sudo -u <user> <command>.
It seems you're blindly copy/paste stuff from internet to make it work, I would suggest learn sudo and su, the man isn't too extensive and will keep you from make mistakes in the future.
 
Because -c is a su flag, not a sudo one. The correct is sudo -u <user> <command>.
It seems you're blindly copy/paste stuff from internet to make it work, I would suggest learn sudo and su, the man isn't too extensive and will keep you from make mistakes in the future.
Ok
 
Hello,

I'm trying to play Steel Rats, an Unreal Engine game, and getting this error:
Code:
./SteelRats-Linux-Shipping: /lib64/libm.so.6: version `GLIBC_2.27' not found (required by ./SteelRats-Linux-Shipping)

Any idea if there is a fix?

Steel Rats is free on Steam until April 4th by the way, pick it up :)
 
Top