Solved Raspberry Pi B+ - no power to USB/Network

trev

Aspiring Daemon

Reaction score: 166
Messages: 798

Hardware: Brand new Raspberry Pi B+
Software : FreeBSD-10.1-STABLE-arm-armv6-RPI-B-20150217-r278906.img.bz2

dd'd the uncompressed img file to an 8GB micro sdCARD, inserted into RPB+, applied power - green LED goes out within 1-2 seconds. Nothing appears to be happening.

Note 1: The FreeBSD image does not play with the green ACT LED. So this wasn't as bad as it first appeared.

Note 2: No output to the HDMI monitor. This was solved by adding:

hdmi_force_hotplug=1

to the config.txt in the DOS partition.

So now it boots and ultimately reaches the login prompt. Yay! Success however is short lived. There's no power to the USB ports or, obviously, the Network port. Studying the boot messages on the screen before they disappear I see:

bcm2835: Could not set USB power state

Obviously that's the problem then, but how to solve it? Any ideas?
 
OP
OP
T

trev

Aspiring Daemon

Reaction score: 166
Messages: 798

It would appear that the FreeBSD-10.1-STABLE-arm-armv6-RPI-B-20150217-r278906.img image is BROKEN :(

In desperation I tried the FreeBSD-11.0-CURRENT-arm-armv6-RPI-B-20150217-r278908.img image and there was life at the USB and Network ports, the MS Arc wireless keyboard sprang to life and I could finally login :)
 
Top