Solved KDE doesn't seem to be installed

OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

I cannot find .xinitrc

maybe thats it
 

Mjölnir

Daemon

Reaction score: 1,495
Messages: 2,114

No no, you decided to go the xsession way, and I needed to make sure that you moved your ~/.xinitrc out of the way. Now did you sudo service hald enable, then sudo service hald start & check it's up & running with service hald status?
 

Mjölnir

Daemon

Reaction score: 1,495
Messages: 2,114

P.S.: In principle, the new Handbook is right: hald(8) will go away, it's outdated, and only needed by webcamd(8) now. So your KDE should start without hald(8), but you'll not be able to use your webcam.
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

I created .xinitrc again but deleted it again
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

hald and dbus are both up and have pids
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

there is no file ~/.xsession-errors

xorg comes up fine with 3 terms and a clock
 

Mjölnir

Daemon

Reaction score: 1,495
Messages: 2,114

Please correct exec ck-launch-session startplasma=x11 (note the "=") to be
echo "DISPLAY=:0; export DISPLAY" > ~/.xsession and then echo "exec ck-launch-session startplasma-x11" >> ~/.xsession
You can also try right now from the running X11 in the xterm: exec ck-launch-session startplasma-x11
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

I thought ~/.xsession should be in the steve directory. It is in root
 

Mjölnir

Daemon

Reaction score: 1,495
Messages: 2,114

What happened when you started KDE from inside the xterm(1)?
I thought ~/.xsession should be in the steve directory. It is in root
Can you answer Yes to all the topics I mentioned in the list on the previous page? Except for [PMAN=(]hald[/PMAN] which is not needed if you don't have a webcam or don't need it.
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

Please let's asure the following topics

  • you're logged in as user, let's say sajm, and the command id lists you're member of the video group. YES

  • please post the output of cat ~/.xsession & cat ~/.xinitrc
  • DISPLAY=:0; export DISPLAY
  • exec ck-launch-session startplasma-x11

  • Likewise, the output of cat ~/.xsession-errors Does not exist
  • bare, naked X11 starts to give you an oldschool xterm(1) or two. YES
  • you have sysrc dbus_enable & sysrc hald_enable both answer Yes, and YES
  • both services are up & running: service dbus status & service hald status show that. Both have PIDs
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

What happened when you started KDE from inside the xterm(1)?

Can you answer Yes to all the topics I mentioned in the list on the previous page? Except for [PMAN=(]hald[/PMAN] which is not needed if you don't have a webcam or don't need it.
Failed

From xorg it opened the KDE banner then exited
from the console its
DISPLAY is not set or it cannot connect to the x server
 

Mjölnir

Daemon

Reaction score: 1,495
Messages: 2,114

Do you have a file .xsession-errors in your (steve's) home directory? If yes and non-empty, please post it here; if it's long, attach (maybe cheat by giving it an allowed file extension e.g. .txt), else inline in [CODE]error log here[/CODE].
What do you mean "DISPLAY is not set or it cannot connect to the x server" I've never seen an error message that says: either this or that...
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

Do you have a file .xsession-errors in your (steve's) home directory? No it does not exist.

"DISPLAY is not set or it cannot connect to the x server"
is the error I get if I try startplasma-x11 from the console.
 

Mjölnir

Daemon

Reaction score: 1,495
Messages: 2,114

No you can't, that must be started from an already running X11. OK now I know why you get the error "DISPLAY is not set". Now again: please do as user steve on the text console: echo "exec ck-launch-session startplasma-x11" > ~/.xsession, then startx
 

Mjölnir

Daemon

Reaction score: 1,495
Messages: 2,114

P.S.: Hopefully they corrected the Handbook to include:
At runtime: do as root: mount /proc if you didn't reboot after adding /proc to fstab(5).
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

No you can't, that must be started from an already running X11. OK now I know why you get the error "DISPLAY is not set". Now again: please do as user steve on the text console: echo "exec ck-launch-session startplasma-x11" > ~/.xsession, then startx
It opened xorg with 2 terms
 

Mjölnir

Daemon

Reaction score: 1,495
Messages: 2,114

That xsession method is for xdm(1)... You don't want that.
echo "exec ck-launch-session startplasma-x11" > ~/.xinitrc then startx
and you can safely rm ~/.xsession
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

I copied .xinitrc across to /steve

When I entered startplasma-x11 it still opens the KDE banner then closes again.

I am trying to redirect the output to a file then I can post it here
 

Mjölnir

Daemon

Reaction score: 1,495
Messages: 2,114

No it's not. Do that as user steve, then it's going to be in steve's home folder.
 

Mjölnir

Daemon

Reaction score: 1,495
Messages: 2,114

I need to see error messages. You can save (as user steve) mv ~/.xinitrc ~/xinitrc-save and then startx and start KDE from inside the running X11: in the xterm(1) window, type: ck-launch-session startplasma-x11 & press <ENTER>
 
Top