Solved KDE doesn't seem to be installed

Zirias

Son of Beastie

Reaction score: 1,701
Messages: 2,870

The ~/. part in the handbook isn't there by accident*), just as well as the dot(!!) at the beginning of the actual filename.

If you don't start to actually pay at least a LITTLE bit of attention to details, you won't be happy with a FreeBSD system.

---
*) telling you, YES, this file is supposed to be in your home directory. And if you don't know yet what ~ means, you're supposed to find out instead of just ignoring it
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

When
The ~/. part in the handbook isn't there by accident*), just as well as the dot(!!) at the beginning of the actual filename.

If you don't start to actually pay at least a LITTLE bit of attention to details, you won't be happy with a FreeBSD system.

---
*) telling you, YES, this file is supposed to be in your home directory. And if you don't know yet what ~ means, you're supposed to find out instead of just ignoring it
Easy cowboy.
 

Mjölnir

Daemon

Reaction score: 1,509
Messages: 2,114

Zirias, noone comes to earth with the full set of UNIX knowlegde injected through the umbilical cord; cool down ;) - FMLU the OP tries his/her best. IIRC I also ran into a bug of sddm.conf(5), there was some bad config item I had to fix manually...

FYI you can configure sddm(1) via deskutils/plasma5-sddm-kcm. Ok now the status is you're trying to 1st get KDE started w/o sddm(1), but through your ~/.xinitrc, correct? And Xorg does start to give you an oldschool xterm, correct? Then there should be some error messages in your ~/.xsession.log (or similar filename, I'm not sure on it's exact name).
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

Here is what I have got

I tried sddm and that didnt work.
I tried the 2nd and 3rd methods and they opened xorg with starx but using startplasma-X11 (which I recall being told to use yesterday) I got an error back

$DISPLAY is not set or cannot connect to the x server.

My display is Intel VGA

I got adventurous and created

/usr/local/etc/X11/xorg.conf.d/driver-intel.conf

That didnt work and I deleted it.

Otherwise the system is stable, WiFi works and I can use xorg if i wished, just no KDE. Gnome was good but will not work with a specific application I wish to run.
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

My thinking is that because xorg worked there is not a display issue
 

Mjölnir

Daemon

Reaction score: 1,509
Messages: 2,114

No Gnome@FreeBSD is screwed up; you could try Mate or that Gnome2; but ok now let's stick to KDE 1st - I'm biased against any Gtk stuff anyway... The file is ~/.xsession-errors.

Can you please try this: start X11 and from the xterm type setenv DISPLAY=:0 setenv DISPLAY ":0" & then startplasma-x11 ck-launch-session startplasma-x11. This of course with the startplasma-x11 in your ~/.xinitrc commented out, or you mv ~/.xinitrc ~/xinitrc-save. EDIT corrected imprecise advice. I apologize for any inconvenience. /EDIT
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

The 3rd method .xsession is now active

I ran the script

setenv: Variable name must contain alphanumeric characters
 

Zirias

Son of Beastie

Reaction score: 1,701
Messages: 2,870

[FONT=monospace]Zirias[/FONT], noone comes to earth with the full set of UNIX knowlegde injected through the umbilical cord; cool down ;)
If you think this has anything to do with "UNIX knowledge", you probably guessed wrong.

What it IS about is: Not doing things manuals and people suggest, instead doing unnecessary or even detrimental things. Never exactly describing what WAS done. Just doing something "slightly similar" as described in the manual. Claiming having followed the manual.

You see this as a pattern from time to time. The learning effect here SHOULD at least be to be precise with everything (following instructions, describing your actions, etc). But if the pattern persists, holding hands will be needed for every little thing. I doubt many would be willing to do that.
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

Never exactly describing what WAS done. Just doing something "slightly similar" as described in the manual. Claiming having followed the manual.

You see this as a pattern from time to time. The learning effect here SHOULD at least be to be precise with everything (following instructions, describing your actions, etc). But if the pattern persists, holding hands will be needed for every little thing. I doubt many would be willing to do that.
I'm sure you are perfect. Well done.
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

The KDE banner page opened then closed
A report was generated.
It will take me a while to type it out as I'm on 2 laptops.

Is there anything specific you are looking for?
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

I ran the corrections and it looked the same to my eyes.

It goes on for pages and is slow
 

Mjölnir

Daemon

Reaction score: 1,509
Messages: 2,114

No. Errors. If it's short, post inline here, else upload to http://bsd.to/ or the like, e.g. pastebin. Or here as attachment (it doesn't take some file types, though). You could try this:
echo "DISPLAY=:0; export DISPLAY" > ~/.xsession and then echo "exec ck-launch-session startplasma-x11" >> ~/.xsession
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

Are those scrips from the command line or xorg?
 

Mjölnir

Daemon

Reaction score: 1,509
Messages: 2,114

Command line. From your login console, text mode. As user, not as root. We have to make sure you're not mixing up two methods: when you decide to go the xsession method, please mv ~/.xinitrc ~/xinitrc-save out of the way.
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

Command line. From your login console, text mode. As user, not as root. We have to make sure you're not mixing up two methods: when you decide to go the xsession method, please mv ~/.xinitrc ~/xinitrc-save out of the way.
Done that
 

Mjölnir

Daemon

Reaction score: 1,509
Messages: 2,114

Ya then start X. KDE should start, if it fails we'll have error messages that tell us where to investigate. Have to leave & will be back @ ~21:00 UTC. If it starts ok, then the error was that one of the various start scripts failed to set the DISPLAY environment variable correctly. Then either you or me can file in a bug report.
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

Not good

DISPLAY is not set or cannot connect to the x server
 

Mjölnir

Daemon

Reaction score: 1,509
Messages: 2,114

Please let's asure the following topics
  • you're logged in as user, let's say sajm, and the command id lists you're member of the video group.
  • please post the output of cat ~/.xsession & cat ~/.xinitrc
  • Likewise, the output of cat ~/.xsession-errors
  • bare, naked X11 starts to give you an oldschool xterm(1) or two.
  • you have sysrc dbus_enable & sysrc hald_enable both answer Yes, and
  • both services are up & running: service dbus status & service hald status show that.
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

there is no hald It was not mentioned in the Handbook
I did wonder about that

I am user steve and part of wheel and video
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

.xsession

DISPLAY=:0; export DISPLAY
exec ck-launch-session startplasma=x11
 

Mjölnir

Daemon

Reaction score: 1,509
Messages: 2,114

Excerpt from my copy of the Handbook:
[...] To install the KDE package, type:

# pkg install x11/kde5
To instead build the KDE port, use the following command. Installing the port will provide a menu for selecting which components to install. KDE is a large application and will take some time to compile, even on a fast computer.

# cd /usr/ports/x11/kde5
# make install clean
KDE requires /proc to be mounted. Add this line to /etc/fstab to mount this file system automatically during system startup:

proc /proc procfs rw 0 0
KDE uses D-Bus and HAL for a message bus and hardware abstraction. These applications are automatically installed as dependencies of KDE. Enable them in /etc/rc.conf so they will be started when the system boots:

dbus_enable="YES"
hald_enable="YES"
Since KDE Plasma 5, the KDE Display Manager, KDM is no longer developed. A possible replacement is SDDM. To install it, type:

# pkg install x11/sddm
Add this line to /etc/rc.conf: [...]
 
Top