gvfs smb does not mount

free-and-bsd

Aspiring Daemon

Reaction score: 103
Messages: 776

Hi everyone,

After some of the system upgrades (I'm using synth) SMB gfvs functionality in x11-fm/pcmanfm stopped working.

At the closer look I've noticed that devel/gvfs still depends on (and installs) net/samba-libsmbclient which the ports system now says is obsoleted:
Code:
Port:   net/samba-libsmbclient
Moved:   net/samba43
Date:   2017-03-21
Reason:   Obsolete
So after a research I discovered that the latter kept being installed from the existing packages. However, during the building process gvfs builds net/samba44 as a dependency -- so one would expect it depends on libsmbclient.so from that port.

I then removed the existing samba36-libsmbclient package from /var/synth/live_packages/All directory to make things 100% clean and then reinstalled devel/gvfs using synth -- the surest way, one would think, to make things work for sure. And it did install without complains, but now SMB related parts of it complain:
Code:
Shared object "libsmbclient.so.0" not found, required by "gvfsd-smb-browse".
So what am I supposed to do? Some people, commenting on an issue that seems related, report that just building net/samba44 and manually copying libsmbclient.so from the build directory fixes the problem. I haven't tried it myself, but obviously this is NOT they way it's supposed to work?

I'm going to run synth upgrade-system anyway, but it will take a long time and I'm afraid will NOT fix the problem, just as isolated package run of synth hasn't fixed it.
 
OP
F

free-and-bsd

Aspiring Daemon

Reaction score: 103
Messages: 776

Even more interesting than that, trying to rebuild net/samba44 fails. And the ports tree updated just yesterday...

So I'm running now synth upgrade-system to see what it will end up with.
 
OP
F

free-and-bsd

Aspiring Daemon

Reaction score: 103
Messages: 776

Upon the manual run I've noticed that a number of ports fail to build with the error message to the effect that $port is using $lib as a dependency, but it is not mentioned in the port's Makefile.
 
OP
F

free-and-bsd

Aspiring Daemon

Reaction score: 103
Messages: 776

Even more interesting than that, trying to rebuild net/samba44 fails. And the ports tree updated just yesterday...
Still fails, and given that this is now the default version of SAMBA it causes difficulties. I have switched to
net/samba45 as default and will see if that fixes the GVFS SMB access problem. In fact, net/samba45 associated
smbclient does its job all right, so its corresponding version of libsmbclient.so must work just as well...
 
OP
F

free-and-bsd

Aspiring Daemon

Reaction score: 103
Messages: 776

Still doesn't work after all the synth update, repository rebuild etc. GVFS doesn't mount SMB shares (e.g. in x11-fm/pcmanfm window), and as gvfs utilities in general are not very verbose, it is pretty difficult to determine why.
 
OP
F

free-and-bsd

Aspiring Daemon

Reaction score: 103
Messages: 776

Of course, I can still mount them using good old style, e.g.:
Code:
mount_smbfs -E utf8:cp866 -I $inet_addr -N -U anonymous //guest@myshare /mymount
but that is kind of back into the stone age :)
 
Top