Solved Grub Failing to boot FreeBSD

Farhan Khan

Active Member

Reaction score: 8
Messages: 114

I am dual-booting Linux (Ubuntu 16.04) and FreeBSD on the same laptop. I decided to use Grub2 (explanation below). Since Linux boots, I am doing this from Linux. The kernel appears to boot and scrolls through the kernel messages, but then ends with the following message:

Code:
Mountroot: waiting for device /dev/ada0s3
Mounting from ufs:/dev/ada0s3 failed with error 19.

Loader variables:
  vfs.root.mountfrom=ufs:/dev/ada0s3
  vfs.root.mountfrom.options=rw
My entry in 40_custom on Linux is as follows:

Code:
menuentry "FreeBSD" {
    insmod ufs2
    set root='(hd0,gpt3)'
    kfreebsd /boot/kernel/kernel
    kfreebsd_loadenv /boot/device.hints
    set kFreeBSD.vfs.root.mountfrom=ufs:/dev/ada0s3
    set kFreeBSD.vfs.root.mountfrom.options=rw
}
I have tried setting the mountpoint to /dev/ada0s3a, but there is no difference. I tried setting the root variable to '(hda0,gpt3,bsd1)' but Grub says "No such partition".

Any ideas?

Use-Case: I am attempting to remotely dual-boot FreeBSD and Linux. I will update which OS boots at any given time by editing Grub and then rebooting. I would use the FreeBSD Bootloader, but it does not appear to have a Linux port, so if I am in Linux, I would not be able to change the bootloader settings and boot into FreeBSD.
 
OP
OP
Farhan Khan

Farhan Khan

Active Member

Reaction score: 8
Messages: 114

Just 4 minutes after posting this, I figured it out! Really quite silly.
I was using /dev/ada0s3, it was actually /dev/ada0p3
's' vs 'p'
 
Top