Solved Claws-mail GPG Plugin Error "No such file or directory"

I quite like mail/claws-mail and its plugins. I've been diving into using PGP to sign email and done so before using Kmail, but Claws Mail requires the plugin mail/claws-mail-pgp. I've never used this before but I know I have a good key to use and its stored in .gnupg (where it should be). However, I get the following error when trying to send an inline PGP or PGP-MIME email:

Code:
Could not queue message for sending:

Signature failed: Data signing failed, No such file or directory

I tried to set "GPG_TTY=tty" but this still doesn't help. Running claws-mail in the terminal doesn't generate any related error when I try to send PGP-signed mail. Does anyone else have any clue whats going on?
 
I found the solution. Gpg-agent was pointing to a nonexistent pinentry, so I installed pinentry-qt5 and added pinentry-program /usr/local/bin/pinentry-qt5 to ~/.gnupg/gpg-agent.conf and now Claws Mail opens this and works as intended.
 
Top