[CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Skype

fernandel

Aspiring Daemon

Reaction score: 201
Messages: 816

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

free-and-bsd said:
fernandel said:
I did install Skype 4 (CentOS 6.5) and it works very well but the problem started two days ago: Skype doesn't start. Than I tried from terminal and I got:

Code:
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number
Then I deleted the Skype directory and started Skype again and it works. But after quit and start again I have the same problem as I wrote above.

My system is FreeBSD 10.0-RELEASE and I use KDE 4.12.5

Thank you.
Yes, I now have the same problem with skype: it doesn't start and moving /compat/linux/etc/fonts/conf.d/10-scale-bitmap-fonts.conf out of the way doesn't halp the matter, of course.
It works again after restarting the computer.
 

free-and-bsd

Aspiring Daemon

Reaction score: 74
Messages: 684

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

No, not here. Ports updated to the last version of each, even net-im/skype4 reinstalled -- just silently doesn't work.
Have no idea what to do now... truss shows nothing that would betray malfunction. No /home/user/Skype directory exists either... so this time don't know what to do to make it work.
 

scottro

Daemon

Reaction score: 512
Messages: 1,424

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

For what it's worth, on a fresh FreeBSD-10 install, then installing ports with portsnap fetch update, then using git to get the latest version, it's still working quite well fo for me. Installed the c6 ports, including sound as described in the README, then the skype4 port, and everything was fine. No problems such as have been mentioned, such as being unable to restart it without restarting the machine.
 

free-and-bsd

Aspiring Daemon

Reaction score: 74
Messages: 684

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

Funny thing: it works when called with sudo and doesn't as regular user!
 

scottro

Daemon

Reaction score: 512
Messages: 1,424

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

Wild stab in the dark---either sound or video has a permissions issue. Make sure you're a member of the webcamd group for video. For sound---hrrm, I don't think I ever had to do anything as far as that goes.
 

free-and-bsd

Aspiring Daemon

Reaction score: 74
Messages: 684

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

Nope, webcamd membership didn't fix it.
 

scottro

Daemon

Reaction score: 512
Messages: 1,424

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

Sorry I can't be of more help. It almost certainly sounds like a permissions issue of some sort, but I don't know what. Another suggestion if you feel like taking the time is to create a new user, and see if that user has the same problems. If so, then it's something in your profile, but I have no idea what.
 

free-and-bsd

Aspiring Daemon

Reaction score: 74
Messages: 684

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

Right, that's a good idea, thanks :)
 

volatilevoid

Active Member

Reaction score: 23
Messages: 194

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

How did you manage to get the oss option in Skype? I only have default and hdmi and with both I can't get the microphone to work (sound output works though). I can hear myself if I enable the Mic monitor in ossxmix. :q I already tried another mixer dev in the ALSA OSS plug-in config.

I'm running 10-RELEASE with an ASUS Xonar D2X sound card (with the OSSv4 port and the oss_cmi878x driver, not the sound system built-in in the kernel).

Thanks in advance!

Edit: After putting pcm.oss back in pcm-oss.conf, I can select oss as sound device. Still the microphone doesn't work ( ossrecord - | ossplay - works by the way).
 

cpm@

Moderator
Staff member
Moderator
Developer

Reaction score: 943
Messages: 2,140

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

volatilevoid said:
How did you manage to get the oss option in Skype? I only have default and hdmi and with both I can't get the microphone to work (sound output works though). I can hear myself if I enable the Mic monitor in ossxmix. :q I already tried another mixer dev in the ALSA OSS plug-in config.

I'm running 10-RELEASE with an ASUS Xonar D2X sound card (with the OSSv4 port and the oss_cmi878x driver, not the sound system built-in in the kernel).

Thanks in advance!

Edit: After putting pcm.oss back in pcm-oss.conf, I can select oss as sound device. Still the microphone doesn't work ( ossrecord - | ossplay - works by the way).
Check out: http://lists.freebsd.org/pipermail/freebsd-ports/2014-March/090788.html
 

volatilevoid

Active Member

Reaction score: 23
Messages: 194

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

cpm said:
Hello @cpm,

Thanks for the link. Unfortunately adding another OSS device to pcm-oss.conf didn't help. I checked the output of ossinfo when running ossrecord - | ossplay - and when running Skype. Both times the output looks the same. The OSS tools and Skype both use IN/OUT of dsp0 - with the difference that ossxmix shows something on the input VU meter when running the OSS tools and when running Skype it doesn't. In the past I used Skype 2.x already because I had no luck with the ALSA variant but I don't want to use the old version. It's really frustrating. :\
 
Last edited by a moderator:

cpm@

Moderator
Staff member
Moderator
Developer

Reaction score: 943
Messages: 2,140

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

According to the above message, have you tried to tweak the sections into /compat/linux/etc/asound.conf? Here you've an example.

Also change pcm.oss and ctl.oss to pcm.!default and oss.!default in /compat/linux/etc/alsa/pcm/pcm-oss.conf
 

volatilevoid

Active Member

Reaction score: 23
Messages: 194

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

cpm said:
According to the above message, have you tried to tweak the sections into /compat/linux/etc/asound.conf? Here you've an example.
Didn't help. It also seems that Skype uses the settings from /compat/linux/etc/alsa/pcm/pcm-oss.conf as changes there are recognized by Skype.
cpm said:
Also change pcm.oss and ctl.oss to pcm.!default and oss.!default in /compat/linux/etc/alsa/pcm/pcm-oss.conf
That's the default. With that I have default and hdmi as available audio devices. With the entries changed to pcm.oss and ctl.oss I see oss as an option (among others). Microphone input doesn't work with them either. It looks like the microphone is on mixer1 instead of mixer / mixer0 - changing these settings doesn't do anything. Skype just refuses to work. :OOO Is there any chance to get pulseaudio (yeah I know... :x) to work? There is no CentOS 6.5 pulseaudio port (yet)...
 

cpm@

Moderator
Staff member
Moderator
Developer

Reaction score: 943
Messages: 2,140

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

Yes, ALSA support was dropped so it will be added soon into the GH repository in order to install Skype 4.3. Unless Skype devs re-add ALSA support again.
 

volatilevoid

Active Member

Reaction score: 23
Messages: 194

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

cpm said:
Yes, ALSA support was dropped so it will be added soon into the GH repository in order to install Skype 4.3. Unless Skype devs re-add ALSA support again.
Well, that's at least something. Any other suggestions to get the current ALSA version running? As a last resort, I'd try the Linux version in a VM...

Edit: I hacked the audio/linux-f10-pulseaudio-libs port to use the C6 library. After that I couldn't get Skype to work at all; it wouldn't let me select the proper sound devices and somewhat crashed (wouldn't log in and shut down properly). I think I'll stick to the F10 ports and Skype 2.x for now. Maybe it's a problem with the audio/oss port but the on-board sound is extremely bad and finding a supported sound card which isn't > 15 years old is hard (already looked for a replacement for my ASUS Xonar D2X, but the "more interesting" cards lack recording support like the ESI Juli@ (with snd_envy24ht))... :\
 

cvnmjs

Member

Reaction score: 3
Messages: 25

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

Hello,
Many thanks for creating these ports.

I see ports/Mk/bsd.pbi.mk is removed. Does this require updating the repository? The missing file seemingly causes an error after merging the checked-out ports with the ports tree (as of this writing).

Cheers.
 

fernandel

Aspiring Daemon

Reaction score: 201
Messages: 816

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

Hi!

After the last days update of my FreeBSD 10.0-RELEASE (amd64), Skype cannot connect. In /var/log/messages I have:
Code:
kernel: linux: pid 97136 (skype): syscall inotify_init not implemented
kernel: linux: pid 97126 (skype): ioctl fd=25, cmd=0x8b01 ('.',1) is not implemented
There are no other messages. I did try to connect with my phone and it works.

I also try to rebuild linux_base-c6 and I got:
Code:
portmaster emulators/linux_base-c6

===>>> Currently installed version: linux_base-c6-6.5
===>>> Port directory: /usr/ports/emulators/linux_base-c6

===>>> Gathering distinfo list for installed ports

===>>> Launching 'make checksum' for emulators/linux_base-c6 in background
===>>> Gathering dependency list for emulators/linux_base-c6 from ports
===>>> Initial dependency check complete for emulators/linux_base-c6


===>>> Starting build for emulators/linux_base-c6 <<<===

===>>> All dependencies are up to date

===>  Cleaning for linux_base-c6-6.5
===>>> Waiting on fetch & checksum for emulators/linux_base-c6 <<<===
===>   linux_base-c6-6.5 depends on file: /usr/local/sbin/pkg - found
=> basesystem-10.0-4.el6.noarch.rpm is not in /usr/ports/emulators/linux_base-c6/distinfo.i686.
=> Either /usr/ports/emulators/linux_base-c6/distinfo.i686 is out of date, or
=> basesystem-10.0-4.el6.noarch.rpm is spelled incorrectly.
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/linux_base-c6


===>   linux_base-c6-6.5 depends on file: /usr/local/sbin/pkg - found
=> basesystem-10.0-4.el6.noarch.rpm is not in /usr/ports/emulators/linux_base-c6/distinfo.i686.
=> Either /usr/ports/emulators/linux_base-c6/distinfo.i686 is out of date, or
=> basesystem-10.0-4.el6.noarch.rpm is spelled incorrectly.
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/linux_base-c6

===>>> make build failed for emulators/linux_base-c6
===>>> Aborting update
Thank you.
 

lemle

New Member

Reaction score: 2
Messages: 5

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

Hello,

I had the same problem. I am updated to the latest (4.3) Skype version. It connects, shows the contacts, but I cannot do anything else.
 

paradox404

New Member


Messages: 3

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

lemle said:
Hello,

I had the same problem. I am updated to the latest (4.3) Skype version. It connects, shows the contacts, but I cannot do anything else.
I find a workaround. First you need to use this guide. Second thing - use dynamic distribution binary skype 4.3, remove (or move) your ~/.Skype directory and log in into your account with checked box "Automatically login...". Then killall -9 skype and run working previous version 4.2 and have a fun).
 

free-and-bsd

Aspiring Daemon

Reaction score: 74
Messages: 684

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

Hi there, @xmj :) Thank you for the great job you've been doing about this emulators/linux_base-c6 port!
I have a question. Now that quite some time has passed from the start, has your emulators/linux_base-c6 been merged into the ports tree? I was updating ports today, and the port was automatically updated by portmaster from version 6.5 to 6.5_1. So are all your other ports linked to this one being merged into the ports tree? Or should I still update using git?
 
Last edited by a moderator:

wblock@

Beastie Himself
Developer

Reaction score: 3,648
Messages: 13,850

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

The instructions are in /usr/ports/UPDATING. Always, always, always check that file before updating or installing ports.
 

free-and-bsd

Aspiring Daemon

Reaction score: 74
Messages: 684

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

wblock@ said:
The instructions are in /usr/ports/UPDATING. Always, always, always check that file before updating or installing ports.
Right :).
So the answer is YES, and I'm glad. Great job, @xmj !!
 
Last edited by a moderator:

ironudjin

Member

Reaction score: 3
Messages: 34

Re: [CFT] linux_base-c6 with CentOS 6.5, linux-c6 ports, Sky

I have a problem with new version of Skype. When I start it, it freezes and in console I see:
Code:
Assertion 'pthread_mutex_unlock(&m->mutex) == 0' failed at pulsecore/mutex-posix.c:108, function pa_mutex_unlock(). Aborting
Should I create bug for it or it's known issue?

UPDATE: Also I've found following in /var/log/messages:
Code:
Oct  1 23:36:54 IRON kernel: linux: pid 66794 (skype): ioctl fd=41, cmd=0x8b01 ('',1) is not implemented
Oct  1 23:36:58 IRON kernel: linux: pid 66794 (skype): linux_sys_futex: op FUTEX_WAIT_REQUEUE_PI not implemented
Oct  1 23:36:58 IRON kernel: 
Oct  1 23:36:58 IRON kernel: linux: pid 66838 (skype): linux_sys_futex: op LINUX_FUTEX_CMP_REQUEUE_PI not implemented
Oct  1 23:36:58 IRON kernel: 
Oct  1 23:36:58 IRON kernel: linux: pid 66794 (skype): linux_sys_futex: op LINUX_FUTEX_UNLOCK_PI not implemented
Oct  1 23:36:58 IRON kernel: 
Oct  1 23:36:58 IRON kernel: linux: pid 66838 (skype): linux_sys_futex: op LINUX_FUTEX_LOCK_PI not implemented
For now I'm rolled back to previous veriosn of Skype.

P.S: FreeBSD 10.1-BETA3 r272252.
 
Top