MrRichBOB

New Member


Messages: 3

I would like to apologise in advance, if this is straight-forward, and/or answered elsewhere on the forum--I have tried for the past few hours to look hard before I dared ask any questions, and I combed through the WiFi section of the Handbook, etc.

Basically, in short, I am using an EliteBook 6930p, which has troubles with all its drivers even on Linux, and no one has even managed to get the fingerprint scanner working there. It took me about a week before I found a solution for getting the WiFi card in it working, on OpenSUSE. So, I looked around, and I found this post here: CLICK ME. So, I followed along, trying to diagnose similar issues, and ultimately compiled my first kernel--that was both fun and scary at the same time. Thankfully, after doing that, the OS can finally see my WiFi card and can even scan around (barely better than it could on Linux--not very well.)

Here are my diagnostics, after running the custom kernel:

First, I tried this command:
$ sudo wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf

And Got this out:
Code:
Successfully initialized wpa_supplicant
wlan0: Trying to associate with e8:fc:af:fd:cc:9e (SSID='NETGEAR78' freq=5765 MHz)
wlan0: Authentication with e8:fc:af:fd:cc:9e timed out.
wlan0: CTRL-EVENT-DISCONNECTED bssid=e8:fc:af:fd:cc:9e reason=3 locally_generated=1
- - - -
Secondly, I checked dmesg and it gave me this out:

Code:
Error reading triso2g from NVRAM: 0
bwn0: ucode fw: ucode16_mimo
bwn0: firmware version (rev 666 patch 2 date 0xb217 time 0x9e7)
bwn0: ucode fw: ucode16_mimo
bwn0: firmware version (rev 666 patch 2 date 0xb217 time 0x9e7)

... over and over again.

So, Imma take it the the firmware is either incompatible with the driver, or it is not actually a low-power card, like I thought it was. (I drew that conclusion based off of dmesg spitting out at me that the kernel wasn't PHY, whatever, compatible before I actually made my custom kernel.

- - - -

Lastly, I have attached any relevant files I actually touched. The custom kernel I have attached as WIFI.txt, and the only things I actually messed with in it were adding lines 298-301, which simply say:

Code:
# Options for BCM4322
option BWN_DEBUG
option BWN_GPL_PHY

I wanted to uncomment line 289, and I really feel like I should have, but I opted not to, as that seemed to be the purpose of modifying /boot/loader.conf

- - - -

THANK ANYONE IN ADVANCE!
 

Attachments

  • rc.conf
    501 bytes · Views: 121
  • loader.conf
    144 bytes · Views: 124
  • WIFI.txt
    14.2 KB · Views: 138
OP
MrRichBOB

MrRichBOB

New Member


Messages: 3

If you read bwn(4) you'll see that you need to install the firmware; net/bwn-firmware-kmod. Did you install that?

That is a lovely idea, I didn't think of that--I did it before making the custom kernel, but didn't think to do so afterward.

I shall do that first thing tomorrow.

EDIT:

So yeah, I cd'd to /usr/ports/net/bwn-firmware-kmod and did $ sudo make clean and $ sudo make reinstall, and still no luck, literally doing the same exact thing.
 
Top