vlc subtitle error

pouria.mzt

Member

Thanks: 1
Messages: 28

#1
hi
I am having problems with running multimedia/vlc on FreeBSD 10.2:
add subtitle to VLC this error:
Code:
Codec not supported:
VLC could not decode the format "ssa " (SubStation Alpha subtitles)
My subtitle language Persian
 
Last edited by a moderator:
OP
OP
pouria.mzt

pouria.mzt

Member

Thanks: 1
Messages: 28

#2
error is:
Code:
VLC can't recognize the input's format:

The format of 'file:///media/PMZT16/%5BAnimWorld%5D%20%5BHorribleSubs%5D%20Servant%20x%20Service%20-%2013%20%5B720p%5D.ass' cannot be detected. Have a look at the log for details.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,416
Messages: 27,728

#3
Have you tried other files? It may just be a corrupt file.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,416
Messages: 27,728

#4
Oh, did you enable support for ASS/SSA? It's off by default:
Code:
ASS=off: ASS/SSA subtitle rendering
 

scottro

Daemon

Thanks: 426
Messages: 1,259

#6
You may need proper fonts. This can be tricky, I know that with Japanese in subtitles, even if I've had fonts installed, the subs might not show up. I generally use mplayer or mpv and sometimes have to put an option for the subtitle font (more with mplayer than mpv, which seems to do a better job of figuring it out automatically.)

I'm not sure how one would do that with vlc, but try putting in a few different fonts in the language and see if you have better luck. (Again, even if you already have some installed.)
 

giorgiob

Member


Messages: 28

#7
Oh, did you enable support for ASS/SSA? It's off by default:
Code:
ASS=off: ASS/SSA subtitle rendering
I am having the same problem and would like to try this out. I cannot find any hints about this option under Tools / Preferences. Where can I find it?
 

cpm@

Moderator
Staff member
Moderator
Developer

Thanks: 924
Messages: 2,127

#8
I am having the same problem and would like to try this out. I cannot find any hints about this option under Tools / Preferences. Where can I find it?
Code:
% make -C /usr/ports/multimedia/vlc showconfig | grep ASS
 ASS=on: ASS/SSA subtitle rendering
 

scottro

Daemon

Thanks: 426
Messages: 1,259

#9
If you cd into /usr/ports/multimedia/vlc and type make config (as root or with root privilege) you will see the option. You can choose it there. I think you'll have to reinstall vlc using ports though, to get it working if it's not already turned on.
 
Top