Video chat

Edit: Maybe, I'm out of touch with current tech:confused: I guess the in-browser video chat systems do exist. But, I don't want to test the tech in flirtymania to see if it offers 2-way video with sound. :D

See sipml5 and jssip, WebRTC, WebSocket.

But I want to try first the traditional form.

FreeBSD audio seems to be not so simple to deal with.
That is what my /dev looks like too.
cat /dev/sndstat
Installed devices:
pcm0: <IDT 92HD90BXX (Analog 2.0+HP/2.0)> (play/rec) default
pcm1: <IDT 92HD90BXX (Analog)> (play/rec)
pcm2: <Intel Cougar Point (HDMI/DP 8ch)> (play)
pcm3: <Intel Cougar Point (HDMI/DP 8ch)> (play)
pcm4: <Intel Cougar Point (HDMI/DP 8ch)> (play)
No devices installed from userspace.

# ls /dev/pcm*
ls: No match.

# ls /dev/dsp*
/dev/dsp0.0 /dev/dsp1.0 /dev/dsp2.0 /dev/dsp3.0 /dev/dsp4.0
From the above manual:
Default sound card for systems with multiple sound cards. When
using devfs(5), the default device for /dev/dsp. Equivalent to a
symlink from /dev/dsp to /dev/dsp${hw.snd.default_unit}.

/dev/dsp is like a symlink
I did not know that symlinks does not appear with "ls *" and never tried it.

I got now iptel to work with OpenBSD pjsua without doing anything new. The problem lied probably at iptel.

Now I have to get it working with FreeBSD. But how?!

I get:

You have 1 active call
Current call id=0 to [CONFIRMED]

But no audio, although I should hear music according to the above. And not only with pjsua I get no audio.
If someone wants to help testing and get it working, at best make a SIP account at (running kamailio that I
also installed). Let us say you has username NNNNNN and pasword pass-of-NNNNNN.

Then you can put the following in a file to start pjsua with configuration options:

pjsua \
--no-tcp \ \ \
--realm=* \
--username=NNNNNN \

Then you run it. It works with OpenBSD. For calling you press m<ret> and then something like:
for example for testing:

With the first you hear music, with the second you hear whatever you say. To hang up you press: h<ret>

Let us see if someone get working this piece of software running.
I see that pjSIP uses audio/portaudio maybe you need this patch that @tobik worked up:

I have a full week ahead of me and cannot help much.
net/pjsip does not have audio enabled by default

Yes, I have it enabled, I tried with both, SDL enabled and disabled, without success.

It seems /dev/dsp cannot be used for both directions?

UPDATE: I just compiled it with audio disabled, and I continue to hear music, but echo does not work.

# cat /dev/sndstat
Installed devices:
pcm0: <ATI R6xx (HDMI)> (play)
pcm1: <Realtek ALC892 (Rear Analog)> (play/rec) default
pcm2: <Realtek ALC892 (Front Analog)> (play/rec)
pcm3: <Realtek ALC892 (Rear Digital)> (play)
pcm4: <Realtek ALC892 (Onboard Digital)> (play)
No devices installed from userspace.