USB Ethernet adapter Setup Issues

KEOU CHAO

New Member

Reaction score: 1
Messages: 2

Hi,

I am building firewall using pfsense 2.4.0-BETA (11.0-RELEASE-p11) on Dell E6330, with Microsoft USB Ethernet adapter. Even though it is not on the compatible HW list, I am able to bring it up as LAN interface, and the firewall works properly with multiples PCs on the LAN. However, the throughput was slow. The same USB Ethernet adapter was able to reach gigabit throughput under Debian 9.

Is there any driver configuration needed to properly setup this USB Ethernet device ? or there is a limitation in the current driver ?

Thanks for any directions.

DETAILS -

Using iperf3 to test the throughput over the USB Ethernet interface -

Download -
Code:
[  5] local 192.168.60.1 port 37618 connected to 192.168.60.129 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  11.0 MBytes  92.3 Mbits/sec    0    177 KBytes       
[  5]   1.00-2.00   sec  11.0 MBytes  92.1 Mbits/sec    0    251 KBytes       
[  5]   2.00-3.00   sec  11.0 MBytes  91.9 Mbits/sec    0    308 KBytes       
[  5]   3.00-4.00   sec  10.9 MBytes  91.4 Mbits/sec    0    355 KBytes       
[  5]   4.00-5.00   sec  10.9 MBytes  91.6 Mbits/sec    0    398 KBytes       
[  5]   5.00-6.00   sec  10.9 MBytes  91.6 Mbits/sec    0    435 KBytes       
[  5]   6.00-7.00   sec  10.9 MBytes  91.3 Mbits/sec    0    470 KBytes       
[  5]   7.00-8.00   sec  10.9 MBytes  91.5 Mbits/sec    0    503 KBytes       
[  5]   8.00-9.00   sec  10.9 MBytes  91.6 Mbits/sec    0    533 KBytes       
[  5]   9.00-10.00  sec  10.9 MBytes  91.5 Mbits/sec    0    562 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   109 MBytes  91.7 Mbits/sec    0             sender
[  5]   0.00-10.00  sec   109 MBytes  91.2 Mbits/sec                  receiver
Upload -
Code:
[  4] local 192.168.60.129 port 38370 connected to 192.168.60.1 port 5201
[ ID] Interval           Transfer     Bandwidth       Retr  Cwnd
[  4]   0.00-1.00   sec  5.63 MBytes  47.3 Mbits/sec  198   25.5 KBytes
[  4]   1.00-2.00   sec  4.56 MBytes  38.2 Mbits/sec  161   33.9 KBytes
[  4]   2.00-3.00   sec  5.20 MBytes  43.6 Mbits/sec  222   24.0 KBytes
[  4]   3.00-4.00   sec  5.38 MBytes  45.1 Mbits/sec  191   29.7 KBytes
[  4]   4.00-5.00   sec  4.37 MBytes  36.7 Mbits/sec  166   31.1 KBytes
[  4]   5.00-6.00   sec  3.19 MBytes  26.8 Mbits/sec  147   25.5 KBytes
[  4]   6.00-7.00   sec  5.38 MBytes  45.1 Mbits/sec  193   29.7 KBytes
[  4]   7.00-8.00   sec  5.47 MBytes  45.9 Mbits/sec  200   26.9 KBytes
[  4]   8.00-9.00   sec  5.47 MBytes  45.9 Mbits/sec  198   24.0 KBytes
[  4]   9.00-10.00  sec  5.38 MBytes  45.1 Mbits/sec  197   31.1 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-10.00  sec  50.0 MBytes  42.0 Mbits/sec  1873             sender
[  4]   0.00-10.00  sec  49.9 MBytes  41.8 Mbits/sec                  receiver
Device Information from
Code:
# usbconfig -d ugen0.4 dump_device_desc
ugen0.4: <Ethernet Adapter Microsoft> at usbus0, cfg=1 md=HOST spd=SUPER (5.0Gbps) pwr=ON (64mA)

  bLength = 0x0012
  bDescriptorType = 0x0001
  bcdUSB = 0x0300
  bDeviceClass = 0x0000  <Probed by interface class>
  bDeviceSubClass = 0x0000
  bDeviceProtocol = 0x0000
  bMaxPacketSize0 = 0x0009
  idVendor = 0x045e
  idProduct = 0x07c6
  bcdDevice = 0x3000
  iManufacturer = 0x0001  <Microsoft>
  iProduct = 0x0002  <Ethernet Adapter>
  iSerialNumber = 0x0006  <02BDFF000000>
  bNumConfigurations = 0x0002
I bring up the ethernet interface via
usbconfig -d ugen0.4 set_config 1

The output from ifconfig
Code:
ue0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
   ether 58:82:a8:8d:96:fc
   hwaddr 58:82:a8:8d:96:fc
   inet6 fe80::5a82:a8ff:fe8d:96fc%ue0 prefixlen 64 scopeid 0x7
   inet 192.168.60.1 netmask 0xffffff00 broadcast 192.168.60.255
   nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
 
Top