Unable to get Desktop environment running properly

Pardub

Member

Reaction score: 5
Messages: 22

Hi,

I tried for many days to install a desktop environment on FreeBsd but it's unsuccessful on a laptop.

This is a Dell 7240 with a i5-4300U ( Haswell serie) with a UK keyboard.

I have 2 ssd's, both booting on UEFI: One with W10 installed and the other with FreeBSD. There is no dual boot, I just change the boot order in the BIOS to boot from the ssd with FreeBSD installed.

I installed drm-fbsd12.0-kmod from the ports as described in the following link as I believed the issue might be related to what I experiment:

Additional install: install: pkg install kde5 plasma5-plasma sddm xorg sudo

The user has been added to the group wheel,video and sudo.

The following line has been added to /etc/fstab:
Code:
proc /proc procfs rw 0 0
sysrc kld_list+="/boot/modules/i915kms.ko" has been added then

kldload /boot/modules/i915kms.ko (I noticed the display was flickering and the fonts became smaller after this last action.)


/etc/rc.conf has been edited by adding:
Code:
dbus_enable="YES"
hald_enable="YES"
sddm_enable="YES"


then reboot and the Plasma desktop appears.

Once I entered the password, the screen freeze and I'm unable to perform a single action.

I had to proceed a hard reboot and login with the single user mode to comment out the sddm_enable="YES" in the /etc/rc.conf.
While being logged in the single user mode, the keyboard loaded was the US keyboard,not the UK I selected during the bsdinstall.

I don't know if this is important but I noticed this is not the user name that appears on the desktop but "User &" instead of the real user name. (I made a lot of fresh installation and I noticed the same behaviour).

Also, after the reboot,I noticed at the end of the DMESG a long list of error "hdac:unexpected unsolicited response from address 0:0000000~" that weren't there after the initial installation.

I added to the links below some files configuration:

dmesg log https://dpaste.com/5AN9NWA4N

fstab log https://dpaste.com/29C7TEAW5

kldstat log https://dpaste.com/FLTW3BV7M

pciconf https://dpaste.com/H5MY4XALN

uname https://dpaste.com/9YC5H55Z2

xorg log https://dpaste.com/248Z25B4A

rc.conf log https://dpaste.com/8YQJGRHGW

How can I get the desktop environment fully functional ?

Thank you for your help.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,665
Messages: 36,409

While being logged in the single user mode, the keyboard loaded was the US keyboard,not the UK I selected during the bsdinstall.
In single user mode nothing is loaded, that includes any keyboard settings. So it defaults to the US layout.

,I noticed at the end of the DMESG a long list of error "hdac:unexpected unsolicited response from address 0:0000000~" that weren't there after the initial installation.
These are probably related to the audio of the video card. While problematic they shouldn't prevent the desktop from working.

Your logs all look fine (apart from the snd_hda(4) messages). If I recall correctly the first time you login and start a KDE session it takes a while for things to get set up. Be a little patient and give it some time.
 
OP
P

Pardub

Member

Reaction score: 5
Messages: 22

Thank you for that answer.I understand now why I got the US keyboard in single user mode.
Have you any idea why I cannot get a functional desktop environment ?
 
OP
P

Pardub

Member

Reaction score: 5
Messages: 22

Sorry about my previous post,I didn't see initially the second part of your answer....
I'll leave the laptop running for a while the KDE session is loaded and update the post later.
Thank you
 

Alexander88207

Well-Known Member

Reaction score: 246
Messages: 443

Sddm is now selecting wayland as default but its not working for me. Maybe you have the same case?
 
OP
P

Pardub

Member

Reaction score: 5
Messages: 22

You are correct.
By default,"Wayland" is selected by default.
if I switch to Plasma on the bottom, the session is starting properly now.
Thank you for the insight!
 
Top