Solved [slim|xfce] login "loop" issue

oinky

New Member


Messages: 4

Hello there,

I have just installed FreeBSD 11 on my old Acer Extensa 5220 Notebook from DVD. After setting up Xorg, xfce and slim, the login manager shows up, asking me for user and password. Up to here, everything works as expected, but..:
No matter if I try to login as root or with my normal UID: after providing my credentials, I am asked again to enter my UID and password. There's no error message as well (like "wrong password" etc, even though if I type "nonsense").

Did I missed something while setting up the system?

The following steps have been done after basic FreeBSD installation:

pkg install nano xorg xfce slim sudo


Afterwards, I've added the following lines to /etc/rc.conf:
Code:
   dbus_enable="YES"
   hald_enable="YES"
   slim_enable="YES"
The .xinitrc-File has been created with the following content.
Code:
   exec startxfce4
.. and copied to /home/oinky/

In /usr/local/etc/sudoers I've added the following user privilege specification:
Code:
   oinky ALL=(ALL) ALL
The command Xorg -configure gave the following output:
Code:
(EE) Server terminated with error (2). closig log file.
Nevertheless*, I copied the xorg.conf.new-File to /usr/local/etc/X11/xorg.conf.d/xorg.conf

After rebooting the system, the login-manager appears but there's no login possible.

* I just checked a tutorial video on youtube. This guy is getting the Xorg-Error as well, however - after rebooting the system he is able to login..

Any ideas on this issue?

Thanks in advance.
 

Minbari

Well-Known Member

Reaction score: 184
Messages: 358

You can configure the sessiondir directive in the SLiM configuration file to define the path to desktop entries, usually /usr/local/share/xsessions. Use exec $1 instead of a particular window manager’s executable name in your .xinitrc to run the command from SLiM passed in as an argument.

/usr/local/etc/slim.conf
Code:
sessiondir /usr/local/share/xsessions/
Code:
echo 'slim_enable="YES"' >> /etc/rc.conf
service slim start

~/.xinitrc

Code:
exec $1
You need to create a desktop entry for your window manager of choice if the port maintainer doesn’t ship one. Here’s an example: /usr/local/share/xsessions/i3.desktop

Code:
[LIST=1]
[*][Desktop Entry]
[*]Encoding=UTF-8
[*]Name=i3 Window Manager

[*]Exec=/usr/local/bin/i3
[*]Comment=This session logs you into i3 Window Manger

[*]Type=Application
[/LIST]
 
OP
OP
O

oinky

New Member


Messages: 4

Hi mrclksr,
hi Minbari,

Thank you both for your fast reply.

/usr/local/etc/slim.conf looks as following:
Code:
[...]
login_cmd       exec /bin/sh - ~/.xinitrc %session
[...]
sessiondir       /usr/local/share/xsessions
[...]
/usr/local/share/xsessions/xfce.desktop (which is the only file in this directory):
Code:
[Desktop Entry]
Version=1.0
Name=Xfce Session
[ several translations of the Name ]
Comment=Use this session to run Xfce as your desktop environment
[ several translations of the comment ]
Exec=startxfce4
Icon=
Type=Application
DesktopNames=XFCE
Currently I only can boot into single user shell as the multi user will end up in the looped situation mentioned in #0.
 
OP
OP
O

oinky

New Member


Messages: 4

Could you post your /var/log/slim.log, please?
...oh my god.. this is so embarrassing:
Code:
slim: waiting for X server to begin accepting connections.
slim: pam_authentication(): authentication error
slim: pam_authentication(): authentication error

slim: waiting for X server to shut down
According to this message I just checked the keyboard layout at the login manager which seems to be US by default, instead of DE.
Keeping this in mind I am able to login. So there was actually no issue with the login manager / xfce itself.

The keymap in /etc/rc.conf is defined as german.cp850.kbd.
The layout actually worked before I started installing / configuring Xorg / xfce / slim.

Thanks a lot for help :)
 

mrclksr

Active Member

Reaction score: 122
Messages: 153

Delete your /usr/local/etc/X11/xorg.conf or move it somewhere else.

Create /usr/local/etc/X11/xorg.conf.d/keyboard-de-nodeadkeys.conf with the following content:

Code:
Section "InputClass"
   Identifier    "KeyboardDefaults"
    Driver        "keyboard"
    MatchIsKeyboard    "on"
    Option        "XkbLayout" "de"
    Option        "XkbVariant" "nodeadkeys"
EndSection
After restarting slim, the correct keyboard layout should be set.

Edit: Corrected.
 
Top