Solved SATA drives with internal RAID capabilities?

Atsuri

Active Member

Reaction score: 23
Messages: 137

Dear FreeBSD users,

Recently, I was working towards setting up a new zpool at work with freshly salvaged Western Digital and Seagate SATA hard drives (all 500 GB). However, FreeBSD 11.0-RC2 detects the drives as elements of bigger raid arrays (r0 and r1) in the arrangement 2x 500 GB + 2x 500 GB. The drives are connected to 4 separate SATA ports on the motherboard via a rather old multi-drive slot (server type PC housing). The motherboard is http://www.asrock.com/mb/Intel/G41M-VS3/ and as far as I read, it doesn't have any RAID-like controllers.

GNU/Linux distributions like Fedora don't detect the drives at all. On FreeBSD 11.0-RC2 I can format the drives, but I cannot destroy the r0 and r1 arrays. In addition, some RAID-capable microcode gets loaded from or for those drives.

Any ideas how do I get about this? Did anyone ever encounter something similarly odd?
Lastly, would it be fine to just ignore the r0 and r1 arrays, format whatever drive space to ZFS and create a zpool out of this?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,292
Messages: 29,742

Drives don't have internal RAID capabilities. What the system is probably detecting is simply the 'old' RAID card's metadata that's stored on the disk.
 
OP
OP
A

Atsuri

Active Member

Reaction score: 23
Messages: 137

Drives don't have internal RAID capabilities. What the system is probably detecting is simply the 'old' RAID card's metadata that's stored on the disk.
Do you think doing a standard dd if=/dev/zero of=/r0 would remove that metadata? It might be in the MBR section of the drives, right?
 

usdmatt

Daemon

Reaction score: 514
Messages: 1,382

It may be useful to see dmesg and gpart show /dev/{disk} output so we can see what the FreeBSD system is detecting. It sounds like the disks were part of a previous RAID array and the RAID configuration is stored on the disks.

Personally I would want to try and clear the old RAID data off before using them as it could easily cause issues. The first thing I would try is to wipe the first/last few MB of the disks as that's most likely where config is stored
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,292
Messages: 29,742

Do you think doing a standard dd if=/dev/zero of=/r0 would remove that metadata?
That should remove it, yes.

It might be in the MBR section of the drives, right?
No, there's no room for it there. It's somewhere on disk and it depends on the type of card where exactly.
 

usdmatt

Daemon

Reaction score: 514
Messages: 1,382

I would start with
Code:
dd if=/dev/zero of=/dev/adaX bs=1M count=5
Writing to the whole disk can take a long time and is rarely necessary. Also if the RAID array is showing up as an r0 device, I'd be surprised if writing to that will overwrite its own metadata. You're better off wiping the raw disk devices.

If the array still shows up after clearing the beginning of the disks then metadata could be at the end, which can be cleared with a slightly different dd command.
 
OP
OP
A

Atsuri

Active Member

Reaction score: 23
Messages: 137

Thank you kindly for all of your responses. I shall try out usdmatt's dd suggestion and post back with an update :).
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,292
Messages: 29,742

Also if the RAID array is showing up as an r0 device, I'd be surprised if writing to that will overwrite its own metadata. You're better off wiping the raw disk devices.
Good catch, I missed that.

Yes, if you're going to wipe the drives use the drive devices themselves not the array device.
 
OP
OP
A

Atsuri

Active Member

Reaction score: 23
Messages: 137

I would start with
Code:
dd if=/dev/zero of=/dev/adaX bs=1M count=5
Writing to the whole disk can take a long time and is rarely necessary. Also if the RAID array is showing up as an r0 device, I'd be surprised if writing to that will overwrite its own metadata. You're better off wiping the raw disk devices.

If the array still shows up after clearing the beginning of the disks then metadata could be at the end, which can be cleared with a slightly different dd command.
Good catch, I missed that.

Yes, if you're going to wipe the drives use the drive devices themselves not the array device.
Again, thank you kindly everyone for help :). In the end it was sufficient to zero the drives (not the arrays) as usdmatt suggested. The leftover metadata was within the initial sectors so cleaning up the first ~10 GB was enough. Afterwards the hard drives behaved as expected and could be used for my own arrays. Cheers!
 
Top