Solved Preventing DVD detection at boot

nmontmarquette

New Member

Reaction score: 1
Messages: 3

How can I modify FreeBSD boot/startup process so it doesn't check or try detecting a CD-ROM/DVD?

I am using `FreeBSD 10.3-RELEASE-p3` on a 2004 `Toshiba` laptop as a pfSense box. The laptop has what seems to be an incompatible (or most likely just too old) DVD player. Some I/O identification command at startup keeps on failing thus keeping the boot process in an endless loop.

I figured out, I could unplug the DVD player from the laptop. That allows me to boot in pfSense (FreeBSD).

The problem is that the BIOS stalls for a few minutes on startup and then pops a warning dialog requiring someone to click a `Continue Boot` button thus preventing any unattended reboot or maintenance.

Unfortunately, the laptop uses a `Phoenix BIOS` which has very few options none of which is about disabling the DVD player or continue-on-error.
 

ljboiler

Well-Known Member

Reaction score: 114
Messages: 371

Is there some “boot order” setting in the BIOS that’s making it look for the DVD before trying the hard drive? If so, maybe that can be changed.
 
OP
OP
N

nmontmarquette

New Member

Reaction score: 1
Messages: 3

Is there some “boot order” setting in the BIOS that’s making it look for the DVD before trying the hard drive? If so, maybe that can be changed.
No, sorry, this is not relevant, the BIOS is trying know-hardcoded-expected devices. The missing or defective DVD player would cause the same behaviour regardless of the order. I don't think there is anything I can do with the very limited BIOS. The only solution is really in FreeBSD boot parameters hence the very specific question.
 

Snurg

Aspiring Daemon

Reaction score: 336
Messages: 793

The information "14-year-old Toshiba laptop" is not very meaningful, except maybe for experts on legacy Toshiba laptops.

Please post a screen photo how it looks what is happening.
Maybe people then can see what actual kind of hardware it is and give advice.
 
OP
OP
N

nmontmarquette

New Member

Reaction score: 1
Messages: 3

Sorry all not making it clearer. I did though my question was straight forward enough. Through a lot of reading I ended up finding THE answer I was looking for. As expected the answer was not specific to either pfSense or my laptop.

Solution: device hints

in my case, I needed to add the following line in the /boot/loader.conf file:
Code:
hint.ata.1.disabled=1
See stage 3 boot
 
Top