Notebook / Laptop compatibility list

Juha Nurmela

Well-Known Member

Thanks: 121
Messages: 401

HP ProBook 6550b
FreeBSD 10.1-RELEASE-p10
  • happy camper if you get it for free.
  • some incompatibilites. If you are buying, select another
Working
  • SSD disk
  • graphics (intel)
  • keyboard
  • mouse
  • USB
  • ethernet
  • bluetooth (btpand and bt speakers tested)
  • SD-card
  • sound
  • 3G & GPS (Qualcomm Gobi 2000, lots of googling required)
Not working
  • serial port (does not show up)
  • wlan (sort of works with NDIS)
Untested
  • dock (parallel port shows up, no connector)
  • DisplayPort video
  • telephone modem
  • Fingerprint scanner
  • Facefacing camera
  • Firewire (interface shows up, everything looks good, no devices to test with)
Problems

Installation required flipping between BIOS IDE/AHCI setting. After installation, AHCI has been okay.

HP WMI does not fully work.

AC-line disconnect/connect not visible to software. LCD backlight adjustment requires intel_backlight package. 10.3-RELEASE fixed these.

Hard to locate the required firmware for the builtin Qualcomm 3G and wlan NDIS.

I wanted to wire external headphones+mic and builtin speakers+mikes separately to different /dev/pcm devices, but failed to configure snd_hda quite like that. No biggie, I'm happy

In 900kB attachment
Code:
devinfo -v
pciconf -lvb
dmesg
cat /dev/sndstat
ifconfig
usbconfig show_ifdrv
acpidump -dt
Juha

Update:

Serial port:
It appears, after some ugly coaxing. /dev/cuau0 eats bytes at the expected speed for 9600 baud, generates expected amount of interrupts while doing so and characters come back when txd and rxd pins are shorted. Yay.

sysutils/acpi_call is needed, and uart(4) must be a module, which is NOT loaded until the following is executed (after every boot)
Code:
#!/bin/sh

kldload acpi_call
acpi_call -v -p \\_SB.PCI0.LPCB.SIO.COM1._SRS -b 4701F803F8030108221000
acpi_call -v -p \\_SB.PCI0.LPCB.SIO.COM1.COMP._ON
kldunload acpi_call

kldload uart
uart0: <16550 or compatible> at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0

The hex data means 0x3f8 (F803, twice) and irq4 (last 10, it's a bitmask).
Dunno what the COMP._ON call does, but the port identifies as a non-std 8250 without it. Maybe it's IrDA-specific.

The related part of DSDT is (2 and 9 index into the hexstring)
Code:
Method (_SRS, 1, NotSerialized)  // _SRS: Set Resource Settings
  {
  CreateWordField (Arg0, 0x02, MIN1)
  CreateWordField (Arg0, 0x09, IRQ0)

Keyboard leds and audio PA:
sysctl dev.hdaa.0.gpio_config="3=clear" or "3=set" flip the speaker-mute-led (near Backspace-key) between orange and cyan. "0=clear/set" bit controls the loudspeaker amplifier (defaults to on). Other bits are not connected.

The fan stopped.
A sensor might have failed, as thermal zone CPUZ shows nothing. Following sets a constant fan speed. 0 off, 60 slow, 100 hair dryer.
Code:
/usr/local/sbin/acpi_call -p \\_SB.PCI0.LPCB.EC0.SFSD -i ${1-60}
 

Attachments

Last edited:

goshanecr

Active Member

Thanks: 9
Messages: 142

Laptop: ASUS G751JM-T7080H (Full specifications)
OS: 11.0-CURRENT #0 r292344: Thu Dec 17 20:56:14
-----------------------------------------------------
CPU: Core i7-4710HQ 2.5ГГц (4 core, 6Мб Cache)
RAM: 8GB DDR3L SDRAM 1600МГц (max 32Gb, 4 slot)
Video: GeForce GTX860M 2GB
HDD: 1TB
Display: 17.3"/1920x1080 IPS

Not working:
-----------------------------------------------------
  • Broadcom BCM4352 WiFi b/g/n/ac
uname -a
Code:
FreeBSD ASUS-BSD 11.0-CURRENT FreeBSD 11.0-CURRENT #0 r292344: Thu Dec 17 20:56:14 YEKT 2015  root@ASUS-BSD:/usr/obj/usr/src/sys/KERNEL  amd64
Attached file has info:
------------------------------------------------------
  • uname -a
  • lspci -v
  • devinfo -v
  • dmesg
  • cat /dev/sndstat
  • ifconfig
  • usbconfig show_ifdrv
  • acpidump -dt
 

Attachments

Free.vesh

New Member

Thanks: 1
Messages: 19

Hi, all.
Recently, I tested HP ProBook G2, HP Evny 13, Lenovo YOGA 900 and MSI GS30.
Because of the Intel latest wifi card, I installed FreeBSD 11-current.
Finally, I liked the combination of HP ProBook G2 and FreeBSD 11-current.
My simple results with vesa driver-based Xorg (sorry for the missed hardware information):
A)HP ProBook G2 (i5-5200). Memory card reader, bluetooth and finger reader did not work. The others worked fine (including power suspend and resume).
B)HP Evny 13 (i5-6200). Memory card reader and bluetooth did not work. The others worked fine (power resume failed).
C)Lenovo YOGA 900 (i7-6500). Since the touchpad failed, I gave up this laptop.
D)MSI GS30 (i7-4870). Memory card reader did not work. ACPI info was incorrect. Touchpad was ELAN (not supported well). The others worked fine (power resume failed).
 

rdeiriar

Member

Thanks: 11
Messages: 25

Hi, everybody
Thinkpad T420s
Intel(R) Core(TM) i5-2520M
10.3-RELEASE
12 GB Ram (1x4GB DDR3-1333, 1x8GB DDR3-1333)
128 Mb SSD
1600x900 14'

0. Summary

I couldn't be happier with this 'bargain-buy' that i got (used) last week. The hardware works really well with FreeBSD, it has an excellent keyboard, it's light without being flimsy, has an mSata port for a second SSD and 2 DIMM slots. Recommended!

1. Installation

Bios state: Default
Source: FreeBSD-10.3-RELEASE-amd64-uefi-memstick.img
Filesystem: ZFS
The installation procedure was completely painless

2. What works

Tested:
Sleep/Resume (See remarks)
Intel Graphics
- Screen brightness controls
Touchpad
Trackpoint
USB
Gigabit Ethernet
Wireless (Centrino Ultimate-N 6300)
Fingerprint reader
Audio
- Volume controls​

Unknown (haven't used yet)
Webcam
Bluetooth​

3. Remarks

Trying to gain a little bit more battery life (2:30 with the current configuration), i added

hw.acpi.cpu.cx_lowest=Cmax


To /etc/sysctl.conf

coretemp and acpi_ibm are both useful and work well, the later also works well with bsdfan https://github.com/darklightclod/bsdfan , a fan control utility for Thinkpads on FreeBSD

acpi_ibm however seems not to respond well to sleep/resume on my machine, so i added

kldunload acpi_ibm
/usr/local/etc/rc.d/bsdfan stop


to /etc/rc.suspend

and

kldload acpi_ibm
/usr/local/etc/rc.d/bsdfan start


to /etc/rc.resume

I bought this one used, and, as delivered, it tended to run the fan all the time. Cleaning the inside and re-pasting the heatsink-fan combo solved the issue. This is not difficult but requires patience, as the mainboard has to come out in order to get to the heatsink. The service manual thinkpads.com/support/hmm/hmm_pdf/t420s_t420si_hmm_en_0a60241_06.pdf is a must for disassembly
 

robroy

Active Member

Thanks: 95
Messages: 159

ThinkPad X240 model 20AM-0014US (Haswell); Lenovo specifications; BIOS level 2.37.

OS installed from the unofficial media which has since been recalled, then updated to 11.0-RELEASE-p1: MD5 (FreeBSD-11.0-RELEASE-amd64-disc1.iso) = 013061c7e485f9118cb778c3b39d089e.

Works:
  • Intel graphics (Haswell)
  • Wireless in 11g and 11a (Intel Dual Band Wireless AC 7260)
  • Sound

Problems so far (two):
  • [Workaround in place thanks to scottro] The touch-screen yields endless kernel messages both during and after installation, like this (over and over again):
    Code:
    ugen1.3: <ELAN> at usbus1
    hid_get_item: Number of items(256) truncated to 255
    hid_get_item: Number of items(256) truncated to 255
    uhid0: <ELAN Touchscreen, class 0/0, rev 2.00/0.12, addr 3> on usbus1
    hid_get_item: Number of items(256) truncated to 255
    hid_get_item: Number of items(256) truncated to 255
    hid_get_item: Number of items(256) truncated to 255
    ugen1.3: <ELAN> at usbus1 (disconnected)
    scottro shared a workaround on his Web site, and also chatted with me here on the forum about it (thank you so much scottro).

    His workaround's to power off the touch-screen's USB device, which stops the endless kernel messages.
    Code:
    # usbconfig | grep Touchscreen
    ugen1.3: <Touchscreen ELAN> at usbus1, cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON (100mA)
    # usbconfig -d 1.3 power_off
    # usbconfig | grep Touchscreen
    ugen1.3: <Touchscreen ELAN> at usbus1, cfg=255 md=HOST spd=FULL (12Mbps) pwr=OFF (100mA)
    I added an rc(8) script to apply his workaround during boot (shown below).
  • UPDATE on 2017, February 23rd: this turned out to be a physical keyboard problem, so please disregard it. Gratuitous , (comma) characters show up while I'm typing, mixed in with the actual keystrokes I've entered. This happened both during install and after install, and both on the console and in X. This might just be a physical keyboard issue; I don't know yet. The frequency's about one gratuitous comma per every ten keystrokes.
More details (including my wacky startup script to apply scottro's workaround during boot):
 
Last edited:

scottro

Daemon

Thanks: 426
Messages: 1,259

Firstly thanks much for the kind words, but, (and sorry, I may not have made this clear), I got those solutions off the Internet, possibly even here. (Though I don't think that was it.)
The big news, to me, anyway, is that the Haswell card works for you.

Also, one question--are you using legacy boot mode or what is probably the default uefi mode? The reason I ask is because I do remember one person on these forums having trouble with their Intel card, reinstalling in Uefi and the card then working. (I also tried on my Yoga2, but it made no difference).
 

robroy

Active Member

Thanks: 95
Messages: 159

Also, one question--are you using legacy boot mode or what is probably the default uefi mode?
"Legacy first" works; "Legacy only" works.

"UEFI only" doesn't work. It brings me to a ThinkPad "Boot Menu," prompting me to select a boot device. Choosing the FreeBSD disk makes the screen flash, then returns me directly back to the "Boot Menu." So UEFI-only's a no-go I'd have to do something else to make UEFI mode work, I guess.

PS. "Both," with "Legacy first" chosen, seems to have been the BIOS default.
 

scottro

Daemon

Thanks: 426
Messages: 1,259

Ok, thank you. UEFI requires a small (by default in FreeBSD, 200MB, I believe), special EFI partition. If you booted the install USB into UEFI mode, it would have told you during disk creation that you need it (and offer to create it for you).
 

georges

Member

Thanks: 1
Messages: 49

Just installed FreeBSD-11 Release on my ASUS ROG G751JL Laptop:

Networking - working
Wireless - Working
Graphics - nvidia driver Working
BT - not tested
Card reader - Not tested
Sound - Working
Keyboard - working
Pad - working
All USB ports - working
Booting from USB 3.0/SSD drive.

Processor / Chipset
CPU
Intel Core i7 (4th Gen) 4720HQ / 2.6 GHz Max Turbo Speed 3.6 GHz
Number of Cores Quad-Core
Chipset Type Mobile Intel HM87 Express

RAM Installed Size
16 GB

Audio & Video

Graphics Processor
NVIDIA GeForce GTX 965M - 2 GB GDDR5 SDRAM
Integrated Webcam
Yes
Sound
Stereo speakers, subwoofer, microphone
Features


Communications

Wireless Protocol
(Intel 7265 (FreeBSD iwm driver) 802.11b/g/n/ac, Bluetooth 4.0
Wired Protocol
RealTek Gigabit Ethernet

Suspend/Sleep (need more testing and configuration - so far not working)
Black screen when switching from desktop to terminal. You can type but you cannot see :)

Addition: Display port, HDMI, and VGA working.
dual screens working (only have 2)
CD Burning - working.

Update: webcam working via webcamd. VLC playback.
 
Last edited:

vermaden

Son of Beastie

Thanks: 1,045
Messages: 2,695

arnab
Can anyone help me to choose among them or has any experience of running FreeBSD on these laptop? Thanks in advance
I can not help about the laptops You mentioned but the ThinkPad W530 has similar specs (up to 32 GB RAM, 4 cores/8 threads, PCI-Express SSD + even two 2.5 drives possible, powerful nVidia Quadro graphics, illuminated keyboard, high resolution screen) and work very good with FreeBSD (even suspend/resume works).

I would consider ThinkPads with specs You need instead of ASUS offerings. Also Razer (creates similar powerful gaming laptops as ASUS ROG) recently claimed support for Linux which indirectly can mean better support for FreeBSD.
 

scottro

Daemon

Thanks: 426
Messages: 1,259

I've found the biggest problem in laptops and FreeBSD are the later Intel video cards. (Some of the later wireless cards as well, though you can usually get a workable usb-wireless from Edimax for less than $10.00 USD.)

However, I would also take vermaden's suggestion, especially as he mentions that everything seems to work.
 

diizzy

Well-Known Member

Thanks: 60
Messages: 259

I'd say that a business modell from Toshiba, Fujitsu or Asus (called Asuspro) will all work fine in general. You will have some quirks with video but overall you shouldn't run into many major issues all will be Intel hardware in most cases (read data sheets) and have much better build quality than consumer models without being excessively expensive.
 

jdakhayman

Member

Thanks: 11
Messages: 24

Just to chime in, Thinkpads, as vermaden has mentioned above, tend to have good support in their X series, T series and W series lines of laptops. Most stuff works, with only small things needing special attention.
 

Trihexagonal

Daemon

Thanks: 548
Messages: 1,070

I've had a Gateway NV53A Acer clone running FreeBSD 11.0-RELEASE since March. The only issue I've seen with it is when it comes back from timing out (I don't use a screensaver) it flashes momentarily before rendering the desktop. Also, if you try to use Forced Pseudo-Transparency in Fluxbox it breaks transparency in Eterm. Undoing it and rebooting brings back transparency to Eterm:

AMD Phenom II x 3 N830 Triple Core @ 2.1GHz
ATI Mobilty Radeon HD 4250
4GB DDR3 RAM
Matshita DVD-RAM Super Multi drive
15.6 16:9 HD LED LCD
Realtek ALC272 Audio
1TB HDD

I've had FreeBSD 11.0-RELEASE-p9 running on my Thinkpad T61 and X61 with no problems, too.

My Thinkpad W520 with Optimus need to enter mode 0 at boot to keep the screen from going into multiple small renditions of the boot screen. Once booted to the desktop it didn't give the proper resolution and needed tweaked.
 
Last edited:

Trihexagonal

Daemon

Thanks: 548
Messages: 1,070

Now that I've swapped out my HDD...

Thinkpad X61
Intel Core 2 Duo CPU T7300 @ 2.0GHz
4GB PC2-5300 RAM
Intel Graphics Media Accelerator X3100 (Intel 965)
12.1" TFT display @ 4:3 screen ratio with 1024x768 resolution
100GB Lenovo HDD @ 7200RPM
Intel HD Audio
Intel PRO/1000 Network Connection
8 cell battery

No DVD burner unless it's docked:
LG GCC-4247N DVD/CDRW (Through X6 UltraBase)
 
Last edited:

Trihexagonal

Daemon

Thanks: 548
Messages: 1,070

Thinkpad T61
Intel Core 2 Duo CPU T7300 @ 2.0GHz
4GB PC2-5300 RAM
nVIDIA Quadro NVS 140M (takes the x11/nvidia-driver-340)
15.4" 1680x1050 (WSXGA+) widescreen
100GB Lenovo HDD @ 7200RPM
Intel HD Audio
Intel PRO/1000 Network Connection
Intel Wireless WiFi Link 4965
Hitachi CD-RW / DVDRAM combo
Lenovo Integrated Reader
9 cell battery
 
Last edited:

vermaden

Son of Beastie

Thanks: 1,045
Messages: 2,695

Hi @ll,

Can I ask about the compatibility with Lenovo ThinkPad P50? Will it work with FreeBSD?
If You would want to use integrated Intel graphics, then You would have to mess with drm-next (who knows when it will be merged, maybe 2020 ...).

As P50 comes with Nvidia, You will have working acceleration from Nvidia Binary driver from Ports/packages.

The rest should 'just work', dunno about newest Intel WiFi, this can be a problem.

It is very similar in features and design to W530, which worked fine, but P50 is newer for sure.
 

vermaden

Son of Beastie

Thanks: 1,045
Messages: 2,695

I would get Lenovo T400/T500 (definitely not T410/T510) and/or Dell Latitude E6400/E6500 (I have one and everything works).

I haven't tried FreeBSD on Sony/HP/non business Dell laptops, so I can not help about it.
This advice is little dated. Today I would give other advice.

If You want to run LibreBoot or CoreBoot, then You need to get T400, if not, then T410(s)/R510/W510/X201 and T420(s)/T520/W520/X220 are last REAL ThinkPads with REAL KEYBOARDs.

You can also get T430/T530/W530/X230 and swap keyboard for the older one, but You need BIOS mod for that as the keys mapping is not 1:1. You can also get FullHD screens for T420(s)/X220 laptops, but that mod is more 'challenging'.

About the interesting features, the USB 3.0 is found in these:
W520, T420s and X220 with i7 CPU. IF You consider getting the X220, make sure get the one with IPS screen.

As for the Dell side, the last real Latitudes with real keyboards are E5410/E6410/E6510 and Precisions from that time (do not remember exact model number).

If You want something newer, then wait a month to 25th anniversary of ThinkPad when Lenovo would release ThinkPad Retro (at least that's the work in progress name) with REAL KEYBOARD:
https://www.theregister.co.uk/2017/09/04/retro_thinkpad_spotted_in_the_wild/
 

Trihexagonal

Daemon

Thanks: 548
Messages: 1,070

Thinkpad T400
Intel Core2 Duo P8600 @ 2.4GHz
8GB PC3-8500 RAM
250GB Scorpio Black HDD @ 7200RPM
Switchable Graphics with Intel GMA 4500MHD and ATI Mobility Radeon HD 3470
14.1" 1280x800 (WXGA) with LED backlight
Intel HD Audio
CD-RW/DVD
Intel Gigabit Ethernet (10/100/1000) PCI-Express


This has "Switchable Graphics" and needs to be put into "Discreet" graphics mode in the BIOS. It then defaults to the Radeon chip and runs fine without any tweaking. I installed both drivers when building X.
 

romanaOne

Member

Thanks: 9
Messages: 66

I installed 11.2RC3 on:

HP Elitebook 8470p

Intel i5-3340M 2.70GHz
HD3000 Graphics (i915kms_load="YES")
16GB RAM
500GB Samsung 850 EVO SSD + 512 GB El Cheapo Walmart Noname Seagate
Audio card (IDT 92HD81B1X) works
15" 1366x768 screen (xbrighness works, no idea about Fn keys)
VGA-out external monitor works.
Broadcom wifi not working, but there is no BIOS whitelist.

Non-obvious modifications and customizations:
  • BCM Wifi did not work, so I just replaced it with Atheros 9285
  • Pulled DVD/CDRW drive and replaced it with hard drive caddy so I can have 2 drives in zfs mirror.
  • Samsung SSD still needs camcontrol tags ada0 -N 1 to prevent NCQ trim corruption. (I run it in rc.d.) Been a few days and no checksum errors, so I think this fixes it.
Aside from these minor tweaks, no special configurations were needed. Everything worked. I mostly followed Cooltrainer's FreeBSD 11 Desktop Howto and settled on MATE for the desktop.
 

k.jacker

Well-Known Member

Thanks: 231
Messages: 446

Dell Latitude E7240 - works great since FreeBSD 10.3

Spec
CPU: Intel Core i7-4600U - speed step works, frequency and temperature can be read (coretemp.ko required)
Video: intel HD4600 (Haswell) - (works out of the box with i915_kms.ko | console switching works | on rare occasions, when booted up, the i915_kms driver complains "gpu hang" and I have to reboot)
Screen brightness: works, acpi_video.ko required. graphics/intel-backlight works, too. (brightness via Fn+up/down doesn't work though)
Wifi: wasn't supported, but is easy to swap. The laptop bottom is easily opened by removing 2 screws only. (With hardware switch for Wifi on/off)
LAN: Intel Pro 1000 (i218-LM) - supported by em(4)
Audio: works - with hw.snd.default_unit=3 speakers work and will switch to headphone jack when headphone connected. (dedicated vol keys: mute is recognized, vol +/- not)
Suspend resume: works fast and without problems. Only internal Wifi device often hangs after resume (doesn't happen to externel USB wifi). Sometimes ifconfig wlan0 up is enough. Sometimes pkill dhclient is required.
(I'm still working on a way to check the state and automate this... maybe getting rid of the crappy Realtek 8188ce would help, too)
Backlit keyboard: brightness is changed via Fn+right/left - works.
USB 3.0: works
Docking station: is recognized, brightness changes automatically when AC line is recognized, LAN works, external monitors work (DVI/VGA), USB works, audio outputs work
Untested: camera, mic, touchscreen

Edit: Silent. CPU idles around 40′C, fan only starts when high constant load is aplied.
 

georges

Member

Thanks: 1
Messages: 49

Just installed FreeBSD 11.2 on my Asus GL753VD.

Surprisingly no hiccups :p:cool:

Everything works. Using Xorg and Mate DE.

RAM 16GB
Kingston NVMe 256GB, 1 TB HDD
GPU: Intel HD 630 and nVidia 1050 4GB.
CPU: Intel Core i7 (7th Gen) 7700HQ / 2.8 GHz
Webcam: working
Trackpad: not tested
Mouse: working.
wireless: Intel 7265 - working.
Intel hd 630: GPU working
Realtek 1GB port: working
usb3: working
usb2: working
Keyboard: working
mice: working
Card reader: working
CD/DVD: working
Multi monitors: working
vlc: working, webcam too.
Sound: working.

Freebsd booted from external SSD (USB 3).
 

yuripv

Member

Thanks: 14
Messages: 34

MacBook Pro 14,3 (15-inch, 2017), running 12.0-ALPHA8 (just HEAD, really).

Barely anything is working yet, keyboard/touchpad are connected via SPI and need a new driver (looking into it, will do if I have enough time/skill), WiFi is missing the driver and is pretty bad even in Linux and likely requires updated firmware.

USB working via the usb-c <-> usb-a adapter (boot, keyboard, wifi dongle).

RAM 16GB
APPLE NVMe SSD, 512GB
GPU: AMD Radeon 560 Pro
CPU: Intel(R) Core(TM) i7-7820HQ CPU @ 2.90GHz
Keyboard: not working (yet)
Touchpad: not working (yet)
Sound: not working (yet)
WiFi: BCM43602 802.11ac Wireless LAN SoC not working
 
Top