• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Notebook / Laptop compatibility list

da1

Aspiring Daemon

Thanks: 92
Messages: 865

#51
Lenovo T420S with Intel i7 (2nd generation), 4GB RAM PC3 10600 (1333 MHz), NVIDIA® Quadro® NVS 4200M, 160GB SSD drive, 1x USB 3.0, 2x USB 2.0, Intel® Wireless WiFi Link 6300 AGN, 720p webcam.

WORKING:
8.2 amd64 (RELEASE+STABLE with atkbd removed from the kernel)
USB 2.0 and USB 3.0
SSD drive
audio
WI-FI
network card


NOT WORKING!:
- full resolution (stuck @ 1024x768 - ports Nvidia driver appears to be useless and the official Nvidia driver reboots the system)
- Integrated keyboard (http://forums.freebsd.org/showthread.php?t=24848)


NOT tested yet:
Fingerprint reader
external display
 

zeissoctopus

Active Member

Thanks: 37
Messages: 164

#52
Acer Aspire 5552-5615
AMD Phenom II N830 (3 cores), 4GB DDR3 RAM, ATI® Radeon® 4250 HD, 320GB HDD, 3 USB 2.0, Broadcom 57780 ethernet, Atheros 9287 802.11n Wifi, 1.3p webcam, 15.6 1366x768 LED LCD, 2-in-1 Card Reader.

Environment
FreeBSD amd64 8-Stable (csup at 2011/7/26)
Xorg

WORKING:
AMD Phenom II N830 --> kernel module: amdtemp
ATI Radeon 4250 HD --> kernel module: radeon, /etc/make.conf: WITHOUT_NOUVEAU=Yes, Ports install: xf86-video-ati
1366x768 LED LCD: Xorg with ATI driver support
AHCI HDD --> kernal module: ahci
Broadcom 57780 --> kernal module: if_bge
USB 2.0 --> General Kernel support
HDA Audio --> kernel module: snd_hda, /etc/sysctl: hw.snd.default_unit=1
1.3p webcam --> Ports install: cuse4bsd-kmod, webcamd
2-in-1 Card Reader --> kernal module: mmc, mmcsd

PARTIALLY WORKING!:
Atheros 9287 11n Wifi: Please following adrian@'s instructions to use FreeBSD9 driver in 8-Stable http://forums.freebsd.org/showpost.php?p=135929&postcount=11. Only 11a/b/g works in 8-Stable.
ACPI --> kernel module: acpi_video. Have kernel error msg: can't evaluate \\_SB_.PCI0.AGP_.VGA_.LCD_._DCS - AE_NOT_FOUND

NOT tested yet:
Supense/Resume
external display
 

da1

Aspiring Daemon

Thanks: 92
Messages: 865

#54
Update for the T420s:

Somewhere along the way to r225640 the integrated keyboard got fixed. Also, by setting "integrated video" in the BIOS, one can make use of the nvidia module for the X server and get full resolution plus the external display.

NOT WORKING!
Resume
Fingerprint reader
Brightness Hotkey (maybe need to use something like application shortcuts for xfce4)
In/Out audio jack
Integrated camera (although webcamd sees the device, I cannot get any video from it)
 

ring_zero

Member

Thanks: 23
Messages: 67

#55
Carpetsmoker said:
Suspend/Resume works on my Thinkpad T61 as of FreeBSD 8.2/amd64. This is with an Intel GMA card.
Only minor quirk is that I need to restart moused on resume.

Strangely enough, on FreeBSD 8 the "BIOS beeps" and brightness controls stopped working. Both of which worked on FreeBSD 6 and 7. I can work around the latter with xbacklight though ...
Try setting the following in /boot/device.hints
Code:
hint.psm0.flags="0x2000"
This flag sets the bit that triggers HOOKRESUME which sends data to the mouse to wake it up. Other values are "0x6000" which triggers both HOOKRESUME and INITAFTERSUSPEND,(this will wake up the mouse and re-initialize it), and "0x4000" which triggers INITAFTERSUSPEND, which will re-initialize the mouse.
 

da1

Aspiring Daemon

Thanks: 92
Messages: 865

#56
UPDATE:

To enable the brightness control from Fn+hotkey, one needs to make sure that
Code:
Option "RegistryDwords" "EnableBrightnessControl=1"
exists in /etc/X11/xorg.conf under the Device section.

The integrated camera works with webcamd, but I think I have a problem with mine (the output is foggy).

The output jacks works, as long as one sets the sysctl variable hw.snd.default_unit to the propper value (3 in my case)

NOT WORKING/Not tested!
Resume
Fingerprint reader
Mic in (audio jack)
 

ring_zero

Member

Thanks: 23
Messages: 67

#57
vermaden said:
I havent tried bluetooth, so probably does not work here either.


The suspend/resume works on mine from time to time (Intel GMA X4500), but I am not always able to use wifi again and it always crashes when i do the suspend during mplayer playing something.

Is there ANY laptop that FreeBSD's suspend/resume works flawlessly?
Toshiba Satellite C655D. Works for me with no issues. I had to make the changes outlined in this post, however.
 

Trihexagonal

Aspiring Daemon

Thanks: 415
Messages: 893

#58
Sony Vaio VGN-N320E
Intel Core 2 Duo T2060 @ 1.60GHz
2GB DDR2 RAM
Intel 82945GM (945GM GMCH) SVGA controller
Intel 82801G High Definition Audio Controller
Atheros 5424/2424 Wifi
Microsoft Trackball Optical USB Mouse
FreeBSD 9.0-RELEASE

Everything works. :)
 

fmc000

New Member

Thanks: 1
Messages: 4

#59
Acer eeePC 900
Intel Celeron-M ULV 353 @ 900MHz
1GB DDR2 RAM - RunCore 32GB SATA SSD + Asus 4GB integrated PATA SSD

What's working:
  • Intel 915GM SVGA controller @ 1024x600
  • RealTek HDA sound card
  • Attansic L2 100Mb/sec LAN
  • Touchpad and PS/2 Mouse
  • Integrated SD cardreader
  • Nokia C5 UMTS modem
  • Suspend / resume from RAM (both console and X)
  • Asus special keys (with acpi_asus)
  • Fan control (with external module eeemon.ko)
What's not working:
  • eGalax Touchscreen (detected but not working in X)
  • BootBooster (EFI partition in setup but ignored?)
Did not test:
  • USB integrated webcam (detected - not tested)
  • Atheros WiFi (detected - not tested)
Release: FreeBSD 9.0-RELEASE with X and Xfce 4.8.x on ZFS root

P.S.
Actually the webcam works perfectly with cuse4bsd + webcamd + uvcview.

The wifi card is detected at boot time only if the blue led is lit, a.k.a. you must have pressed the special key fn+f2 before the last shutdown / reboot. If the system boots without the blue led lit the wifi card is not detected regardless of any actions taken.
 

mav@

Aspiring Daemon
Developer

Thanks: 216
Messages: 702

#60

Trihexagonal

Aspiring Daemon

Thanks: 415
Messages: 893

#63
DemoDoG said:
I also have FreeBSD setup on both my laptops and it works perfectly, no need for penguins.
Toshiba NB100 notebook and Toshiba sattelite pro
Is anybody else running FreeBSD on a Toshiba? I've been looking at the specs of a Toshiba Satellite Model: L775-S7114 and thinking of buying one in the coming weeks.

It's got a Intel® Core™ i3-2350M 2.3GHz duo core processor and Intel HD graphics 3000 chip so I thought it should run FreeBSD out of the box without much trouble. I've had good luck with Intel CPU's and wouldn't have to deal with Optimus technology with it. I did search the forums and saw where there might be a problem as far as wifi compatibility (and I don't see what kind of card it comes with) but I have an Ethernet network and will probably never move it off the desk once it's set up. There were few other assorted issues but nothing that looked like it couldn't be worked out.

It had good reviews and would suit my needs as far as every day use. The price is right, $450, and it would be an all around upgrade from my Sony, which pretty much works without having to tweak it at all. Whatever I get I want it to have a 17.3" screen like this does.
 

htutt

Member

Thanks: 1
Messages: 48

#64
Hi Trihexgonal

I am using FreeBSD 9.1-RC2 on TOSHIBA Satellite L740 which has core i5 and Nvidia Graphic with 14 inch screen.

CPU: Intel(R) Core(TM) i5-2450M CPU @ 2.50GHz
GPU: nvidia0: <GeForce GT 525M> on vgapci0
Ethernet: alc0: <Atheros AR8151 v2.0 PCIe Gigabit Ethernet> port 0x2000-0x207f mem 0xc3100000-0xc313ffff irq 18 at device 0.0 on pci10
Wireless: ath0: <Atheros 9285> mem 0xc3200000-0xc320ffff irq 17 at device 0.0 on pci9
Built-in webcam: ugen0.4: <Alcor Micro, Corp.> at usbus0

If you want to see more info, here my dmesg file.

They are working fine for me except bluetooth device which is failing.
I look at your future laptop Toshiba L775-S7114, it would be nice. Toshiba Satellite used to ship with Atheros wireless Adapter which is working perfectly with FreeBSD. For me, I would like to have Nvidia for Graphic because it is working perfectly with FreeBSD as Nvidia supports for FreeBSD.

Wish you got the best hardware for your FreeBSD!!
 

G_Nerc

Active Member

Thanks: 11
Messages: 122

#65
My not very good history at this moment with new laptop and FreeBSD.
Model: iRu Patriot 806, Core i5 3210 2500Mhz, 17 inch with Intel HD4000 + GT630M, Wi-FI: RTL8273AE
So when I'm install FreeBSD 9.0 amd64 it does not work with realtek ethernet and realtek wi-fi.
So I'm csup to 10-Current with USD Ethernet and onboard ethernet after that works.
Wi-Fi not works, and I can't use Xorg because of Nvidia optimus not work (system reboot with startx and nvidia-driver)
So I'm tryin work with vesa and setup Intel KMS driver
 

b7j0c

Member

Thanks: 4
Messages: 47

#68
System76 Gazelle:

https://www.system76.com/laptops/model/gazp8

my specs: i7, 16GB RAM, 180GB SSD. 1080p matte display.

works without any tweaking:

No-pain install
Intel wireless
X at 1080p
Intel audio driver

I haven't tested suspend/resume etc but I can confirm this as a modern laptop for sale now that provides good out-of-the-box operation for people who really want to avoid tweaking.

EDIT: I would like to add that the graphics performance (Ivy Bridge) is honestly poor. Hopefully llvmpipe will address this.
 

sossego

Retired from the forums

Thanks: 142
Messages: 1,561

#69
Toshiba Satellite A105-S2061
512MB Memory
FreeBSD 9.0
Has blackbox, mwm, lxde, openbox, and xfce4 as desktops.
Built firefox 18.0 on it.
Kernel is set at 2500Hz

The only problem seems to be the CD audio. OSS is installed.
 

sossego

Retired from the forums

Thanks: 142
Messages: 1,561

#70
Sony VAIO PCG-8G1L
This model is known for overheating. Only /dev/ttyv0 is available.
The solution would be to place the hard drive into another laptop, set everything up, and then return it to the original laptop.
For comparison: On a Linux system, p4-clockmod must be loaded immediately or the system overheats. Controls for cpu frequency must be immediately enabled.
 

respite

Member

Thanks: 2
Messages: 33

#72
Lenovo x230 ordered with Intel Centrino Advanced-N 6205. WiFi, wired NIC, sound work on default FreeBSD 9.1-RELEASE install. Intel HD 4000 works with xf86-video-intel.
 

ohyes

Member

Thanks: 1
Messages: 56

#73
FreeBSD'hello :f
VAIO VPCZ13 - FreeBSD 9.1 OK but...
This is a computer with HD4000 graphic and a nVidia 330M.
On this computer there is a hard switch between Speed/Stamina/Auto for the graphic card - no bios access for that.

My first install (20130303) I setup the Intel HD4000.
Install was OK but cannot switch to tty, see that thread: Thread 38470

Retry with nVidia install and specify DFP and EDID file in xorg.conf, with different hard-switch positions: not OK - no screens device error.

Finally 'I' hack the bios to get option of video card choose and set it on nVidia (no switch).
Then, no problem (video, wifi, raid, synaptics touchpad -tap disabled with no unwanted events-, sound, etc...).
I will post all setup, hack bios method, and conf files soon.
 

zspider

Aspiring Daemon

Thanks: 110
Messages: 584

#74
ASUS K55VD.

700 GB HD(7200 RPM), 8GB RAM, Ivy Bridge CPU, dual core, 2.5 GHZ, 10/100/1000 Ethernet, ALC270 sound works with 9.0 module for sure, Intel HD4000 and Nvidia 2GB Optimus.

Wireless not supported yet, supposedly will be in 10.0. Card reader unknown. Nvidia is untouchable but the Intel HD4000 works nicely for native FreeBSD applications, (AMD64 Direct rendering with Intel drivers for Wine and Linuxulator still needs to be fixed), TTY becomes unusable after loading Xorg with Intel drivers.

Everything else seems to be peachy and I've been running this system for about 4 months.
 

prp-e

Member


Messages: 53

#75
Acer Aspire 5520

FreeBSD 9.1-RELEASE
X.org
KDE/GNOME/Xfce

--------------------

CPU : AMD Athlon X2 - 1.9 GHz.
VGA : NVIDIA GeForce 7000m
Wireless adapter : External Wireless adapter (GNET).
RAM : 3 GB DDR3.
H.D.D : Original : 320 GB - WD. Custom(mine) : 500GB SATA3 , HGST(brand from Taiwan).
 
Top