Solved New Xorg switch from devd to udev

malavon

Active Member

Reaction score: 144
Messages: 242

the log makes no sense because with a mask set to 12 i don't see why Xorg is attaching the keyboard multiplexer via edev in the first place. I thought the point of the mask was it would only use the hardware for edev.
This might still be a difference, I haven't changed the sysctl on my end (although I didn't see any difference between the default 3 and 12, which is why I just left it as-is).
my keyboard is mapped as a pc105
What I get on my end:
Code:
> setxkbmap -query
rules:      evdev
model:      pc105
layout:     be
options:    terminate:ctrl_alt_bksp
So that looks pretty much the same. I'm not sure I can help you much further, I hope you can get it sorted. Your logs look the same as mine, so I couldn't tell you what the difference is.
 

fernandel

Aspiring Daemon

Reaction score: 221
Messages: 893

Okay, I didn't removed evdev support from kernel because Mr. Michael Gmelin help me and he found problem in scfb driver. He made a patch and it works. I just lost middle/scrolling button in my bluetooth Apple Magic Mouse.
I solved a problem with Apple Magic Mouse. The problem was
Code:
sysctl kern.evdev.rcpt_mask=12
I did try 6 and didn't work either but with default settings 3 works like before. There are no problem with keyboard either.
 

broozar

Member

Reaction score: 8
Messages: 22

I just updated my system with "pkg upgrade" and was having serious issues with both keyboard (PS/2) and mouse (USB). Arrow keys were wrong, garbage output on certain keys, etc.
Went to my config file in /etc/X11/xorg.conf.d/10-keyboard.conf which was there from a previous install and removed both entries about Rules and Driver. Now I only have Identifier, Match, Model, Layout and Variant. Seems mostly good so far, although the mouse wheel behaviour is not completely fixed.
 

free-and-bsd

Aspiring Daemon

Reaction score: 108
Messages: 797

Thank you everyone! Thanks to your comments I was able to do it successfully. I HAD that problems a while ago, but in coincided with my switching to STABLE, so I blamed it on STABLE :). But I noticed, too, that strange dependence change in xorg-server... but again, blamed it on something I did before and then forgot. And now that I could see it WAS actually new way of doing it, you're here with your experiences.

BTW, I didn't even need to change any sysctl settings. Just installing libinput and xf86-input-libinput packages did the trick.
CONCLUSION: I REALLY need to read UPDATING before updating :oops:...
 

gnath

Active Member

Reaction score: 39
Messages: 157

Thanks all and for this thread. I had same problem but blamed myself and using -STABLE branch. That logic should be there for pulling dependency from x11-servers/xorg-server for package users.
 

morbit

Well-Known Member

Reaction score: 35
Messages: 261

Awful transition overall- required changes to kernel config, recompiling xorg-server with new defaults, editing xorg.conf which I had for years as well as a new syntax for localised keyboard (see above for sane keyboard defaults), but got my input back, thanks.
 

malavon

Active Member

Reaction score: 144
Messages: 242

Wait, does that mean other people no longer have the issue where bottom arrow and End open up the Plasma launcher (basically the start menu)?
If so I'd be very grateful if someone could let me know how they solved it.
 

morbit

Well-Known Member

Reaction score: 35
Messages: 261

Unfortunately, I don't use KDE

Code:
rules:      evdev
model:      pc105
layout:     pl
options:    lv3:ralt_switch_multikey
 

CrunchBerry

New Member

Reaction score: 1
Messages: 13

Wait, does that mean other people no longer have the issue where bottom arrow and End open up the Plasma launcher (basically the start menu)?
If so I'd be very grateful if someone could let me know how they solved it.
KDE is the only thing that "fixed" my issue, but again I don't think my issue was Xorg, I think its XFCE is broken. In fact what basically made me rage quit was when I noticed my up key worked fine in an xfreerdp session from my XFCE host, but UP wouldn't work with XFCE. To be fair I don't think end or down ever did that to me in kde when I tried it, kde would just have components crash on startup. now it seems to be stable for me. I would suggest if folks have this issue to do the following test: try xorg using only twm as your desktop. run xev to check the inputs from Up or the broken keys. Or try apps that you know didn't work. If it does work I'd try KDE, or perhaps some other window manager. Your xorg might be configured fine, your current window manager/desktop maybe broken.

coincidentally we seem to have this bug:

I found that when I disabled but forgot to enable a window manager in .xinitrc and the XF86FullScreen key gave an odd error on startx. which is indeed missing from
Code:
/usr/local/include/X11/XF86keysym.h
which also notes that file is no longer maintained by Xorg.

perhaps the bug is related, maybe the missing symbol messes up the keyboard routines of xfce. XFCE still uses HAL, which I also read messes with keyboards by injecting its own default mappings and layouts ignoring the xorg configs to EVDEV interfaces. Linux users seemed to love this EVDEV switch, and reported all the same problems we have here. I find it odd that x11-drivers/xf86-input-evdev requires hald by virtue of webcamd dependancy, when we are using that to eliminate hal. Might recompile webcamd without hal to see if this does anything, but Thunar still requires hal because gvfs, so its moot for XFCE anyway to test. I'm just making WAGS here.


I don't care to put any more effort in this though. XFCE was on thin ice with me, this killed it. KDE is actually a lot nicer then I recall from the 2000s... Good luck
 

zeising@

Member
Developer

Reaction score: 14
Messages: 21

Hi!
I was pointed towards this forum post (I'm not a frequent forum user). I just wanted to check if everything is ok and that issues has been solved, or if there is anything else we/I can do.
Regards
Niclas
FreeBSD Graphics Team
 

mickey

Aspiring Daemon

Reaction score: 149
Messages: 521

Wait, does that mean other people no longer have the issue where bottom arrow and End open up the Plasma launcher (basically the start menu)?
If so I'd be very grateful if someone could let me know how they solved it.
I was having the problem with the plasma application launcher pop up when pressing the down arrow key when I recently installed KDE from packages on my notebook. Solution was to delete the keyboard shortcut from the application launcher (which displayed as Alt-L if I remember it right). Have not seen any other ill effects since then.
 

Emrion

Well-Known Member

Reaction score: 95
Messages: 374

Hi!
I was pointed towards this forum post (I'm not a frequent forum user). I just wanted to check if everything is ok and that issues has been solved, or if there is anything else we/I can do.
Regards
Niclas
FreeBSD Graphics Team
"Resolved" isn't the term I would use. Let's say it roughly works for most people with many little and annoying problems. For example, I'm under VirtualBox / Windows 7: with chromium, often a clic outside the page results in a backward page. I also lost two of my mouse buttons (which worked for page forward / backward in chromium).

So this change has a taste of regression even if it works (and there is others problems not udev related).
 

malavon

Active Member

Reaction score: 144
Messages: 242

Solution was to delete the keyboard shortcut from the application launcher (which displayed as Alt-L if I remember it right). Have not seen any other ill effects since then.
I can confirm this does remove the key down/End issue, but of course then the launcher doesn't have a shortcut anymore. In my case I bind it to alt+f1, which incidentally also means the meta/windows button.

I was pointed towards this forum post (I'm not a frequent forum user). I just wanted to check if everything is ok and that issues has been solved, or if there is anything else we/I can do.
Well, the issue described here seems to be bothering quite a lot of issues. The plasma launcher now opens up with key down and End when it's bound to alt+f1.
It'd be great if someone could take a look into it.
 

zeising@

Member
Developer

Reaction score: 14
Messages: 21

I can confirm this does remove the key down/End issue, but of course then the launcher doesn't have a shortcut anymore. In my case I bind it to alt+f1, which incidentally also means the meta/windows button.


Well, the issue described here seems to be bothering quite a lot of issues. The plasma launcher now opens up with key down and End when it's bound to alt+f1.
It'd be great if someone could take a look into it.
Can you check which version of libxkbcommon you have installed, as well as the output from setxkbmap -query? I haven't heard of any issues with KDE after the latest update to libxkbcommon.
 

mickey

Aspiring Daemon

Reaction score: 149
Messages: 521

Code:
libxkbcommon-0.10.0_2

rules:      evdev
model:      pc102
layout:     de
variant:    nodeadkeys
options:    numpad:pc,kpdl:dot
Plasma launcher does not open when pressing down arrow or end key, neither when bound to Alt-F1 nor when bound to Alt-L.
 

zeising@

Member
Developer

Reaction score: 14
Messages: 21

Code:
libxkbcommon-0.10.0_2

rules:      evdev
model:      pc102
layout:     de
variant:    nodeadkeys
options:    numpad:pc,kpdl:dot
Plasma launcher does not open when pressing down arrow or end key, neither when bound to Alt-F1 nor when bound to Alt-L.
This looks OK. You want the latest libxkbcommon, as well as rules: evdev in the setxkbmap -query output. I assume that if you bind it to Alt-F1 or Alt-L, it works as expected?
 

mickey

Aspiring Daemon

Reaction score: 149
Messages: 521

This looks OK. You want the latest libxkbcommon, as well as rules: evdev in the setxkbmap -query output. I assume that if you bind it to Alt-F1 or Alt-L, it works as expected?
Yes, both Alt-L and Alt-F1 work as expected when bound as a shortcut for the application launcher. Just tested it on my desktop machine which builds from ports/svn as well as on my notebook which installs from packages. Both have libxbcommon-0.10.0_2 installed. Keymap on notebook uses presario for the model, otherwise it's the same as on my desktop. Even the media keys (play/pause, stop, next, previous) seem to work as expected. 👍
 

malavon

Active Member

Reaction score: 144
Messages: 242

Code:
libxkbcommon-0.10.0

rules:      evdev
model:      pc105
layout:     be
options:    terminate:ctrl_alt_bksp
[code]
Do you mean something has changed while the version hasn't been increased (aside from port revision)? I'd expect a higher version number if that's the case.
Anyway, I'll build it today and test it out.
 

zeising@

Member
Developer

Reaction score: 14
Messages: 21

Code:
libxkbcommon-0.10.0

rules:      evdev
model:      pc105
layout:     be
options:    terminate:ctrl_alt_bksp
[code]
Do you mean something has changed while the version hasn't been increased (aside from port revision)? I'd expect a higher version number if that's the case.
Anyway, I'll build it today and test it out.
Yes, you need to update libxkbcommon, the ports revision made changes to allow for evdev rules to be used by default. The legacy rules causes keyboard issues when using evdev. I believe that KDE uses libxkbcommon directly for some things, so it needs to be updated.
 

meine

Active Member

Reaction score: 67
Messages: 133

I encountered the same problems after the update. The tty console worked just fine.

Following one of the lines here, I added
Code:
kern.evdev.rcpt_mask=6
to my /etc/sysctl.conf.

Now booting the box hangs just after 'reading' the keyboard. When pressing <enter> I get a single user root prompt, but with only part of the permissions. Because of that, I'm not able to change /etc/sysctl.conf back to its original state.

Is there any solution to that?

TIA,
 

zeising@

Member
Developer

Reaction score: 14
Messages: 21

I encountered the same problems after the update. The tty console worked just fine.

Following one of the lines here, I added
Code:
sysctl kern.evdev.rcpt_mask=6
to my /etc/sysctl.conf.

Now booting the box hangs just after 'reading' the keyboard. When pressing <enter> I get a single user root prompt, but with only part of the permissions. Because of that, I'm not able to change /etc/sysctl.conf back to its original state.

Is there any solution to that?

TIA,
Are you using ZFS or UFS?
If you're using UFS, when you get to the single user prompt, try to run:
# fsck -p
# mount -uw /
If you are using ZFS, try to run
# /etc/rc.d/zfs start

Then you should be able to edit /etc/sysctl.conf. You only need to add kern.evdev.rcpt_mask=6 there, no need to add sysctl before that line.
 

Emrion

Well-Known Member

Reaction score: 95
Messages: 374

For zfs, to get rw, it's: zfs set readonly=off zroot/ROOT/default
Provided it's a default installation.
 

meine

Active Member

Reaction score: 67
Messages: 133

If you're using UFS, when you get to the single user prompt, try to run:
# fsck -p
# mount -uw /
Thanks! I use UFS. Saving /etc/sysctl.conf is not possible.

Excuse for the 'sysctl', that was just a copy-paste error in my post.

The curious part is that 'mask=6' was said to work, but it doesn't on my box...

(regaining my n00b status, learing FreeBSD by breaking things...)
 

zeising@

Member
Developer

Reaction score: 14
Messages: 21

Thanks! I use UFS. Saving /etc/sysctl.conf is not possible.

Excuse for the 'sysctl', that was just a copy-paste error in my post.

The curious part is that 'mask=6' was said to work, but it doesn't on my box...

(regaining my n00b status, learing FreeBSD by breaking things...)
After running the commands above, you should be able to edit and save /etc/sysctl.conf. Is it still not working?
 

meine

Active Member

Reaction score: 67
Messages: 133

After running the commands above, you should be able to edit and save /etc/sysctl.conf. Is it still not working?
Nope. I got the following output:
Code:
# fsck -p
** SU+J Recovering /dev/ada0s1a
** Reading 33554432 byte journal from inode 4.
** Building recovery table.
** Resolving unreferenced inode list.
** Processing journal entries.
/dev/ada0s1a: ino 963265 nlink manipulation error, new 18446744073709551615, old -1
/dev/ada0s1a: UNEXPECTED SU+J INCONSISTENCY
/dev/ada0s1a: INTERNAL ERROR: GOT TO reply()
/dev/ada0s1a: UNEXPECTED SOFT UPDATE INCONSISTENCY; RUN fsck MANUALLY.
# mount -uw /
mount: /dev/ada0s1a: R/W mount of / denied. Filesystem is not clean -- run fsck.
Forced mount will invalidate journal contents: Operation not permitted
#
Apparently things already were wrong executing fsck -p.

Running fsck manually I found in another tread:

It should be fsck -f -y /dev/ada0s1a here?

In this tread it was mentioned that this might happen after a crash or when the machine is unproperly shut off. That indeed was the case just before I made changes to /etc/sysctrl.conf. At least that explains all this...
 
Top