Solved New Xorg switch from devd to udev

aragats

Daemon

Reaction score: 593
Messages: 1,481

Then restarting X messed up keymap at first, but it could be solved by just deleting /usr/local/etc/X11/xorg.conf.d/input.conf
But people use such files for purpose, falling back to the default keymap is not what they want.
Personally I call x11/setxkbmap from ~/.xinitrc, but many people have their keymaps configured in xorg.conf* files.
 

fernandel

Aspiring Daemon

Reaction score: 221
Messages: 893

Okay, I didn't removed evdev support from kernel because Mr. Michael Gmelin help me and he found problem in scfb driver. He made a patch and it works. I just lost middle/scrolling button in my bluetooth Apple Magic Mouse.
 

twllnbrck

Active Member

Reaction score: 163
Messages: 233

I also have problems after upgrading x11-servers/xorg-server to 1.20 with UDEV enabled via poudriere. Im using x11-wm/openbox and graphics/drm-kmod. I always get a black screen when starting X server via .xinitrc. Xorg -retro works as expected.
I got mouse and keyboard working by installing x11-drivers/xf86-input-libinput but openbox wont start properly. Still a black screen and no menu as well as other prestarted apps.
Any suggestions? I would be grateful for any help!
 

genneko

Member

Reaction score: 12
Messages: 40

But people use such files for purpose, falling back to the default keymap is not what they want.
Thanks. You're right.
I'm very bad at X and I didn't notice the keymap got back to the default because XFCE4 seems to have setup a correct keyboard layout for me (through my locale setting?).
After reading your comment, I checked the login manager screen (where XFCE4 didn't start yet) and found the keymap was not what I expected there.

So I put my previous input.conf back to /usr/local/etc/X11/xorg.conf.d and changed it to use libinput driver.
Now it seems to be working even before XFCE4 session starts, though I'm not sure if it's correctly configured. I have to learn the basics of xorg configuration ...
 

jandras

New Member

Reaction score: 1
Messages: 4

Up arrow stopped working in some cases on my keyboard when I upgraded to xorg-server 1.20 and switched to udev.
I'm using xfce 4.14 and a Microsoft Wired 600 USB keyboard.
In native xfce programs up arrow works in the pull-down menus but doesn't work elsewhere (e.g. in the file list window of thunar, in tcsh or bash running in xfce-terminal). In firefox it does not work at all, nor in the menus. Up arrow on the numeric keypad works everywhere.
I tried several different layouts in xfce keyboard settings, but it did not help.
It's the same with kern.evdev.rcpt_mask=6 and 12.
 

Emrion

Well-Known Member

Reaction score: 95
Messages: 374

With the help of what I read here, I finally made Xorg 1.20 work (or almost) on a VirtualBox VM with lxde. Well, two of my mouse buttons aren't working as before but no matter...

The thing that is anoying me is the autostart of X. I use this in /etc/crontab:
Code:
#minute hour    mday    month   wday    who     command
@reboot                                 Emrion  startx
It worked perfectly before and now I have to login in console and type startx.

Is anybody see what happened?
 

kpedersen

Daemon

Reaction score: 765
Messages: 1,760

Wait? Haven't we been here before when Xorg defaulted to requiring hald? (which was quite a pain in the butt and required me to always build a port rather than just using a package).

Is there a specific problem that needs to be solved by jumping to different systems?
 

kpedersen

Daemon

Reaction score: 765
Messages: 1,760

The thing that is anoying me is the autostart of X. I use this in /etc/crontab:
This solution isn't ideal because if the getty initializes after X, it will steal input. Also, if it is like Linux, newer Xorg requires starting from an interactive terminal. (This can be changed but I cannot recall where).

A better solution is to auto login, and then startx in your profile. Check out this post (#6):

 

fernandel

Aspiring Daemon

Reaction score: 221
Messages: 893

Up arrow stopped working in some cases on my keyboard when I upgraded to xorg-server 1.20 and switched to udev.
I'm using xfce 4.14 and a Microsoft Wired 600 USB keyboard.
In native xfce programs up arrow works in the pull-down menus but doesn't work elsewhere (e.g. in the file list window of thunar, in tcsh or bash running in xfce-terminal). In firefox it does not work at all, nor in the menus. Up arrow on the numeric keypad works everywhere.
I tried several different layouts in xfce keyboard settings, but it did not help.
It's the same with kern.evdev.rcpt_mask=6 and 12.
I do not know how you start xfce... You can try to put in your $HOME/.xinitrc:
Code:
setxkbmap -model pc105 -layout fr or whatever you use
 

CrunchBerry

New Member

Reaction score: 1
Messages: 13

this has been beyond frustrating, but I'll throw you a monkey wrench. xev reports this in xfce4 for Up


KeymapNotify event, serial 37, synthetic NO, window 0x0,
keys: 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0



for the up key but in twm it works fine.

like this from xfce but with the proper Up keypress event on code 111


KeyPress event, serial 37, synthetic NO, window 0x1e00001,
root 0x1d8, subw 0x1e00002, time 7697287, (35,51), root:(1115,262),
state 0x0, keycode 116 (keysym 0xff54, Down), same_screen YES,
XLookupString gives 0 bytes:
XmbLookupString gives 0 bytes:
XFilterEvent returns: False


I'm using ports, the tip to make a custom input config made no difference. I'm no longer using xorg.conf, just one to configure nvidia, and one for modules and fontpaths in xorg.conf.d . tried that first. using the custom config for input devices above made no difference in my Xorg.log.0 for detection, I only used it with the keyboard definitions as my mouse has been fine. I suspect this might be something in the widget libraries. I certainly am not going back to twm for Up, it works on the keypad for me. something is messed up, but if it works in twm, it isn't Xorg that seems to be broken with evdev. I might try rebuilding everything xfce depends on and it. Not clear that would help. Something is preventing the Up to map to a KeyPress event, and it seems to be within xfce for me, but not sure if a qt based desktop like kde is doing the same thing.

on occasion from twm xterm it would respond with ~[[A I believe or similar, basically the ASCII escape code for up if I recall correctly. but once focus was clearly on the xev window this went away. under xfce it doesn't work at all. can't rule out keyboard mux isn't causing issues, but xterm works fine under twm by showing terminal history on Up key, not for xfce, and not sure why.

I have kern.evdev.rcpt_mask=12 set now, had 6 per the instructions prior.
 

Minbari

Well-Known Member

Reaction score: 232
Messages: 460

With the help of what I read here, I finally made Xorg 1.20 work (or almost) on a VirtualBox VM with lxde. Well, two of my mouse buttons aren't working as before but no matter...

The thing that is anoying me is the autostart of X. I use this in /etc/crontab:
Code:
#minute hour    mday    month   wday    who     command
@reboot                                 Emrion  startx
It worked perfectly before and now I have to login in console and type startx.

Is anybody see what happened?
Put those lines in your .*rc file (bashrc/zshrc/tcshrc) at the bottom of the file and X server will start automatically after you login on vt.
Code:
if [ $( /usr/bin/tty ) = "/dev/ttyv0" ]; then
    ssh-agent && startx
    logout
 fi
 

mast07

New Member

Reaction score: 7
Messages: 19

I also have problems after upgrading x11-servers/xorg-server to 1.20 with UDEV enabled via poudriere. Im using x11-wm/openbox and graphics/drm-kmod. I always get a black screen when starting X server via .xinitrc. Xorg -retro works as expected.
I got mouse and keyboard working by installing x11-drivers/xf86-input-libinput but openbox wont start properly. Still a black screen and no menu as well as other prestarted apps.
Any suggestions? I would be grateful for any help!
Have a look at https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=244306
 

CrunchBerry

New Member

Reaction score: 1
Messages: 13

That means only one thing: xfce4 is processing that keystroke. Its keycode is assigned to an action.
You may be on to something there. I tried KDE on a whim based on your comment, and while KDE doesn't start without pieces crashing for me the Up key works fine in Konsole too. I've never mapped anything to Up on purpose, and until the update it worked fine. There is no listed shortcut assigned to it, but perhaps its keyboard mapping routines are glitched. Maybe its Gtk that has some kind of glitch in it. Maybe I need to manually parse the config files.
Been wanting to switch to kde for a while, but it seems to be a train wreck with crashes so i just wait and give it a whirl once in a while after large chunks see updates. might have to see if I can resolve them on my system. this isn't the first time xfce has been broken for me. my favorite is when it starts crashing on new directory creation or renaming, or when doing updates and the whole desktop crashes out the panels and interfaces. least Mate never did that too me. if only e16 was still an option...

the bug posted seems to apply to drm when using the drm-kmods which I don't have. just using stock with modesetting nvidia driver from ports. I'll have to dig a little deeper or hope someone smarter figures out the root.

Anyone running Gnome? does the keyboard work there? I'd try Mate but this I no longer have it on a fresh machine and don't want to go back.
 

JohnnySorocil

Member

Reaction score: 13
Messages: 78

I had this problem after I replaced keyboard on my laptop (ThinkPad T430s) and rebooted machine - I was able to login normally, start WM, start xterm, keyboard and mouse were working all normal.
But if I tried to start firefox - the whole GUI will (almost) freeze - I can move trackpoint, but cannot use keyboard. I think that clock in the GUI was stop also (so whole GUI was frozen, reason for trackpoint working maybe because it was managed by moused). At first I blame new keyboard but the problem was the same with old one. Reinstalling Firefox, Xorg server and others did have effect.

Anyway, after trying a few combinations this one worked for me and my Firefoxes :)
Code:
pkg install -y xf86-input-libinput
portmaster --force-config xorg-server # selected: FIXDRM and UDEV
# ls /usr/local/etc/X11/xorg.conf.d
20-intel.conf  flags.conf  layout.conf  trackpoint.conf
 

malavon

Active Member

Reaction score: 144
Messages: 241

Thanks for everyone in this thread, at least I managed to get Xorg back up and running with my trusty ps2 keyboard.
I'm also getting the down arrow/end/pgdn issue which opens the plasma launcher. Annoying as hell :(
Right now I'm running with DEVD and FIXDRM, but UDEV had the same issue for me.
 

mickey

Aspiring Daemon

Reaction score: 147
Messages: 519

In retrospective the recent changes seem to have a lot of potential to break things for users one way or the other.
For some x11-drivers/xf86-input-libinput seemed to be missing, which should be fixed by resetting the port options of the x11-drivers/xorg-drivers meta-port to their defauilts which now includes libinput, so that it pulls in x11-drivers/xf86-input-libinput as a dependency. In my case the problem has been that the keyboard driver which had been working flawlessly so far now produces all kinds of odd results ranging from garbled keyboard input to no keyboard input at all. Switching to libinput driver instead seems to have fixed that. And then there is the kern.evdev.rcpt_mask sysctl that adds to the confusion and requires an understanding of what each bit value does:
Code:
0x01  SYSMOUSE     This requires that moused(8) is running.
0x02  KBDMUX       This requires a kernel that has the kbdmux(4) driver (GENERIC kernel has it)
0x04  HWMOUSE      Hardware mouse (as opposed to sysmouse)
0x08  HWKBD        Hardware keyboard (as opposed to kbdmux)
The default value is 3, so if you're running GENERIC kernel (or one that includes kbdmux) and want to use moused(8) you are fine without even touching kern.evdev.rcpt_mask. If you want to go without moused(8) then remove SYSMOUSE and replace it with HWMOUSE, so use a value of 6. If you want neither SYSMOUSE nor KBDMUX use a value of 12.

Lastly if you need to adjust keyboard settings (layout, model, special keys, etc) I don't see why you would be doing this in your .xinitrc file or elsewhere, when the solution is simply to do it in your xorg.conf (Whether you use a single monolithic xorg.conf file or individual files in /usr/local/etc/X11/xorg.conf.d is entirely up to you). Just make sure you do it the right way by using InputClass sections and not using InputDevice sections. You can even use multiple InputClass sections if you feel the need for it, in that case ordering of the sections should be from most generic to most specific. InputClass sections can match on a variety of criteria, consult xorg.conf(5) for details.
For example I use one InputClass section to switch the keyboard layout for all keyboards to german without dead keys and a second InputClass section to configure my PS/2 keyboard to be a 102-key model instead of the default 105-key (who needs windows keys anyways?):
Code:
# Assume some sane defaults for all keyboards.

Section "InputClass"
        Identifier              "Keyboard Defaults"
        MatchIsKeyboard         "yes"
        Option                  "XkbLayout"     "de"
        Option                  "XkbVariant"    "nodeadkeys"
        Option                  "XkbOptions"    "numpad:pc,kpdl:dot"
EndSection

# PS/2 system keyboard is a 102-key model.

Section "InputClass"
        Identifier              "PS/2 System Keyboard"
        MatchIsKeyboard         "yes"
        MatchProduct            "AT keyboard"
        Option                  "XkbModel"      "pc102"
EndSection
And for what it's worth, I am using KDE and Firefox and not seeing any problems with my down/end keys so far.
 

jans

New Member

Reaction score: 1
Messages: 6

I still can't get my keyboard to work, and the input in my login manager is garbaged after I changed my pkg source from quarterly to latest this morning. See https://forums.freebsd.org/threads/input-on-login-screen-garbaged-after-pkg-upgrade.74242/ for details.

I've tried to set kern.evdev.rcpt_mask to 12, removed all keyboard sections in /usr/local/etc/X11/xorg.conf.d and checked that x11-drivers/xf86-input-libinput is installed. I also played with different setxkbmap-settings in my .xinitrc. But I still can't log into X as I am not able to type my username and password. Do you have any more ideas?
 

jans

New Member

Reaction score: 1
Messages: 6

Solved. Removing the Driver "Keyboard" from *all* files did the trick (missed one of two files in xorg.conf.d when I tried the first time).
 

malavon

Active Member

Reaction score: 144
Messages: 241

I've tried to set kern.evdev.rcpt_mask to 12, removed all keyboard sections in /usr/local/etc/X11/xorg.conf.d and checked that x11-drivers/xf86-input-libinput is installed. I also played with different setxkbmap-settings in my .xinitrc. But I still can't log into X as I am not able to type my username and password. Do you have any more ideas?
Check your logs. I had the same issue because I still had files that set the driver in separate files. I had files to set both the keyboard settings but I also had one to configure 'zapping' behaviour (killing Xorg with ctrl+alt+backspace).
If any of the normal keyboard drivers is still present, that'll cause this behaviour (check next section, driver is commented out).
Code:
> cat /usr/local/etc/X11/xorg.conf.d/keyboard-zap.conf
Section "InputClass"
        Identifier      "KeyboardDefaults"
#       Driver          "keyboard"
        MatchIsKeyboard "on"
        Option          "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
I don't have any of my previous logs with that behaviour anymore, but this is what they contain now:
Code:
[    23.927] (II) config/devd: detected event input: System keyboard multiplexer, bustype=0006, vendor=0000, product=0000, version=0000
[    23.927] (II) config/devd: adding input device /dev/input/event1
[    23.927] (**) System keyboard multiplexer: Applying InputClass "evdev keyboard catchall"
[    23.927] (**) System keyboard multiplexer: Applying InputClass "Evdev keyboard"
[    23.927] (**) System keyboard multiplexer: Applying InputClass "libinput keyboard catchall"
[    23.927] (**) System keyboard multiplexer: Applying InputClass "KeyboardDefaults"
[    23.927] (**) System keyboard multiplexer: Applying InputClass "KeyboardDefaults"
[    23.927] (II) Using input driver 'libinput' for 'System keyboard multiplexer'
[    23.927] (**) System keyboard multiplexer: always reports core events
[    23.927] (**) Option "Device" "/dev/input/event1"
[    23.928] (**) Option "_source" "server/devd"
[    23.928] (II) event1  - System keyboard multiplexer: is tagged by udev as: Keyboard
[    23.928] (II) event1  - System keyboard multiplexer: device is a keyboard
[    23.928] (II) event1  - System keyboard multiplexer: device removed
[    23.928] (**) Option "config_info" "devd:/dev/input/event1"
[    23.928] (II) XINPUT: Adding extended input device "System keyboard multiplexer" (type: KEYBOARD, id 7)
[    23.928] (**) Option "xkb_rules" "evdev"
[    23.928] (**) Option "xkb_layout" "be"
[    23.928] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
 

CrunchBerry

New Member

Reaction score: 1
Messages: 13

Check your logs. I had the same issue because I still had files that set the driver in separate files. I had files to set both the keyboard settings but I also had one to configure 'zapping' behaviour (killing Xorg with ctrl+alt+backspace).
If any of the normal keyboard drivers is still present, that'll cause this behaviour (check next section, driver is commented out).
Code:
> cat /usr/local/etc/X11/xorg.conf.d/keyboard-zap.conf
Section "InputClass"
        Identifier      "KeyboardDefaults"
#       Driver          "keyboard"
        MatchIsKeyboard "on"
        Option          "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
I don't have any of my previous logs with that behaviour anymore, but this is what they contain now:
Code:
[  3416.468] (II) config/udev: Adding input device System mouse (/dev/input/event0)
[  3416.468] (**) System mouse: Applying InputClass "evdev pointer catchall"
[  3416.468] (**) System mouse: Applying InputClass "libinput pointer catchall"
[  3416.468] (II) LoadModule: "libinput"
[  3416.469] (II) Loading /usr/local/lib/xorg/modules/input/libinput_drv.so
[  3416.471] (II) Module libinput: vendor="X.Org Foundation"
[  3416.471]     compiled for 1.20.7, module version = 0.28.2
[  3416.471]     Module class: X.Org XInput Driver
[  3416.471]     ABI class: X.Org XInput driver, version 24.1
[  3416.471] (II) Using input driver 'libinput' for 'System mouse'
[  3416.471] (**) System mouse: always reports core events
[  3416.471] (**) Option "Device" "/dev/input/event0"
[  3416.471] (**) Option "_source" "server/udev"
[  3416.473] (II) event0  - System mouse: is tagged by udev as: Mouse
[  3416.474] (II) event0  - System mouse: device is a pointer
[  3416.474] (II) event0  - System mouse: device removed
[  3416.474] (**) Option "config_info" "udev:/dev/input/event0"
[  3416.474] (II) XINPUT: Adding extended input device "System mouse" (type: MOUSE, id 6)
[  3416.474] (**) Option "AccelerationScheme" "none"
[  3416.474] (**) System mouse: (accel) selected scheme none/0
[  3416.474] (**) System mouse: (accel) acceleration factor: 2.000
[  3416.474] (**) System mouse: (accel) acceleration threshold: 4
[  3416.475] (II) event0  - System mouse: is tagged by udev as: Mouse
[  3416.475] (II) event0  - System mouse: device is a pointer
[  3416.475] (II) config/udev: Adding input device System keyboard multiplexer (/dev/input/event1)
[  3416.475] (**) System keyboard multiplexer: Applying InputClass "evdev keyboard catchall"
[  3416.475] (**) System keyboard multiplexer: Applying InputClass "Evdev keyboard"
[  3416.475] (**) System keyboard multiplexer: Applying InputClass "libinput keyboard catchall"
[  3416.475] (II) Using input driver 'libinput' for 'System keyboard multiplexer'
[  3416.475] (**) System keyboard multiplexer: always reports core events
[  3416.475] (**) Option "Device" "/dev/input/event1"
[  3416.476] (**) Option "_source" "server/udev"
[  3416.476] (II) event1  - System keyboard multiplexer: is tagged by udev as: Keyboard
[  3416.476] (II) event1  - System keyboard multiplexer: device is a keyboard
[  3416.477] (II) event1  - System keyboard multiplexer: device removed
[  3416.477] (**) Option "config_info" "udev:/dev/input/event1"
[  3416.477] (II) XINPUT: Adding extended input device "System keyboard multiplexer" (type: KEYBOARD, id 7)
[  3416.477] (**) Option "xkb_rules" "evdev"
[  3416.504] (II) event1  - System keyboard multiplexer: is tagged by udev as: Keyboard
[  3416.504] (II) event1  - System keyboard multiplexer: device is a keyboard
[  3416.504] (II) config/udev: Adding input device AT keyboard (/dev/input/event2)
[  3416.504] (**) AT keyboard: Applying InputClass "evdev keyboard catchall"
[  3416.504] (**) AT keyboard: Applying InputClass "Evdev keyboard"
[  3416.504] (**) AT keyboard: Applying InputClass "libinput keyboard catchall"
[  3416.504] (II) Using input driver 'libinput' for 'AT keyboard'
[  3416.504] (**) AT keyboard: always reports core events
[  3416.504] (**) Option "Device" "/dev/input/event2"
[  3416.504] (**) Option "_source" "server/udev"
[  3416.505] (II) event2  - AT keyboard: is tagged by udev as: Keyboard
[  3416.505] (II) event2  - AT keyboard: device is a keyboard
[  3416.506] (II) event2  - AT keyboard: device removed
[  3416.506] (**) Option "config_info" "udev:/dev/input/event2"
[  3416.506] (II) XINPUT: Adding extended input device "AT keyboard" (type: KEYBOARD, id 8)
[  3416.506] (**) Option "xkb_rules" "evdev"
[  3416.506] (II) event2  - AT keyboard: is tagged by udev as: Keyboard
[  3416.506] (II) event2  - AT keyboard: device is a keyboard
[  3416.507] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event3)
[  3416.507] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
[  3416.507] (**) Logitech USB Receiver: Applying InputClass "Evdev keyboard"
[  3416.507] (**) Logitech USB Receiver: Applying InputClass "libinput keyboard catchall"
[  3416.507] (II) Using input driver 'libinput' for 'Logitech USB Receiver'
[  3416.507] (**) Logitech USB Receiver: always reports core events
[  3416.507] (**) Option "Device" "/dev/input/event3"
[  3416.507] (**) Option "_source" "server/udev"
[  3416.508] (II) event3  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: is tagged by udev as: Keyboard
[  3416.508] (II) event3  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: device is a keyboard
[  3416.508] (II) event3  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: device removed
[  3416.508] (**) Option "config_info" "udev:/dev/input/event3"
[  3416.508] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 9)
[  3416.508] (**) Option "xkb_rules" "evdev"
[  3416.509] (II) event3  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: is tagged by udev as: Keyboard
[  3416.509] (II) event3  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: device is a keyboard
[  3416.510] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event4)
[  3416.510] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"
[  3416.510] (**) Logitech USB Receiver: Applying InputClass "libinput pointer catchall"
[  3416.510] (II) Using input driver 'libinput' for 'Logitech USB Receiver'
[  3416.510] (**) Logitech USB Receiver: always reports core events
[  3416.510] (**) Option "Device" "/dev/input/event4"
[  3416.510] (**) Option "_source" "server/udev"
[  3416.511] (II) event4  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: is tagged by udev as: Mouse
[  3416.511] (II) event4  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: device is a pointer
[  3416.511] (II) event4  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: device removed
[  3416.511] (**) Option "config_info" "udev:/dev/input/event4"
[  3416.511] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: MOUSE, id 10)
[  3416.511] (**) Option "AccelerationScheme" "none"
[  3416.511] (**) Logitech USB Receiver: (accel) selected scheme none/0
[  3416.511] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000
[  3416.511] (**) Logitech USB Receiver: (accel) acceleration threshold: 4
[  3416.512] (II) event4  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: is tagged by udev as: Mouse
[  3416.512] (II) event4  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: device is a pointer
nvidiaglx.conf
Code:
Section "Device"
    Identifier  "Card0"
    Driver      "nvidia"
    BusID       "PCI:2:0:0"
EndSection

# must let doom3 to work...
Section "ServerFlags"
    Option "AllowIndirectGLX" "on"
    Option "IndirectGLX" "on"
EndSection

#config screens
Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Westinghouse"
    ModelName    "LCM-22w3"
EndSection
files.conf
Code:
Section "Files"
    ModulePath   "/usr/local/lib/xorg/modules"
    FontPath     "/usr/local/share/fonts/misc/"
    FontPath     "/usr/local/share/fonts/TTF/"
    FontPath     "/usr/local/share/fonts/OTF/"
    FontPath     "/usr/local/share/fonts/Type1/"
    FontPath     "/usr/local/share/fonts/100dpi/"
    FontPath     "/usr/local/share/fonts/75dpi/"
EndSection
I have no other conf files in /usr/local/etc/X11/xorg.conf I deleted anything configuring the input sections in the first stabs at fixing this as they used to use the keyboard driver instead of edev. Xorg is just autoconfiguring the rest.

the log makes no sense because with a mask set to 12 i don't see why Xorg is attaching the keyboard multiplexer via edev in the first place. I thought the point of the mask was it would only use the hardware for edev.

Code:
$} sysctl -a | grep rcpt_mask
kern.evdev.rcpt_mask: 12
Code:
[   116.083]     ABI class: X.Org XInput driver, version 24.1
[   116.083] (II) Using input driver 'libinput' for 'System mouse'
[   116.083] (**) System mouse: always reports core events
[   116.083] (**) Option "Device" "/dev/input/event0"
[   116.083] (**) Option "_source" "server/udev"
[   116.303] (II) event0  - System mouse: is tagged by udev as: Mouse
[   116.303] (II) event0  - System mouse: device is a pointer
[   116.303] (II) event0  - System mouse: device removed
[   116.303] (**) Option "config_info" "udev:/dev/input/event0"
[   116.303] (II) XINPUT: Adding extended input device "System mouse" (type: MOUSE, id 6)
[   116.304] (**) Option "AccelerationScheme" "none"
[   116.304] (**) System mouse: (accel) selected scheme none/0
[   116.304] (**) System mouse: (accel) acceleration factor: 2.000
[   116.304] (**) System mouse: (accel) acceleration threshold: 4
[   116.304] (II) event0  - System mouse: is tagged by udev as: Mouse
[   116.305] (II) event0  - System mouse: device is a pointer
[   116.305] (II) config/udev: Adding input device System keyboard multiplexer (/dev/input/event1)
[   116.305] (**) System keyboard multiplexer: Applying InputClass "evdev keyboard catchall"
[   116.305] (**) System keyboard multiplexer: Applying InputClass "Evdev keyboard"
[   116.305] (**) System keyboard multiplexer: Applying InputClass "libinput keyboard catchall"
[   116.305] (II) Using input driver 'libinput' for 'System keyboard multiplexer'
[   116.305] (**) System keyboard multiplexer: always reports core events
[   116.305] (**) Option "Device" "/dev/input/event1"
[   116.305] (**) Option "_source" "server/udev"
[   116.306] (II) event1  - System keyboard multiplexer: is tagged by udev as: Keyboard
[   116.306] (II) event1  - System keyboard multiplexer: device is a keyboard
[   116.306] (II) event1  - System keyboard multiplexer: device removed
[   116.306] (**) Option "config_info" "udev:/dev/input/event1"
[   116.306] (II) XINPUT: Adding extended input device "System keyboard multiplexer" (type: KEYBOARD, id 7)
[   116.306] (**) Option "xkb_rules" "evdev"
[   116.344] (II) event1  - System keyboard multiplexer: is tagged by udev as: Keyboard
[   116.344] (II) event1  - System keyboard multiplexer: device is a keyboard
[   116.345] (II) config/udev: Adding input device AT keyboard (/dev/input/event2)
[   116.345] (**) AT keyboard: Applying InputClass "evdev keyboard catchall"
[   116.345] (**) AT keyboard: Applying InputClass "Evdev keyboard"
[   116.345] (**) AT keyboard: Applying InputClass "libinput keyboard catchall"
[   116.345] (II) Using input driver 'libinput' for 'AT keyboard'
[   116.345] (**) AT keyboard: always reports core events
[   116.345] (**) Option "Device" "/dev/input/event2"
[   116.345] (**) Option "_source" "server/udev"
[   116.346] (II) event2  - AT keyboard: is tagged by udev as: Keyboard
[   116.346] (II) event2  - AT keyboard: device is a keyboard
[   116.346] (II) event2  - AT keyboard: device removed
[   116.346] (**) Option "config_info" "udev:/dev/input/event2"
[   116.346] (II) XINPUT: Adding extended input device "AT keyboard" (type: KEYBOARD, id 8)
[   116.346] (**) Option "xkb_rules" "evdev"
[   116.347] (II) event2  - AT keyboard: is tagged by udev as: Keyboard
[   116.347] (II) event2  - AT keyboard: device is a keyboard
[   116.347] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event3)
[   116.347] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
[   116.347] (**) Logitech USB Receiver: Applying InputClass "Evdev keyboard"
[   116.347] (**) Logitech USB Receiver: Applying InputClass "libinput keyboard catchall"
[   116.347] (II) Using input driver 'libinput' for 'Logitech USB Receiver'
[   116.347] (**) Logitech USB Receiver: always reports core events
[   116.347] (**) Option "Device" "/dev/input/event3"
[   116.347] (**) Option "_source" "server/udev"
[   116.348] (II) event3  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: is tagged by udev as: Keyboard
[   116.348] (II) event3  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: device is a keyboard
[   116.349] (II) event3  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: device removed
[   116.349] (**) Option "config_info" "udev:/dev/input/event3"
[   116.349] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 9)
[   116.349] (**) Option "xkb_rules" "evdev"
[   116.350] (II) event3  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: is tagged by udev as: Keyboard
[   116.350] (II) event3  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: device is a keyboard
[   116.350] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event4)
[   116.350] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"
[   116.350] (**) Logitech USB Receiver: Applying InputClass "libinput pointer catchall"
[   116.350] (II) Using input driver 'libinput' for 'Logitech USB Receiver'
[   116.350] (**) Logitech USB Receiver: always reports core events
[   116.350] (**) Option "Device" "/dev/input/event4"
[   116.350] (**) Option "_source" "server/udev"
[   116.351] (II) event4  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: is tagged by udev as: Mouse
[   116.351] (II) event4  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: device is a pointer
[   116.351] (II) event4  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: device removed
[   116.351] (**) Option "config_info" "udev:/dev/input/event4"
[   116.351] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: MOUSE, id 10)
[   116.352] (**) Option "AccelerationScheme" "none"
[   116.352] (**) Logitech USB Receiver: (accel) selected scheme none/0
[   116.352] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000
[   116.352] (**) Logitech USB Receiver: (accel) acceleration threshold: 4
[   116.352] (II) event4  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: is tagged by udev as: Mouse
[   116.353] (II) event4  - Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 2: device is a pointer
my keyboard is mapped as a pc105
Code:
$} setxkbmap -query
rules:      evdev
model:      pc105
layout:     us
this is beyond a simple X11 configuration issue, when the exact same configs work under twm and kde, and I'd switch to kde if it didn't just crash components on launch for me. the Up key doesn't map XKeypress events under xfce, its fine under kde and twm. If xorg config was tweaked wrong it should be broken in any window manager/desktop environment. keyboard layout in xfce doesn't make a difference when explicitly told its a pc105 keyboard versus use system default. even a trusty regular old ps/2 keyboard didn't resolve the issue.
 
Top