Solved Network in the base system stopped working after installing VMs or due to causes unknown

I installed debian and Ubuntu in a bhyve virtual environment, the network bridge did not work for the VMs, tried to troubleshoot this, all the while with kernel security lowered to -1, at one point the base system was frozen and after a hard reboot, there is a login loop for KDE plasma 5, and the network interface doesn't obtain the IP address. I can access the console by CTL alt F1 etc. and could disable VM related settings and disable thebridges, or boot to single user mode, but several reboots later there is no network and I can't get to plasma. Checked rc conf sysctl conf boot loader conf, don't know what other configurations to check.

Network connects, but ping 8.8.8.8 returns no route to host.

host.pkg.freebsd.org returns ;; connection timed out

dhclient re0 returns

sbin/dhclient 1: Syntax error: "(" unexpectedsyntax error in command substitution.

sbin/dhclient shows a file in machine readable characters (in part) or the file is corrupt.

Tried adding default router by specifying router private ip, enabled gateway, dhcpd, tried everything multiple times, doesn't work. Another old computer works.

This is resolved. IN .Xauthority there was a permissions problem, a file setting corruption that must have occurred, which prevented the usual plasma login; Some configuration changes brought back network. Thank you.
 
Last edited:
Top