ZFS mountroot fails error 5

Gowen

New Member


Messages: 1

Hello, I asked it on maillist freebsd-questions, but no answers.

I have a server with 2x2TB with geli + zfs-mirror disks and zfs on root with gptzfsboot. Disks are ada0 and ada1. Previously they were at ada1 and ada2.

I get stuck at mountroot> stage. System starts, I input the passphrase, get the menu and FreeBSD starts to load, but I get this message

Code:
Solaris: NOTICE: Cannot find the pool label for 'interno'

Mounting from zfs:interno/ROOT/default failed with error 5

Loader variables:
  vfs.root.mountfrom=zfs:interno/ROOT/default

Manual root filesystem specification:
  <fstype>:<device> [option]
      Mount <device> using filesystem <fstype> and with the specified (optional) option list.
 
    eg. ufs:/dev/da0s1a
        zfs:tank
        cd9660:/dev/cd0 ro

?                      List valid disk bootdevices
.                       Yield 1 second (for background tasks)
<empty line>  Abort manual input

mountroot>
If I type ? , I get the list of devices

Code:
mountroot> ?
List of GEOM managed disk devices:
  gpt/data2 gpt/boot2 ada1p3 ada1p2 ada1p1 gpt/data1 gpt/boot1 ada1 ada0p3 ada0p2 ada0p1 ada0
The zfs partitions are at ada0p3 and ada1p3, but they should be at ada0p3.eli and ada1p3.eli

I tried zfs: with all of them, nothing worked. I tried the zpool name, 'interno', again without success.

What should I do?

Is there any manual about mountroot? Can't find on handbooks

Thanks in Advance
 

Emrion

Active Member

Reaction score: 36
Messages: 182

Hello and welcome,

I tried to reproduce your problem in a VM but to no avail. I think there is something you didn't mention and that thing makes all the difference.

Disks are ada0 and ada1. Previously they were at ada1 and ada2.
Can you explain how you got this?
 
Top