Install samba45 from ports end up with ldb deps error

labiol

New Member


Messages: 3

Code:
Installing tdb-1.4.2,1...
===>   samba45-4.5.16_1 depends on package: tdb>=1.3.10 - found
===>   Returning to build of samba45-4.5.16_1
===>   samba45-4.5.16_1 depends on package: ldb>=1.1.27 - not found
===>   samba45-4.5.16_1 depends on package: ldb>=1.1.27 - not found
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/net/samba45
*** Error code 1


Installing ldb from pkg:

Code:
Checking integrity... done (6 conflicting)
  - talloc1-2.1.14 conflicts with talloc-2.3.0 on /usr/local/include/talloc.h
  - talloc1-2.1.14 conflicts with talloc-2.3.0 on /usr/local/include/talloc.h
  - tevent1-0.9.37 conflicts with tevent-0.10.1 on /usr/local/include/tevent.h
  - tevent1-0.9.37 conflicts with tevent-0.10.1 on /usr/local/include/tevent.h
  - tdb1-1.3.16,1 conflicts with tdb-1.4.2,1 on /usr/local/include/tdb.h
  - tdb1-1.3.16,1 conflicts with tdb-1.4.2,1 on /usr/local/include/tdb.h
Checking integrity... done (0 conflicting)
The following 7 package(s) will be affected (of 0 checked):

Installed packages to be REMOVED:
        tdb-1.4.2,1
        tevent-0.10.1
        talloc-2.3.0

New packages to be INSTALLED:
        ldb: 1.1.29_3
        talloc1: 2.1.14
        tevent1: 0.9.37
        tdb1: 1.3.16,1

forces to install tevent1, which in turn is not compatible with samba ...

Code:
freebsd-version
12.1-RELEASE-p2

Ports and pkg refreshed.
 
Last edited by a moderator:

Emrion

Aspiring Daemon

Reaction score: 155
Messages: 544

It probably won't help you but... I wonder two things: the first one is why samba45 is yet in ports as it's EoL since june 2018? The second is: why do you want to install this very version? The last one is samba410.
 
OP
L

labiol

New Member


Messages: 3

Good point. It is my home installation, so I just jumped to directory with older samba not thinking a lot of this. With samba410 installation completed.
Thanks!!!! Also, fbsd should no longer keep the samba45 version in ports as there is a dependency issue...
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,185
Messages: 35,689

Also, fbsd should no longer keep the samba45 version in ports as there is a dependency issue...
Maybe you should update your ports tree? net/samba45 was removed almost 2 years ago.

Code:
This port expired on: 2018-06-13
 
Top