Solved i3: Specificed font and mouse cursor is ignored

Hello guys! I recently installed my first BSD System with FreeBSD!

Almost everything worked perfectly, but I got one minor problem.

I noticed that, when I installed Visual Studio Code the font for Firefox, Chromium, PavuControl changed. They use the same font as VSCode (as can be seen in the attachment).
But I never specificed this font to be used anywhere.
In Firefox and Chromium I can set a font in the settings, which is however, completely ignored by Firefox and Chromium.
So, I tried setting a default font with lxappearance. Didn't work either.
lxappearance itself is the only application which uses the font accordingly.
One could argue Firefox, Chromium and vscode are not gtk, but pavucontrol is a gtk application, which also ignores the font setting.
Thats my problem with the font. (For example, in lxappearance I set Hack Font)

I also installed a cursor theme, which I also set using lxappearance.
In Firefox and Chromium the right cursor is used.
When I'm over my background or on my terminal emulator, then it switches back to the old one, which I don't understand why it does that.
Any ideas? I'm clueless

Best regards
 

Attachments

  • image.png
    image.png
    135.4 KB · Views: 84
Complication are caused by mixture of GUI frameworks used by different apps. You essentially need to know which framework those apps are using, like Qt5, GTK2, GTK3, tk etc. Mostly each framework has its own configuration tool (you need to manually edit config file), after all i3 is a manual tilling window manager. ;)
A solution is to use x11/xsettingsd.
e.g.:

Code:
[CODE]# Configure our fonts.
Xft/Antialias 1
Xft/HintStyle "hintfull"
Xft/Hinting 1
Xft/RGBA "none"
Xft/lcdfilter "none"
More info here and here.
 
Back
Top