Solved How do you see which processes are downloading data?

What I see now is that Conky is constantly registering a light download. I've never seen this before unless I'm using an extender, but I'm not using an extender now.
systat -ifstat also records this constant download. It fluctuates around 0.035 KB per second. There is no constant upload.

So I wonder why this suddenly changed.
When I do sockstat -l I see the following processes:
dbus daemon
I don't see anything else.
Can it be the service for VirtualBox when I'm not using VB. I'll check this and see if it helps if I disable this service.

In FreeBSD, how can you see in real time which processes are downloading data?
For the PID, there is a question mark on all entries. For USER it says root. For PROGRAM, I don't see the name of a program. I only see a few different entries with my 'internal IP' and then I think a different IP address and then a colon and a (port) number. At the end there is also the 'unknown TCP' that is displayed under program. It also states how much data is sent and received.

It also does not give the name of the program/process in my case, which I think is the intention of this program.
What I see now is that Conky is constantly registering a light download.
Your network card might just be receiving something. Doesn't have to be a download, think of things, other devices, broadcasting on your network. Things like DLNA for example, or other UPnP types of traffic like Avahi/zeroconf and/or mDNS. Windows also tends to loudly proclaim its presence on the network. Your system may not actually use any of it but it certainly is going to receive it.

One way to find out is just to actually look at the traffic, tcpdump(1) is the typical tool for that.
systat -ifstat gives me this - box doing nothing much apart from my ssh session:
      Interface           Traffic               Peak                Total
           bge0  in      0.036 KB/s          0.038 KB/s            1.463 MB
                 out     0.103 KB/s          0.249 KB/s          986.687 KB

Assume you're not using ssh (and if you were you'd have some outgoing).
Any Windows machine is very noisy on the network as pointed out. mDNS is another one seen a lot, phones when they switch to wifi if the wifi is on your same network segment are also very chatty.

Basically anything sent to a broadcast address has a chance of hitting your network interface, even if it gets rejected.
as pointed out, tcpdump run as root or sudo gives you the definitive answer.
To solve the problem, I had restarted my computer a few times yesterday while troubleshooting. But I had never turned the PC off completely.
Then last night I had turned off my PC completely (and also turned off the switch so that it no longer got power).
Today, when I turned on the computer, I immediately saw that the 'constant download' had disappeared in Conky.

The theory that it could be caused by a smartphone or windows computer seems strange to me.
Why is an Android smartphone or a windows computer using the same router suddenly going to start sending a signal to my PC if it never used to?
The problem is solved at the moment. I will try to investigate it further if it were to return.