Solved Help Please - Controller Card Driver Install

Warfaire

New Member


Messages: 3

I am going to start off and say that I have very very limited experience with CLi in Linux and I am finding out FreeBSD is different. I have a Highpoint Rocket Raid 3740A card that I need to get installed on my FREEBSD system.

Attached is the readme file and I also have a link to the driver here. I need a step by step, better than the readme instructions on how to install this driver. I am having a very hard time even following what it is telling me to do.

For example. Step 1. " Install Kernel source package and building tools." - - I have no idea what this even means.

and in step 2 it asks me to go into directory /usr/src/sys/ - - but there is no such directory.

I have been watching videos and reading other forums and posts and How To's for over 2 weeks and I still am completely lost. Everything else in the system works except that I cannot get this card installed. I know the card works as it is new. Bought new; and bios sees it as well as when I tested it with both windows and unraid bootable trial usb just to test.

Highpoint assured me that it works with all versions of FreeBSD but they just told me to follow the readme...

Before people start replying with other recommendations such as go to an OS I am comfortable in; I am really looking for step by step for this one in FreeBSD. I found one with .ko files but this driver doesn't use .ko's so I'm even more lost.

Thank you all.

~k

 

Attachments

  • rr3740a-Readme.txt
    7.3 KB · Views: 77

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 11,557
Messages: 37,877

Code:
% man -k rocketraid
hpt27xx(4) - HighPoint RocketRAID 27xx SAS 6Gb/s HBA card driver
hptiop(4) - HighPoint RocketRAID 3xxx/4xxx device driver
hptmv(4) - HighPoint RocketRAID 182x device driver
hptrr, rr232x(4) - HighPoint RocketRAID device driver
So, hptiop(4) is the most likely.
 
OP
W

Warfaire

New Member


Messages: 3

so oddly enough the patch worked using the hptiop driver set and not the one listed on the highpoint site for the 37xx series.
 
Top