GNOME 3 locking after login


Deleted member 67029

Alain, you really need to find yourself a woman. You have way too much time on hand.

Beastie7, thanks for the advice.

Deleted member 67029

I just went to another virtual terminal and rebooted from root. The problem didn't return this time.

Anyway, it works now and if it happens again I know what to do.

I am off to bed! Night
I had the same problem and the cause was GDM, I solved it by installing sddm. And now everything works great

pkg install sddm

IMPORTANT: I don't know how, but gdm selected the "gnome wayland session" by default. Change that to "gnome in Xorg" and everything should work

Deleted member 67029


No I didn't, I had just installed FreeBSD, I hadn't even had time to make any adjustments yet. I think the bug is with GNOME 3 itself. If I had time I would have deleted the files one by one to isolate the cause, then analyse it, but I had 4 hours sleep the night before and was 4 hours past my bedtime. Wiping out the home directory was a kamakazi last effort to fix it as I was planning on wiping out the virtual machine anyway.

Deleted member 67029

So I installed FreeBSD 12.2-RELEASE again, setup my NIC, installed the packages 'xorg', 'gnome3', and 'sudo'.. went to put a pizza in the oven and have a piss, came back to a locked screen, tried unlock it and now it's stuck again... just when things where starting to get exciting!
I am running FreeBSD 12.2-RELEASE. After I login to GNOME 3, it locks the screen. Then when I enter my password, it says authentication failure. Then when I try and enter my password again, I can't enter my password - I type but nothing shows up.

What could be causing this problem?
I assume you are experiencing this bug:
I had to disable GDM and now use startx to launch gnome-sessions.
Last edited:
I am using FreeBSD13.0, I have exactly the same problem, I'm not using root.
I have used all the solutions can not solve, the log does not have any relevant information.

# pkg info | grep -E "gnome|gdm"
chrome-gnome-shell-10.1        GNOME Shell integration for Chrome
gdm-3.28.4_6                   GNOME 3 display manager
gnome-autoar-0.3.1             Glib wrapper around libarchives
gnome-backgrounds-3.38.0       Collection of backgrounds for GNOME
gnome-calculator-40.1          GNOME 3 calculator tool
gnome-calendar-3.38.2          Simple and beautiful calendar application for GNOME
gnome-color-manager-3.36.0     Session framework for the GNOME desktop to manage color profiles
gnome-control-center-3.38.6    Control center for GNOME 3 project
gnome-desktop-3.38.2           Additional UI API for GNOME 3
gnome-icon-theme-extras-3.12.0 Additional collection of icons for the GNOME desktop
gnome-icon-theme-symbolic-3.12.0 GNOME Symbolic Icons
gnome-keyring-3.36.0_1         Program that keeps passwords and other secrets
gnome-menus-3.36.0             Implementation of the FreeDesktop Desktop Menu Spec
gnome-online-accounts-3.40.0   Interface provider to access the user's online accounts
gnome-power-manager-3.32.0     Power management system for the GNOME Desktop
gnome-session-3.38.0_1         Session component for the GNOME 3 desktop
gnome-settings-daemon-3.38.2   GNOME 3 settings daemon
gnome-shell-3.36.6_7           Next generation GNOME desktop shell
gnome-shell-extensions-3.36.3  GNOME desktop shell extensions
gnome-system-monitor-40.1      GNOME 3 system monitor program
gnome-terminal-3.40.2          Terminal component for the GNOME 3 Desktop
gnome-themes-extra-3.28_2      Standard themes for GNOME
gnome-tweaks-3.34.1_1          Allows to tweak some hidden settings in GNOME3
gnome-video-effects-0.5.0      Collection of Gstreamer effects
gnome3-lite-3.36_4             The "meta-port" of the GNOME desktop slimmed down for only the basics
gnome_subr-1.0                 Common startup and shutdown subroutines used by GNOME scripts
libgnome-keyring-3.12.0_2      Program that keeps passwords and other secrets
libgnomekbd-3.26.1             GNOME keyboard shared library
libproxy-gnome3-0.4.17         GSettings-based configuration plug-in for libproxy
pinentry-gnome3-1.1.1          GNOME 3 version of the GnuPG password dialog
polkit-gnome-0.105_1           GNOME frontend to the PolicyKit framework

# uname -a
FreeBSD 13.0-RELEASE-p3 FreeBSD 13.0-RELEASE-p3 #0: Tue Jun 29 19:46:20 UTC 2021  amd64
It appears FreeBSD developers don't actually test what they build. I have installed FreeBSD and GNOME and X Window System exactly as per the instructions, yet it doesn't work!
It certainly looks that way when you have just installed FreeBSD on a PC, followed the basic installation instructions to the letter and get locked out following a reboot.

I rolled back with ZFS and tried again a few times before I started picking it apart.

After building the gdm port on Poudriere it looks like gdm is built without Wayland. There is a --without-wayland switch that is used but gdm will not run on FreeBSD without Wayland present. I renamed a few Wayland binaries to test my theory and replaced gdm-wayland-session with an exact copy of gdm-xorg-session suitably renamed.

GDM doesn't use my xorg pretending to be wayland, it just returns to console with no error. The config option in /usr/local/etc/gdm/custom.conf that says Wayland wont be used is also disrespected.

The biggest annoyance is that if you remove the Wayland package to have Xorg only, it takes out most of the Gnome3 packages with it. There appears to be no policy for gnome package maintainers to provide the option of a non Wayland Gnome3 setup on FreeBSD. You get what you are given. I guess the reality of the matter is that Gnome3 has become a systemd desktop and maybe the time has come for me to find a desktop that runs equally well on the non-systemd operating systems that I use with ZFS.
Every time I have tried Wayland it has caused me problems. I guess after all of the problems that I have had with it over the years I have now become accustomed to believing that it will never work. I am trying a Poudriere build today with --disable-wayland-support removed from the Makefile to see if running with Wayland will actually fix a problem this time.
Yes, you can go back to a previous version - I had the same problem on with 13.0-RELEASE, so I did:

pkg add -f
Then it's probably a good idea to lock to that version:
pkg lock accountsservice

That seems to have solved it for me.