FreeBSD doesn't starting after restart

Demogo1

New Member


Messages: 2

I have Hyper-V with Freebsd 12 on vitrual machine. I intalled web server (apache, php, mysql) on freebsd.
After hard restarting my hyper-v server (press power button on server) FreeBSD doesn't work, mysql doesn't mount database.
I have more troubles with database files.
But, if i stoping all services before restart, then my FreeBSD worked fine!
What's going on?
 

yuripv

Well-Known Member

Reaction score: 128
Messages: 285

So it's mysql not starting correctly after unclean shutdown and not FreeBSD? What errors are you seeing exactly?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,744
Messages: 39,332

With VMWare, VirtualBox and FreeBSD's own bhyve the VM is sent an ACPI power signal, this causes the VM to do a clean shutdown. It sounds like your configuration just kills the VM without a proper shutdown. This can cause all sorts of caches to not be written to disk, corrupting your database files.
 
OP
D

Demogo1

New Member


Messages: 2

With VMWare, VirtualBox and FreeBSD's own bhyve the VM is sent an ACPI power signal, this causes the VM to do a clean shutdown. It sounds like your configuration just kills the VM without a proper shutdown. This can cause all sorts of caches to not be written to disk, corrupting your database files.
yes, i guess.
What can i correct it? Maybe rc.conf?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,744
Messages: 39,332

What can i correct it? Maybe rc.conf?
It's not the FreeBSD side you need to configure. I have zero Hyper-V experience so I cannot tell you how or what.
 
Top