freebsd 7.0- Error Mounting /dev/acd0 on /dist: Input/output error (5)

OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

wow. ok, so why does freebsd use an md5 encryption if its so insecure?
download is started. won't be done until tomarrow.
 

skyhawk

New Member


Messages: 17

Because it's not being used for encryption in this context - just to confirm that the download was not corrupted somewhere along the way. SHA-5 sums are also posted by the FreeBSD people, but I don't know of a quick-n-easy Windows utility that can calculate those.
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

5f185a688ef2e0db59105e8f439c8620
5f185a688ef2e0db59105e8f439c8620

looks like my file isnt corrupt this time. so before burning it with imgburn (cuz I only have 1 blank left), is there any settings i need to check? or just click the file/ISO -> disk button?
 

SeanC

Active Member

Reaction score: 7
Messages: 126

skyhawk:

Thanks for running with Lego's problems.

Some where in the back of my mind I remember some CD burning programs screwing up how they "finish" a CD.

How many problems will we see where the cause is bad media or bad burn?!
 

skyhawk

New Member


Messages: 17

Lego - on most modern hardware and with media that isn't from the stone age, no further tweaking should be required. Just let Imgburn do it's thing. You want to be in Write mode, Ctrl-Alt-W.
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

ok, I'm getting ready to run it. anything special I need to know about dual booting? XP is up and running, in fact that's what Im replying on... i have already set half of my hdd to for XP with partition magic 8, the other half is empty/unused. and let bsd setup the boot manager.right.
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

ok well i couldn't get the dua boot to work. so just freebsd is installed. im sitting at just past the welcome message, like after you login now lost. :p what do i do now. i installed xorg during the install isn't that supposed to give me some sort of a window setup. i've been looking at beryl, can i install that right now?

ADDED:

Im so lost now. Its like back to dos. only dos commands don't work :(
Ok Im trying to get xorg to install, but it seems that I don't have the files :( should i just download the disc 2 and disc 3 and run sysinstall again, and include the port collection? because i selected ALL for the install, but no the to the port collection install.
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

i need a way to get my drivers in for my realtek rtl8185 wireless card. i can't access my router directly with an rj45. ok i'll give that a try downloading disc 2. thanks. does disc 2 have the ndiswrapper i need to get my winXP drivers to work??

ADDED:

Can I run disk 2 from a usb stick? cuz im outta blank cds :(
 

skyhawk

New Member


Messages: 17

Lego - you're done with removable media. Get the machine an internet connection, then you'll have everything you need. Absolute worse case, set up a small dual-boot with Windows, download from Windows, then either mount or extract the disc images from within FreeBSD. FreeBSD can read/write FAT32 and read NTFS (I think).

Regarding the dual-boot, I strongly recommend running with only native partitioning utilities - Stuff like PartitionMagic tends to create strange situations that nothing knows how to correctly deal with. I gather your machine was completely hosed? You should have installed Windows to a small partition, with it's native installer/partitioner, then installed FreeBSD making a FreeBSD partition/slice with it's native tool. You'd have been up and running.

You're now largely beyond my help - You've got a running FreeBSD machine. At this point I install server software and get things up and running and the machine sits in a closet for the rest of it's life. I can't help with desktop stuff like you're doing.
 

SeanC

Active Member

Reaction score: 7
Messages: 126

Be careful: Installing Windows after FreeBSD will overwrite your boot sector and you will not be able to access you FreeBSD partitions.

There is PC-BSD. There is also DesktopBSD:

http://www.desktopbsd.net/

However, I do not recommend them because they side-step the learning curve and have been behind FreeBSD in their releases (they are based on FreeBSD and have to wait until FreeBSD is updated).

If you want to immediately have a GUI and point-n-click, stick with Windows, linux or Apple. If you want to learn , stick with FreeBSD. Everything that you can do with PC-BSD and DesktopBSD you can do with FreeBSD once you know how.

Get online. Get your desktop environment.
Read the Handbook. Print it out. Write down everything. I can not stress that enough.

And for fun, there is also a wiki:
http://www.freebsdwiki.net/index.php/Main_Page

Happy hacking!
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

LOL, yea, I found out the hard way with the dual booting, and the handbook has been somewhat helpful but I think its still gear'd to someone who has had atleast some experience with linux, instead of someone that just decided Im gunna learn linux, and installed it..

So I wiped everything and used the windows install to set up my partition and only used half my drive, so it should be fine now, that i didn't use partition magic...

Im not to sure how to get the files i need to the place i need them to use ndis to install my drivers for my NIC, after that i will get KDE installed. just to clarify KDE is a desktop enviroment like beryl right?

yes, i would like to learn the hard way, instead of using PC or Desktop BSD. i've been using the handbook and stuff but it made it hard not having the second computer as a resource. but It should get better now.

Why did you say Happy Hacking? who said anything about hacking :p , I'd be happy just learning how to do simple tasks like install/run software/drivers and a web browser :p

ADDED:

Ok, I figured out how to navigate basics.. like when i log in, Im logging in as root (i realize they recommend not using root, but at this point i don't care much and just need to be able to access everything instead of using the su cuz im not sure exactly how that works for the moment), and I use "cd whatever/" to change directories, but how do i change devices? cd acd0 or cd acd0: the drivers i need are on my usb stick (I believe is da0 ). so I need to copy them to my hdd before running ndis on them and setting up the NIC don't I?
 

skyhawk

New Member


Messages: 17

Lego, the word "hacking" has historical meaning that is no longer consistent with "mainstream" usage. Historically hacking meant making something work, hacking together a quick solution to a problem, that kind of thing. "Hacker" was a badge of pride - check Wikipedia and The Jargon File for more information.

Learning UNIX without a mentor and with a less-than-fully-functional machine is going to be very painful. Don't say I didn't warn you.

For starters, learn to use the manual page reader. For starters I suggest "man hier" and "man mount", and "man ls". UNIX uses the concept of mount points. To access your CD or flash drive, you need to "mount" the filesystems to use them.

As an example, "mount /dev/da0 /mnt" will make the contents of your flash drive available on /mnt. Remember to umount /mnt before pulling the drive.
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

lol, sorry didn't mean to offend.. it was a joke.

i get an invalid argument when i try to mount the flash drive.

"mount /dev/da0 /mnt"
"mount: /dev/da0 : Invalid argument

PS

My system is fully fuctional now. I have winXP and FreeBSD running in good form. with the boot manager from BSD.
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

Ok, I still can't mount my usb is that because its formated for windows?

So I copied the inf and sys file to my usr folder and tried to compile them.. it goes through the entire thing then when it goes to compile i get this error:

Building Kernel module... /usr/share/misc/windrv_stub.c:57:20: error: windrv.h: No such file or directory
mkdep: compile failed.
build failed. Exiting.

Does someone have a precomiled version of the Realtek rtl8185 wireless G PCI card?? that I can just download and install?
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

ok, still can't seem to mount my usb, but that can wait.

Ok, I created a dir MyDriver, copied both inf and sys for my wireless card (Realtek 8185) to MyDriver, ran ndisgen, and got this error now. Not sure what I was doing wrong before but now I really don't know what I was doing wrong:

Generating Makefile... done.
Building Kernel module... make: don't know how to make windrv_stub.c. Stop
Building Failed. Exiting.


Does anyone know what needs to be done to get this working because i have seen others get this card working, and followed there examples, but I just doesn't seem to want to work.
 

skyhawk

New Member


Messages: 17

I can't help you with your ndiswrapper issue - I've never used it.

you need to find the device file for your flash drive. run "cat /var/run/dmesg.boot" One of the lines there, probably decently close to the bottom, will be FreeBSD detecting a USB Mass Storage Device and assigning it the SCSI direct access driver, I think. It should state the device name at detection time. Might be umass0, though I seem to recall FreeBSD always mapping USB mass storage devices to the da driver. Do you have a fixed card-reader installed in the machine? That might have da0, which would make your flash drive da1 or da2 (or even higher, depending how the flash reader is implemented). The section you're looking for should probably be within a few lines of the ad* lines for your HDD.
 

Djn

Well-Known Member

Reaction score: 67
Messages: 392

To install kernel and world source without an internet connection, try running /stand/sysinstall , chose Configure, Distributions, Src, All (but "No" if it asks about the ports collection), Exit, CD/DVD , and see if that works.

Oh, and regarding that USB stick.
Try running
Code:
ls /dev/da*
and look for the device with the highest number (e.g. da1), and the longest name (e.g. da1s1) , then e.g.
Code:
mount -t msdosfs /dev/da1s1 /mnt
.
 
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

Djn said:
Oh, and regarding that USB stick.
Try running
Code:
ls /dev/da*
and look for the device with the highest number (e.g. da1), and the longest name (e.g. da1s1) , then e.g.
Code:
mount -t msdosfs /dev/da1s1 /mnt
.
HOT DIGGITY!! WORKS!! Man you are a God! Thanks...Again :p and to everyone else as well Thank you, im so glad i chose bsd, it may not work right away, but you can't beat the community!

I had the name right with da0s1. But why do i need to add the -t msdosfs? was i right in assuming its because its set for windows filesystem. and well -t (transform?) msdosfs (MicrosoftDosFileSystem?)
 
Top