freebsd 7.0- Error Mounting /dev/acd0 on /dist: Input/output error (5)

Lego

Well-Known Member

Reaction score: 1
Messages: 404

Hi, I spent the last few days downloading freeBSD 7.0 Stable, and wipped my hard drive this morning. put the boot cd in, and it runs the entire setup. goes through, the fdisk setup, and Problem 1 happens.

It says thats my drive geometry is incorrect, and will adjust things to it right... which i don't understand anyway. so then I make the partition, and make the slices(all auto). after that it looks like it mounts the drives. But then problem 2 happens.

Error Mounting /dev/acd0 on /dist: Input/output error (5)

I can't do anything at this point now. Im at a friends house using his net. I don't have another OS, I had windows XP home but I never got the CD when i bought the system, windows or unix base. What am I doing wrong and How do I fix it..

I have done searches on google, and freebsd.org, it would seem Im not the only person with this error, but I can't seem to find a fix, How can I get this error fixed so i can atleast get my computer back online.

I have a celeron 1.78Ghz single core, 2gb ram, dvd/cd burner, 160GB Western Digital HHD, video and audio shouldn't matter I think, but Im using a PCI video with onboard Video disabled.

Any Help is appreciated.
 
OP
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

oh and Im only using one HDD, and only want Freebsd on it. no dual booting.
 
OP
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

Can nobody help me?? I've even made sure that my cdrom and HDD are both the master on there IDE cables. Please Anyone?
 
OP
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

Error Mounting /dev/acd0 on /dist: Input/output error (5)

ad0: dma limited to udma33, controller found non-ata66 cable
ad0: 152627mb <wdc wd1600jb-00gva0 08.02d08> at ata0-master udma33
acd0: dvdr <hl-dt-st dvdram gsa-h10n/jl10> at ata1-slave udma33

am I just being ignored? or does nobody have any clue as to why this is happening??? It also doesn't matter if i use the master or slave spot on the cable the dvd drive always comes up ata1 slave.
 
A

Anonymous

Guest


Lego said:
Can nobody help me?? I've even made sure that my cdrom and HDD are both the master on there IDE cables. Please Anyone?
I am not sure if this help you but try to boot with "noapci". When the menu open choose with noapci.
 

SeanC

Active Member

Reaction score: 7
Messages: 126

Settle down Lego, it's Sunday and people may not be reading the posts as frequently.

Problem 1: Let FreeBSD fix the geometry error.

Problem 2 questions:
Are your jumper settings correct?
Do you have 1 or 2 DVD\CD drives on this computer?
Does this error occur after you choose to install from CD (Figure 2-27):
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/install-media.html

And does it ask you which drive to install from?(ie. acd0 or acd1 if you have 2 drives)
 
OP
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

sorry, im just frantic. I have one dvd/cdrom burner. yes, I set the jumpers on the burner to master and still recieve the same error. yes it occurs after that image, and i do have both my hdd and dvdburner reading masters. hdd is master primary, dvdburner is master secondary . it brings up the mounting partitions thing, then it posts a white message in the bottom left corner, saying it set up all the filesystems successfully. then a message pops up saying "emergency shell holgraphics something or other.." it disappears before i can read it all. then i get the "Error mounting /dev/acd0 on /dist: input/output error (5)"

how do i boot with noapci?? what is that?? and i don't see a menu option i have default install, custom, minimal, and stuff like that.

Thanks guys I really hope i get this working... cuz no computer sucks... and i refuse to buy a copy of windows.... im so sick of windows..
 
OP
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

update: tried running acpi (diabled) and it still didn't work. whats acpi(diabled) do ?
 

skyhawk

New Member


Messages: 17

I have two suggestions, not sure either of them will resolve your issue..

First, try downloading FreeBSD 7.0-RELEASE, rather than a stable snapshot.

Also, next time try a different make of CD media. Different brand.
 

skyhawk

New Member


Messages: 17

Also check/swap your cabling on your optical drive, and try swapping the drive out with a different unit. As a last resort see if the BIOS will let you back the drive down to "PIO Only".

This looks like a hardware problem to me.
 
OP
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

what do you mean snapshot ? i downloaded the iso image from the freebsd.org. ISO image disc 1 of 7.0 Release. i put stable becuase i thought thats how i seen some people refering to it? i have tried swaping out 2 other drive, a cdrom, and a cdrom burner. no luck. would a different make of cd really make a difference?? and whats PIO only do?? Im pretty sure i can't change any of the ide settings in the bios but i'll look again. and i did change the cable out.

ADDED: I burned it to an HP lightscribe cd-r
 

skyhawk

New Member


Messages: 17

Media might surprise you. Try to perform a read test on your disc. My methodology uses Windows. Grab Nero DiscSpeed (http://www.cdspeed2000.com/download.html) and press F2 on the "benchmark" tab. If you get errors or a not-very-straight looking line, you've got a bunk disc (or DMA problems, but let's assume that's not an issue).

How'd you burn the image? Something like Nero's "Burn Image" mode or the fantastic Imgburn program?

Sorry for the Windows-centric approach, I only use FreeBSD on the server-side of things.

There's also the ability to instruct the kernel not to use DMA transfers on the IDE bus - it's be phenomenally slow, but if you're having DMA problems it should work. I believe selecting "Safe Mode" on the CD Loader will run with DMA disabled.
 
OP
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

um yes i did use nero burn image. i'll download cdspeed on this computer and run the disk and get back to ya. I think im gunna get a version of xp on my computer :( so i can atleast stay at home and try and fix this. I'll just setup a dual boot now :( and remove windows after bsd is working. if xp and everything i've ever ran on my computer never had issues could i still have a dma issuse? so hopefully it is just a bad disk.
 

skyhawk

New Member


Messages: 17

I should have thought of this sooner.

Assuming you don't have a media problem, grab RapidCRC (http://rapidcrc.sourceforge.net/) and run it against your disc image. Use something like Imgburn (http://imgburn.com/) to grab an image off your install disc if your original download is gone.

MD5 (7.0-RELEASE-i386-disc1.iso) = 5f185a688ef2e0db59105e8f439c8620
 
OP
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

ok when i open the cd in windows it shows the cd as blank. I know its not blank. it boots and everything. it wouldn't boot to the installation if it were blank. is it because its a different filesystem? so it windows doesn't know what to do with it?or should it not be blank in windows?
 

skyhawk

New Member


Messages: 17

The disc should be iso9660, the standard CD filesystem. Something's funky with your Windows box. Or your media. :)

Let me grab an install disc I've got and double-check that.

Confirmed. Windows sees this disc as it would see any other Data CD. Either your media is bunk or more likely you somehow flummoxed the download or burning procedure.

Try downloading again, then running RapidCRC against the download to confirm the checksum is the same. Then use Imgburn to write the image onto a blank CD. Of course, put another known-good data disc in the Windows machine to make sure it's working properly. :)
 
OP
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

ok so the only file i need to download is the 7.0 Release ISO disc 1 from the freebsd.org page right? could it be that i used nero to burn it... because i always have nero verify data on the disk.
 
OP
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

what do ya know... i just ran imageburn and when it opened the cd it says status incomplete.. so nero must have smugged my burn(smugged is being lite for the hassel it has caused....) ok so now i have to download the entire image again. Right?
 
OP
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

HL-DT-ST CD-RW GCE-8400B B104 (ATA)
Current Profile: CD-R

Disc Information:
Status: Incomplete
Erasable: No
Sessions: 1

ATIP Information:
Start Time of LeadIn (MID): 97m17s06f
Last Possible Start Time of LeadOut: 79m59s74f
 

skyhawk

New Member


Messages: 17

To do a fresh install the only download you need is the one I posted the MD5 for above - 7.0-RELEASE-i386-disc1.iso

I try to stay away from Nero in general, though I like it better than most other Windows burning software. Imgburn really takes the cake though. I recall *really* old version of Nero (Like, Nero 5 or older) were kinda stupid with regards to "foreign" image files.
 

skyhawk

New Member


Messages: 17

Try grabbing Imgburn. Click through into one of it's action modes, such as say "Write image file to disc" and try Tools -> Drive -> Close -> [Disc], [Track], [Session]. Try all three for fun! Probably won't help, but maybe....
 
OP
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

yea, it wouldn't let me do anything to it. was a nice idea though.
 

skyhawk

New Member


Messages: 17

FreeBSD doesen't publish CRC checksums on their images. They do publish an MD5sum however. RapidCRC is able to compute those.

Same idea as a checksum - just a different algorithm.
 
OP
OP
L

Lego

Well-Known Member

Reaction score: 1
Messages: 404

LOL, i just confused myself even more... ok i thought md5 was an encryption, like for your passwords and stuff, and i thought that checksum value was the value returned when you do like a 'scan disk' on the image to verify its all there and in good forum. am i right? or just confused like i think i am?? LOL
 
Top