FreeBSD 12 STABLE: Wacom bamboo fun CTH-661 how to

D

Deleted member 58914

Guest


To get your wacom bamboo fun CTH-661 working, start by installing xf86-input-wacom and adding this to your /etc/rc.conf:

Code:
devd_enable="YES" #To use a wacom tablet
webcamd_enable="YES" #To use a wacom tablet (and a webcam if you have it)

Then do:
Code:
cp /usr/local/etc/X11/xorg.conf.d/wacom.conf.sample /usr/local/etc/X11/xorg.conf.d/wacom.conf

The default settings for wacom.conf worked as long as you know what input event is for pen, touch and pad. They will then correctly show with the command xsetwacom list. To discover which input event is controlling what, do:
Code:
sudo cat /dev/input/eventNUMBER

After that, use the input device, for example, by touching the tablet touch area. If you see garbage text showing at the terminal, then you will know which that input is assigned to that event number. When done type Ctrl+Z. After also editing the wacom.conf file, reboot. In my case the file content was this because I had an usb mouse connected at usb connector 3 at the laptop and I used the usb connector 4 for the wacom tablet:
Code:
# Manual configuration example for Bamboo Pen & Touch for use without devd or HAL.

Section "InputDevice"
    Identifier    "wacom stylus"
    Driver        "wacom"
    Option        "Type"            "stylus"
    Option        "Device"        "/dev/input/event7"
    Option          "AutoServerLayout"    "true"
EndSection

Section "InputDevice"
    Identifier    "wacom eraser"
    Driver        "wacom"
    Option        "Type"            "eraser"
    Option        "Device"        "/dev/input/event7"
    Option          "AutoServerLayout"    "true"
EndSection

Section "InputDevice"
    Identifier    "wacom pad"
    Driver        "wacom"
    Option        "Type"            "pad"
    Option        "Device"        "/dev/input/event8"
    Option          "AutoServerLayout"    "true"
EndSection

If you want instead of the stylus the touch option, replace stylus with:

Code:
Section "InputDevice"
    Identifier    "wacom touch"
    Driver        "wacom"
    Option        "Type"            "touch"
    Option        "Device"        "/dev/input/event6"
    Option          "AutoServerLayout"    "true"
EndSection

If you want both, put both at wacom.conf.

I do not know if it is needed or not, but you may want to add the following at your /etc/rc.conf:
Code:
wacom_enable="YES" #Maybe optional
 
Last edited by a moderator:

YuryG

Aspiring Daemon

Reaction score: 29
Messages: 503

I have simple Wacom Pen Tablet CTL-472. Is there a way to make it work under FreeBSD?
 

YuryG

Aspiring Daemon

Reaction score: 29
Messages: 503

All scarce recommendations from there are fulfilled already but not too much help of them. Moves of stylus act very strange: it make (USB-) mouse buttons unusable when I plug the graphical tablet, and moving the stylus moves mouse pointer (sometimes changing its shape in different forms) only up-down on the left edge of the screen, no horizontal movements happen.
 
Top