• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

FreeBSD 11.1 Release on a Supermicro A2SDi-4C-HLN4F

BaSh

New Member


Messages: 2

#1
Hello,

i am having a problem getting FreeBSD to boot reliable on the Supermicro A2SDI-4C-HLN4F.
Sometimes it works, most of the time it get stuck at the EFI boot block.
I have tried setting the boot options to legacy but that did not help either.
I thought i got it fixed by using UEFI and manually selecting the SSD as boot option but that was only in around 1/10 tries.
Linux derivats like Ubuntu and Mint run without problems, same for Windows and Unix.

All of this is done via IPMI so no Monitor attached.

Firmware Revision: 03.60
Bios Version: 1.0b
IPMI Version: 1.0.1

Here's a screenshot of the problem:
freebsd efi boot block_1.JPG
 

k.jacker

Well-Known Member

Thanks: 179
Best answers: 1
Messages: 360

#2
Hei,
hard to tell why it's not booting without more information...

Two things I'd try, to figure out what's wrong.
1. Install with UEFI boot, your single SSD using GPT and UFS and let the installer setup the disk.

If that gives the same result, try to boot in legacy mode.

2. To do that you can't just switch to legacy mode and try to boot from an EFI partition.
You must first configure the BIOS to boot in legacy mode and then install FreeBSD.
The installer should install a MBR then on it's own. Try to boot...
 

BaSh

New Member


Messages: 2

#3
Hey,
so i tried using legacy mode and installing complety new, that did not work (wierd thing here is that the install says, that the system can not boot MBR in the installer)
Tried anyways, did not help still getting the EFI Console.
Same goes for using UEFI boot and GPT + UFS or GPT + ZFS.


Edit:
I think i found the device leading to this problem, i have a Intel i350-T4 attached via a Thermaltake PCI-E Riser.
If i disconnect the card it boots fine.
I tried removing the PXE boot options for the i350-T4 but it still doesnt boot correctly all of the time.


Edit2:
Fixed the problem with a firmware update for the i350-T4
 
Last edited:
Top