Solved Finnish spell checker "voikko"

JazzSinatra

Member

Thanks: 1
Messages: 29

#1
Hello.

I'm not completely sure is this the right subforum to ask this, but I'm trying to build this Finnish linguistic software *"Voikko" for FreeBSD 10.3-RELEASE-p11. I have installed needed depencies (one of which is **Foma).

I have built libvoikko from repository with configures:
./configure --prefix=/usr/local/voikko --with-dictionary-path=/usr/local/voikkodict --disable-hfst CC=/usr/local/bin/gcc49

Then I did make and make install. There were no problems with building libvoikko. Next I tried to build "voikko-fi" with gmake vvfst-install DESTDIR=/usr/local/voikkodict, but I get this error:


cat vvfst/all.att | sort -n | voikkovfstc -o vvfst/mor.vfst
/usr/local/lib/gcc48/libstdc++.so.6: version GLIBCXX_3.4.20 required by /usr/local/bin/voikkovfstc not found
gmake: *** [Makefile:127: vvfst/mor.vfst] Error 1


If I try to execute voikkovfstc I get the same error:

/usr/local/lib/gcc48/libstdc++.so.6: version GLIBCXX_3.4.20 required by /usr/local/bin/voikkovfstc not found

Is there anything that I could do? Could I get the voikkovfstc to use lang/gcc49/ or could I modify gcc48/libstdc++.so.6: to have the missing "GLIBCXX_3.4.20"?

Thank you for your time.


*Voikko:
https://github.com/voikko
https://github.com/voikko/corevoikko

**Foma:
https://bitbucket.org/mhulden/foma/downloads/
 
OP
OP
JazzSinatra

JazzSinatra

Member

Thanks: 1
Messages: 29

#2
I solved this problem by renaming gcc48 to gcc68, so that the ld found the right directory. After that the error disappeared.
 

tobik@

Daemon
Developer

Thanks: 1,357
Messages: 1,909

#3
If you create a port the ports framework will take care of cases like this and you'll have a much easier time compiling it next time :)

It adds -Wl,-rpath=/usr/local/lib/gcc49 -L/usr/local/lib/gcc49 to LDFLAGS, so that errors like yours don't happen when multiple gcc versions are installed.
 
Top