Can't connect to anything

OP
OP
jayxkanz666

jayxkanz666

Member


Messages: 32

Why does your machine have an APIPA IP address? How is your machine connected to your internet? via a switch or something?
You haven't accidentally connected it a a machine running Windows of some sort?
Nope, the Ethernet cable is connected directly to my router.
 

tingo

Daemon

Reaction score: 373
Messages: 1,981

Why does your router give out APIPA ip addresses then? Something is fishy here....
 

tingo

Daemon

Reaction score: 373
Messages: 1,981

Do you have another ethernet card you could try? Or a usb-to-ethernet adapter (some of those works with FreeBSD, some don't)?
 
OP
OP
jayxkanz666

jayxkanz666

Member


Messages: 32

Do you have another ethernet card you could try? Or a usb-to-ethernet adapter (some of those works with FreeBSD, some don't)?
No, not for that computer. (Worth noting: if I connect my phone and share the internet via USB tethering, it works. That's how I've been able to send these logs)
 

rigoletto@

Daemon
Developer

Reaction score: 892
Messages: 1,851

Try to set it manually. If it works, the range of possible problems will be narrowed.

For instance:
Code:
ifconfig_alc0="inet 192.168.0.10 netmask 255.255.255.0"
defaultrouter="192.168.0.1
What is the chipset of the network card? It may be a driver problem.

EDIT: clean-up
 
OP
OP
jayxkanz666

jayxkanz666

Member


Messages: 32

Try to set it manually. If it works, the range of possible problems will be narrowed.

For instance:
Code:
ifconfig_alc0="inet 192.168.0.10 netmask 255.255.255.0"
defaultrouter="192.168.0.1
What is the chipset of the network card? I may be a driver problem.
Maybe you should read what I've said earlier. Setting the IP statically will not work either, and the Ethernet controller chipset is a Qualcomm Atheros AR8162
 

ShelLuser

Son of Beastie

Reaction score: 1,702
Messages: 3,514

I do not believe that it is a hardware problem since Ethernet/WiFi works fine on my Linux installation.
Yeah, that was going to be my next question ;) However, just to make sure: that Linux installation runs on the same machine?

But moving right along: how is Linux actually configured? A simple DHCP setup or does it use specific flags and/or drivers? Also: that router, I assume that the router functions as the DHCP server or does it use some specific settings as well?

Any ideas? (I've already tried to assign a static IP, but that won't work either.
How did you do that?

Just asking to keep ruling out options...

When in doubt # ifconfig 192.168.0.50 255.255.255.0 alc0 && route default 192.168.0.1.
 
OP
OP
jayxkanz666

jayxkanz666

Member


Messages: 32

Yeah, that was going to be my next question ;) However, just to make sure: that Linux installation runs on the same machine?

But moving right along: how is Linux actually configured? A simple DHCP setup or does it use specific flags and/or drivers? Also: that router, I assume that the router functions as the DHCP server or does it use some specific settings as well?


How did you do that?

Just asking to keep ruling out options...

When in doubt # ifconfig 192.168.0.50 255.255.255.0 alc0 && route default 192.168.0.1.
Linux uses a simple DHCP setup with no specific flags/drivers, works out of the box. The router functions as the DHCP server, but has some settings you can change aswell. (I haven't changed any of them)

I assigned a static IP by modifying my rc.conf as following:
Code:
ifconfig_alc0="inet 192.168.0.150 netmask 255.255.255.0"
defaultrouter="192.168.0.1"
..But as I've stated before, this does not solve anything.
 

ShelLuser

Son of Beastie

Reaction score: 1,702
Messages: 3,514

Well, then we're back to things which don't add up and/or make sense. You say that you got different results when using dhclient and dhcpd. I assume you're referring to the automated startup which uses settings from /etc/rc.conf? Thing is: both systems use the same approach, there is no dhcpd involved here only /usr/sbin/dhclient (you corrected that later).

However, I can come up with a theory: "No route to host" happened when you got the APIPA address assigned, the other before.

There's one thing more I'm missing here... What's the error message when you set up a static IP address?

So: # ifconfig 192.168.0.50 255.255.255.0 alc0, followed by ping 192.168.0.1.

Well, either that or adding the settings you mentioned earlier to /etc/rc.conf and then rebooting.
 

aragats

Daemon

Reaction score: 479
Messages: 1,157

$ sudo dhcpcd -d alc0 using config file `/usr/local/etc/dhcpcd.conf' dhcpcd-7.0.0-alpha starting
Alpha? I wouldn't trust alpha dhcp client...
As ShelLuser advised, assign an address from command line and run ifconfig without any argument right after to see the result.
Let's see the state and addresses of other interfaces as well.
 
OP
OP
jayxkanz666

jayxkanz666

Member


Messages: 32

And here are the results:
(Note, my router only accepts IP addresses ranging from 192.168.0.100 to 192.168.200)

Code:
[jayxkanz@jayxbsd ~]$ sudo ifconfig alc0 192.168.0.150 255.255.255.0
[jayxkanz@jayxbsd ~]$ ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1): 56 data bytes
ping: sendto: Host is down
[jayxkanz@jayxbsd ~]$ ifconfig
alc0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=c319a<TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MCAST,WOL_MAGIC,VLAN_HWTSO,LINKSTATE>
    ether 20:89:84:96:53:a3
    inet 192.168.0.150 netmask 0xffffff00 broadcast 255.255.255.0 
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
    options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
    inet6 ::1 prefixlen 128 
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2 
    inet 127.0.0.1 netmask 0xff000000 
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    groups: lo
 

balanga

Son of Beastie

Reaction score: 111
Messages: 2,732

One wonders how you got it installed in the first place.... I would still suggest you try installing 11.0-RELEASE on a USB pen drive using the mini-memstick image and see how far you get.
 
OP
OP
jayxkanz666

jayxkanz666

Member


Messages: 32

One wonders how you got it installed in the first place.... I would still suggest you try installing 11.0-RELEASE on a USB pen drive using the mini-memstick image and see how far you get.
I did as you said, but before I even got a chance to install it, it failed at the "acquiring DHCP lease" part.
 

balanga

Son of Beastie

Reaction score: 111
Messages: 2,732

So it looks like a driver issue... Did it offer the correct interface to set up? Maybe try a USB/Ethernet card or WiFi...

How did you manage to get it installed earlier?
 
OP
OP
jayxkanz666

jayxkanz666

Member


Messages: 32

So it looks like a driver issue... Did it offer the correct interface to set up? Maybe try a USB/Ethernet card or WiFi...

How did you manage to get it installed earlier?
Not a driver issue, it offers the correct interface/driver, alc.
I used the memstick image earlier and I don't believe that one requires an internet connection.
 

ShelLuser

Son of Beastie

Reaction score: 1,702
Messages: 3,514

A new day and the same problem ;)

Ok, I re-read the thread (again) and something else came to mind: does your router support Gigabit ethernet aka 1000baseTX? Because I couldn't help notice that ifconfig displays your NIC as using 100baseTX.

When in doubt: boot Linux, use ifconfig and share the output here. That might give more clues.

Right now, even though I think this is very unlikely, I'm starting to wonder if this could be caused by a difference in media type. So maybe fixable by forcing the alc driver to utilize 1000baseTX. This is of course assuming that your router uses 1000baseTX.
 
OP
OP
jayxkanz666

jayxkanz666

Member


Messages: 32

A new day and the same problem ;)

Ok, I re-read the thread (again) and something else came to mind: does your router support Gigabit ethernet aka 1000baseTX? Because I couldn't help notice that ifconfig displays your NIC as using 100baseTX.

When in doubt: boot Linux, use ifconfig and share the output here. That might give more clues.

Right now, even though I think this is very unlikely, I'm starting to wonder if this could be caused by a difference in media type. So maybe fixable by forcing the alc driver to utilize 1000baseTX. This is of course assuming that your router uses 1000baseTX.
Nope, my router and the Ethernet controller only support 100baseTX
 

tingo

Daemon

Reaction score: 373
Messages: 1,981

No, not for that computer. (Worth noting: if I connect my phone and share the internet via USB tethering, it works. That's how I've been able to send these logs)
OK, but that is (essentially) the same. You have used your phone, which acted as an usb network card, and the machine worked. This rules out any configuration errors on the machine.
Conclusion: the alc(4) driver isn't working with the hardware you have.
 
Top