Booting install USB shows jumbled graphics.

UltrasonicMadness

New Member


Messages: 3

Hello FreeBSD community

I am having problems booting from USB after writing the FreeBSD 11.0 image to a USB drive, although I have had the same issue when trying the UEFI-memstick image of FreeBSD 10.3. I used the command from the install guide with the filename changed to reflect the new version.

dd if=FreeBSD-11.0-RELEASE-amd64-memstick.img of=/dev/da0 bs=1M conv=sync

When booting from the USB drive, I see the boot screen appear as normal until I press 1 to boot into multi-user mode. Following this, the top (roughly) 5/6 of the screen turns into a jumbled mess of lines (which is presumably the system loading) turning mostly blue after some seconds, although it will still show horizontal lines all over the screen and nothing remotely legible. The bottom of the screen does not change at all, still showing a section of the bootloader.

The laptop I am using is an HP Pavilion g6 with UEFI, secure boot disabled and the following graphics setup:
Code:
$ lspci | grep VGA
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7640G]
I have also had issues getting this laptop to boot with later versions of the Linux kernel (starting at around version 4.7.1) and I've been relying on Arch's LTS kernel (4.4.x) since. I don't know how relevant this is but it seemed worth pointing out. This post describes what seems to be a similar problem to the one I am having.

Best regards,
UltrasonicMadness
 

Atsuri

Active Member

Reaction score: 24
Messages: 137

I just checked the Graphics section of the FreeBSD wiki and it seems your AMD graphics class should be fully supported (Radeon HD 7600-series). Is the Radeon HD 7640G an integrated GPU? Do you also have a discrete card on this computer?

Otherwise, I would also recommend trying the text-only mode with vt().
 
OP
OP
UltrasonicMadness

UltrasonicMadness

New Member


Messages: 3

Where would I enter the commands for enabling Newcons? This is installation media where the only prompt I can access is the boot options menu (option 6) without the display becoming beyond illegible. I think this laptop's graphics card is integrated, pretty sure there isn't another one on here.
 

spanglefox

Active Member

Reaction score: 15
Messages: 154

OK, there are kind of two options available. You can try and use textmode or the old sc(4)().

  1. Press Esc when the system boots from the installation media.
  2. You will then be presented with an "OK" line (see photo)

Now you can type in what is show there.

The alternative is to replace textmode with:
set kern.vty=sc
boot


Hope that helps
 

ANOKNUSA

Aspiring Daemon

Reaction score: 372
Messages: 675

Rather than falling back to sc(4), just type mode 0. This sets the resolution of the console to its lowest setting. The garbled graphics are likely caused by the kernel trying to automatically match your screen's resolution without the correct driver for your video chip being loaded.

If it's happening while booting the installation disk, it's going to happen when booting the installed system, and if OP intends to use X and is using a newer KVM-based graphics chip then using the old console driver might cause more problems than the one it "fixes" now. Better to momentarily work around the problem with up-to-date tools and commands and learn how to fix the problem later than getting into bad habits from the start.
 

egermanus

New Member


Messages: 1

Type mode 2. If that doesn't work, type mode and you'll get a list of compatible modes. I had the same issue and mode 2 worked for me.
 

pjb

New Member


Messages: 1

Hi UltrasonicMadness,
I had exactly the same problem as you tonight, I thought it was dead until I came have a look here a little by chance.
ANOKNUSA and egermanus, your answers worked ! Thanks ! Perfect !
In the FreeBSD menu I pressed ESC then I could write then I typed mode 2 (first I tried mode 0 but it did not work) and finally I typed boot to resume the installation.

Thanks again, I'll go finish my installation.
 

bangmyhead

Member

Reaction score: 1
Messages: 60

OK, there are kind of two options available. You can try and use textmode or the old sc(4)().

  1. Press Esc when the system boots from the installation media.
  2. You will then be presented with an "OK" line (see photo)

Now you can type in what is show there.

The alternative is to replace textmode with:
set kern.vty=sc
boot


Hope that helps
This solves my problem on my notebook but how I can let this permanent?
 
Top