Solved Awful fonts, specially Terminus.

rigoletto@

Daemon
Developer

Reaction score: 1,055
Messages: 2,116

Hi,

I am running i3wm and I configured most of the desktop to use x11-fonts/terminus-font, including urxvt.

It was working as expected while I was using pkg (exclusively), however when I managed to have the things more or less how I want to, I rebuilt everything using ports-mgmt/synth what did the job without any error/problem.

Just after the installation of the new built packages, every program opened which should be using Terminus was indeed using some "generic" fixed font. Also, all other fonts currently have an awful looking.

Beyond the changes made due to make.conf there are very little changes on the ports options, and IIRC I didn't change anything fontconfig/freetype too. However monospace font is working OK.

Code:
CPUTYPE?=native
OPTIMIZED_CFLAGS=YES
BUILD_OPTIMIZED=YES
WITH_CPUFLAGS=YES

MK_PROFILE=no

OPTIONS_SET = INSULTS OPTIMIZED_CFLAGS UTF8 X11
OPTIONS_UNSET = AVAHI BASH CUPS DEBUG DOCS EXAMPLES IPV6 PROFILE PULSEAUDIO TLS_SRP XINERAMA ZSH

DEFAULT_VERSIONS+=ssl=libressl
I do not know what I am looking for. I can't find anything relevant on the logs. :(

EDIT: I just notice right now the i3status is not shown my local IP anymore, it show it as "down", but of course it is not down.
 
OP
OP
rigoletto@

rigoletto@

Daemon
Developer

Reaction score: 1,055
Messages: 2,116

Those are the Ports which suffered modification on its options:

/var/db/ports:
Code:
archivers_rar
archivers_xarchive
graphics_feh
graphics_gimp-app
math_gmp
multimedia_ffmpeg
print_ghostscript9-agpl-base
sysutils_conky
x11-servers_xorg-server
x11-themes_slim-themes
x11_rxvt-unicode
x11_xautolock
 
OP
OP
rigoletto@

rigoletto@

Daemon
Developer

Reaction score: 1,055
Messages: 2,116

Somehow, after various tweaks it is properly working again. The terminus specific issue I have to set it as:

xos4 Terminus
 
Top