Solved Android USB rules

paololucchesi

New Member


Messages: 4

Hi there!

I'm having an annoying problem with my Moto X2 android device on FreeBSD 11.0-RC2:
I've installed android-tools-adb, but as I expected my system can't see the USB device properly to push/pull files through adb. The thing is that I cannot add udev rules like on a Linux system. Any solution?
Thanks in advance,
Paolo
 

acheron

Aspiring Daemon

Reaction score: 228
Messages: 601

android-tools-adb works perfectly on my LG phone. What is an udev rules? You are on a FreeBSD forums, don't expect user to know all this linux nonsense.
 

tingo

Daemon

Reaction score: 431
Messages: 2,109

Do you get any errors when you try these commands? Show us the errors.
 

tobik@

Daemon
Developer

Reaction score: 1,386
Messages: 1,909

Do you get any errors when you try these commands? Show us the errors.
Always a good strategy. You can set the environment variable ADB_TRACE=all (or maybe just usb) to get more information.
 
OP
OP
P

paololucchesi

New Member


Messages: 4

Do you get any errors when you try these commands? Show us the errors.
No errors: I just get a blank list when scanning for devices with sudo adb devices

Always a good strategy. You can set the environment variable ADB_TRACE=all (or maybe just usb) to get more information.
Tried that too, but no way:

root@paolo-freebsd:/home/paolo # adb devices
List of devices attached

root@paolo-freebsd:/home/paolo #
 
OP
OP
P

paololucchesi

New Member


Messages: 4

Seems that someway adb debugging was disabled on my phone. How stupid I am o_O. Sorry for the waste of time, and thank you for your help. I think I can add SOLVED tag.
 
Top