Your system's proportions

roccobaroccoSC

Aspiring Daemon

Reaction score: 210
Messages: 722

Hi, I am wondering how big are the FreeBSD systems you are using? Would you care to share your storage size, memory, network bandwidth, number of file systems?
Let me kick it off with two of my boxes:
  • NAS
Bash:
% zpool list
NAME      SIZE  ...
storage  14.4T 
zroot    31.8G 

# grep -i memory /var/run/dmesg.boot
real memory  = 17179869184 (16384 MB)
avail memory = 16428228608 (15667 MB)

% sysctl hw.model hw.machine hw.ncpu
hw.model: .... @ 1.50GHz
hw.machine: amd64
hw.ncpu: 4

# Network: 2x Gigabit Ethernet

% zfs list | wc -l
      46
  • And the same on a production VM:
Bash:
% zpool list
NAME    SIZE  ...
zroot  59,5G 

% grep -i memory /var/run/dmesg.boot
real memory  = 16106127360 (15360 MB)
avail memory = 15571709952 (14850 MB)

% sysctl hw.machine hw.ncpu
hw.machine: amd64
hw.ncpu: 4

# Network: 1x virtio (routing via gigabit ethernet)

% zfs list | wc -l
     460
:)
 

timotheosh

New Member

Reaction score: 2
Messages: 10

My Raspberry PI 4B

I modified the sdcard image so I could do a fresh install from it onto an m2. ssd with a ZFS root.

$ zpool list NAME SIZE ALLOC FREE CKPOINT EXPANDSZ FRAG CAP DEDUP HEALTH ALTROOT zroot 472G 21.5G 451G - - 0% 4% 1.00x ONLINE - $ grep -i memory /var/run/dmesg.boot real memory = 8441827328 (8050 MB) avail memory = 8205492224 (7825 MB) usbus0 Memory Model Features 0 = <TGran4,TGran64,SNSMem,BigEnd,16bit ASID,16TB PA> Memory Model Features 1 = <8bit VMID> Memory Model Features 2 = <32bit CCIDX,48bit VA> $ sysctl hw.machine hw.ncpu hw.machine: arm64 hw.ncpu: 4 $ zfs list|wc -l 30
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,294
Messages: 38,811

Would you care to share your storage size, memory, network bandwidth, number of file systems?
Pfew. You ready for it?

One of my oldest systems, a server named Molly. Has had many incarnations, mainboard swaps, storage added and whatnot over the years. It was my only "server" (besides Maelcum; the firewall) until I built Hosaka. It's a Core i5-3470; 16GB memory. LSI SAS9207-8i for all the disks. Intel 1000/PRO network card. Serves most of my media content, shares and I build my repositories on it.
Code:
# Three pools, zroot (single disk for the OS); Intel 320 160GB SSD, storage; 4x3TB Raid-Z, fbsd1; 3x1TB Raid-Z
root@molly:~ # zfs list
NAME                                       USED  AVAIL     REFER  MOUNTPOINT
fbsd1                                     1.02T   756G      117K  none
fbsd1/DATA                                 929G   756G      117K  none
fbsd1/DATA/MAME                            862G   756G      841G  /storage/MAME
fbsd1/DATA/commodore                      66.7G   756G     66.7G  /storage/commodore
fbsd1/DATA/mysql                           830M   756G      830M  /var/db/mysql
fbsd1/HOMES                                986M   756G      128K  /usr/home
fbsd1/HOMES/dice                           986M   756G      977M  /usr/home/dice
fbsd1/bastille                             755M   756G      149K  /usr/local/bastille
fbsd1/bastille/backups                     128K   756G      128K  /usr/local/bastille/backups
fbsd1/bastille/cache                       180M   756G      128K  /usr/local/bastille/cache
fbsd1/bastille/cache/13.0-RELEASE          180M   756G      180M  /usr/local/bastille/cache/13.0-RELEASE
fbsd1/bastille/jails                      68.0M   756G      128K  /usr/local/bastille/jails
fbsd1/bastille/jails/ports                67.8M   756G      149K  /usr/local/bastille/jails/ports
fbsd1/bastille/jails/ports/root           67.7M   756G     67.7M  /usr/local/bastille/jails/ports/root
fbsd1/bastille/releases                    507M   756G      128K  /usr/local/bastille/releases
fbsd1/bastille/releases/13.0-RELEASE       507M   756G      507M  /usr/local/bastille/releases/13.0-RELEASE
fbsd1/bastille/templates                   176K   756G      176K  /usr/local/bastille/templates
fbsd1/jails                               7.64G   756G      117K  /jails
fbsd1/jails/clean_jail                    7.55G   756G     2.74G  /jails/clean_jail
fbsd1/jails/j-ports                       89.1M   756G     2.82G  /jails/j-ports
fbsd1/obj                                 31.8G   756G     31.8G  /usr/obj
fbsd1/ports                               47.7G   756G     2.88G  /usr/ports
fbsd1/ports/distfiles                     35.3G   756G     35.3G  /usr/ports/distfiles
fbsd1/poudriere                           14.9G   756G      117K  none
fbsd1/poudriere/data                      8.70G   756G     8.70G  /usr/local/poudriere/data
fbsd1/poudriere/jails                     6.16G   756G      128K  /usr/local/poudriere/jails
fbsd1/poudriere/jails/122-release         1.71G   756G     1.71G  /usr/local/poudriere/jails/122-release
fbsd1/poudriere/jails/13-stable           1.51G   756G     1.51G  /usr/local/poudriere/jails/13-stable
fbsd1/poudriere/jails/130-release         2.94G   756G     2.94G  /usr/local/poudriere/jails/130-release
fbsd1/poudriere/ports                      373K   756G      117K  none
fbsd1/poudriere/ports/desktop              128K   756G      128K  none
fbsd1/poudriere/ports/server               128K   756G      128K  none
fbsd1/release                             3.04G   756G      117K  /storage/release
fbsd1/release/13-stable                   3.04G   756G     3.04G  /storage/release/13-stable
fbsd1/src                                 2.77G   756G     2.51G  /usr/src
fbsd1/vm                                  1003M   756G      280M  /vm
fbsd1/vm/images                            723M   756G      723M  /vm/images
storage                                   7.74T  43.3G      209K  /storage
storage/DayZ                               163K  43.3G      163K  /storage/DayZ
storage/backups                           21.6G  43.3G     21.6G  /storage/backups
storage/backups/bareos                    52.4M  43.3G     52.4M  /storage/backups/bareos
storage/media                             7.71T  43.3G     7.71T  /storage/media
storage/test                               209K  43.3G      209K  /storage/test
zroot                                     6.86G   121G       96K  /zroot
zroot/ROOT                                6.78G   121G       96K  none
zroot/ROOT/13.0-STABLE_2021-09-06_213229     8K   121G     4.22G  /
zroot/ROOT/13.0-STABLE_2021-09-06_213328     8K   121G     4.22G  /
zroot/ROOT/13.0-STABLE_2021-10-02_221125     8K   121G     4.34G  /
zroot/ROOT/default                        6.78G   121G     4.39G  /
zroot/usr                                   96K   121G       96K  /usr
zroot/var                                 3.43M   121G       96K  /var
zroot/var/audit                             96K   121G       96K  /var/audit
zroot/var/crash                             96K   121G       96K  /var/crash
zroot/var/log                             1.27M   121G     1.27M  /var/log
zroot/var/mail                            1.79M   121G     1.79M  /var/mail
zroot/var/tmp                               96K   121G       96K  /var/tmp

Maelcum, my firewall, connects the internet (600Mbit Cable internet) to the rest of my network. It also acts as a router between VLANs. Maelcum has had many incarnations too, it started off with an old trashed Siemens Pentium 90 and a Telis BRI ISDN card. Been having some throughput issues with it but that might be due to the rather under specced hardware. May need to replace it with something newer, it's getting old (judging by the SSD lifetime it's almost 8 year old hardware).
Code:
# Intel(R) Celeron(R) CPU 847 @ 1.10GHz Onboard passively cooled CPU mainboard
# Single drive zroot (standard install) on a Kingston 60GB SSD (has a whopping 69102h power_on_hours and still no errors)
# Two Intel PRO/1000 network cards

Hosaka; my VM 'beast' I cobbled together some time ago from an old trashed server. It's a dual Xeon E5620 with an onboard mpt(4) controller, 4x1GB igb(4) (Supermicro X8DT3-LN4F) and has 96GB ECC RAM. As you can see I run a number of VMs on it, most of them FreeBSD too. It's old hardware, slow in comparison to more modern boards and CPUs but it works good enough for what I use it for.
Code:
# zroot; 2 Intel 320 160GB SSDs mirrored; stor10k; 4 x 600GB 10K SAS RAID10
NAME                                   USED  AVAIL     REFER  MOUNTPOINT
stor10k                                211G   867G       23K  none
stor10k/DATA                           209G   867G       23K  none
stor10k/DATA/vm                        209G   867G       26K  /storage/vm
stor10k/DATA/vm/debian                3.34G   867G     30.5K  /storage/vm/debian
stor10k/DATA/vm/debian/disk0          3.34G   867G     3.34G  -
stor10k/DATA/vm/errol                 2.75G   867G       30K  /storage/vm/errol
stor10k/DATA/vm/errol/disk0           2.75G   867G     2.75G  -
stor10k/DATA/vm/fbsd-test             9.75G   867G       34K  /storage/vm/fbsd-test
stor10k/DATA/vm/fbsd-test/disk0       9.75G   867G     9.75G  -
stor10k/DATA/vm/gitlab                16.0G   867G       31K  /storage/vm/gitlab
stor10k/DATA/vm/gitlab-runner         13.4G   867G     55.5K  /storage/vm/gitlab-runner
stor10k/DATA/vm/gitlab-runner/disk0   13.4G   867G     13.4G  -
stor10k/DATA/vm/gitlab/disk0          16.0G   867G     16.0G  -
stor10k/DATA/vm/kibana                41.3G   867G     56.5K  /storage/vm/kibana
stor10k/DATA/vm/kibana/disk0          41.3G   867G     41.3G  -
stor10k/DATA/vm/plex                  19.0G   867G       58K  /storage/vm/plex
stor10k/DATA/vm/plex/disk0            19.0G   867G     19.0G  -
stor10k/DATA/vm/riviera               15.8G   867G     38.5K  /storage/vm/riviera
stor10k/DATA/vm/riviera/disk0         15.8G   867G     15.8G  -
stor10k/DATA/vm/sdgame01              17.8G   867G       27K  /storage/vm/sdgame01
stor10k/DATA/vm/sdgame01/disk0        17.8G   867G     17.8G  -
stor10k/DATA/vm/tessierashpool        15.1G   867G       34K  /storage/vm/tessierashpool
stor10k/DATA/vm/tessierashpool/disk0  15.1G   867G     15.1G  -
stor10k/DATA/vm/ubuntu                5.63G   867G     5.63G  /storage/vm/ubuntu
stor10k/DATA/vm/wintermute            29.3G   867G     65.5K  /storage/vm/wintermute
stor10k/DATA/vm/wintermute/disk0      16.3G   867G     8.18G  -
stor10k/DATA/vm/wintermute/disk1      13.1G   867G     10.5G  -
zroot                                  131G  9.18G       88K  none
zroot/DATA                             114G  9.18G       88K  none
zroot/DATA/swap                       8.25G  9.42G     8.02G  -
zroot/DATA/vm                          106G  9.18G     8.90G  /vm
zroot/DATA/vm/case                    11.6G  9.18G      156K  /vm/case
zroot/DATA/vm/case/disk0              11.6G  9.18G     11.6G  -
zroot/DATA/vm/images                   498M  9.18G      498M  /vm/images
zroot/DATA/vm/jenkins                 12.1G  9.18G      168K  /vm/jenkins
zroot/DATA/vm/jenkins/disk0           12.1G  9.18G     12.1G  -
zroot/DATA/vm/kdc                     6.38G  9.18G      160K  /vm/kdc
zroot/DATA/vm/kdc/disk0               6.38G  9.18G     6.38G  -
zroot/DATA/vm/lady3jane               66.3G  9.18G      136K  /vm/lady3jane
zroot/DATA/vm/lady3jane/disk0         19.2G  9.18G     19.2G  -
zroot/DATA/vm/lady3jane/disk1         47.1G  9.18G     47.1G  -
zroot/ROOT                            14.3G  9.18G       88K  none
zroot/ROOT/default                    14.3G  9.18G     12.9G  /
zroot/usr                             2.93G  9.18G       88K  /usr
zroot/usr/home                         172K  9.18G      172K  /usr/home
zroot/usr/ports                         88K  9.18G       88K  /usr/ports
zroot/usr/src                         2.93G  9.18G     2.42G  /usr/src
zroot/var                             4.77M  9.18G       88K  /var
zroot/var/audit                         88K  9.18G       88K  /var/audit
zroot/var/crash                         88K  9.18G       88K  /var/crash
zroot/var/log                         1.57M  9.18G     1.57M  /var/log
zroot/var/mail                         884K  9.18G      884K  /var/mail
zroot/var/tmp                         2.07M  9.18G     2.07M  /var/tmp

Williscorto; A Zotac ID80 plus. Mainly runs a FreeBSD desktop to test FS-UAE on. It's getting a bit slow, still has the original 5400 RPM HD in it, might replace that with an SSD. Plain and simple, default ZFS layout.

ChibaCity; A Zotac Zbox Giga ID72 plus. Hooked up to my AVR/TV. Plan to put some emulators and media players on it. Haven't gotten the time for it yet. It runs a few things now but mostly all unfinished tests.

PiBSD; A Raspberry Pi 3; Using it with a minipro TL866 programmer, mostly use it to code 6502 assembler on it and burn it to an EEPROM.

I have two desktop machines too, but they run Windows 10 only, you probably don't want to know about those ;)

The whole thing is tied together with a HP Procurve 2530-48G (48 x 1GB ports). Which was donated to me, after I replaced it with newer equipment for a client.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,294
Messages: 38,811

Why bastille and not a plain /etc/jail.conf ?
Easier to create and manipulate jails without having to think about all the difficult bits. The fbsd1/jails datasets are the 'old' jails, I used to built them by hand but it was just a bit of a chore to keep them updated. Bastille made that really easy.
 

Menelkir

Well-Known Member

Reaction score: 333
Messages: 272

C64 and Amiga software I collected over the years. Is that a lot? I'm a bit of a hoarder and I kind of lost track :D
Pretty much, I also have a huge amount of software I collect from retrostuff (Commodore, MSX, ZX, TRS, etc) but my entire Commodore thing is something near 36G.
 

Alain De Vos

Daemon

Reaction score: 643
Messages: 2,161

As this is off-topic there are some really good C64 games.
Ever programmed sprites ?
I made drawings on paper and then counting the digits, adding powers of two, this was like 34 years ago.
And detecting things like collision.
Programming with backtracking in dos.
Later in life came unixware and SCO-unix.
 

ralphbsz

Son of Beastie

Reaction score: 2,342
Messages: 3,236

Home server / NAS / internet router:
Intel Atom, 32bit, 1.8 GHz, 4 core. Physically 4 GiB RAM, but being a 32-bit machine, only 3 GiB get used.
Two 100-base T Ethernet ports, one is the internal home network, other goes to my ISP via DSL. WiFi is provided by a commercial AP installed on the internal wired network.
Boots from a 32 GiB (!) Intel SSD which is now 5 or 6 years old, but works great. Has a second identical SSD inside, which is set up for emergency booting if the first SSD fails.
Contains two SATA disks which form the main file systems, mostly RAID-1 (straight mirroring) in ZFS. One 3TB, one 4TB. The extra TB is used for a file system that gets very little use and is not important.
An external 2 (or 4?) TiB backup disk is connected via USB-3 and a 6' extension cable. That backup disk is physically in a big safe with very thick walls, which happens to be right next to the bookshelf where the server sits.
De-facto headless. It has a tiny keyboard and a 12" VGA monitor attached, for occasional local administration when the network fails.
 

forquare

Well-Known Member

Reaction score: 180
Messages: 329

My VPS, network is a single virtualised NIC:
Code:
# zpool list -o name,size
NAME    SIZE
zroot  76.9G

# grep -i memory /var/run/dmesg.boot
real memory  = 4294967296 (4096 MB)
avail memory = 4072525824 (3883 MB)

# sysctl hw.model hw.machine hw.ncpu
hw.model: AMD EPYC 7601 32-Core Processor
hw.machine: amd64
hw.ncpu: 2

# zfs list -H| wc -l
      45

My home DHCP server, single gigabit NIC:
Code:
# zpool list -o name,size
NAME    SIZE
zroot   460G

# grep -i memory /var/run/dmesg.boot
real memory  = 6442450944 (6144 MB)
avail memory = 6184656896 (5898 MB)
real memory  = 6442450944 (6144 MB)
avail memory = 6184652800 (5898 MB)

# sysctl hw.model hw.machine hw.ncpu
hw.model: Intel(R) Atom(TM) CPU D525   @ 1.80GHz
hw.machine: amd64
hw.ncpu: 4

# zfs list -H| wc -l
      77

I've also got a Supermicro 2U server waiting to be set up (bought a couple of years ago before a house move the ended up taking about two years 😅, now just waiting to get cabling to/from the garage/workshop):
  • 2x Intel Xeon E5-2630L
  • 64GB memory
  • 12 drives - think it'll have 41TB of space total, but realistically will be much less as most drives will be configured into mirrors
  • LSI 9200-8i
  • 4x Gigabit NICs
 

hardworkingnewbie

Active Member

Reaction score: 161
Messages: 162

I'm running FreeBSD 13.0-RELEASE-p4 64 bit as on a small NUC with 2 Gigabit NICs.

CPU: Intel(R) Celeron(R) N4100 CPU @ 1.10GHz (1094.44-MHz K8-class CPU)
8 GB DDR3 RAM
128 GB SSD
ZFS only

It's my internet firewall/gateway, and thanks to the magic of bhyve it also runs FreePBX.

It does its job, and it basically bored all day long. Required administration is neglectable. So doing a great job!
 

eternal_noob

Aspiring Daemon

Reaction score: 508
Messages: 739

I am running FreeBSD 13.0 on a Raspberry Pi 400. See here for specs.

I use the default SD card image which provides the following partitions:
Code:
Filesystem                Size    Used   Avail Capacity  Mounted on
/dev/ufs/rootfs            14G    8,3G    4,9G    63%    /
devfs                     1,0K    1,0K      0B   100%    /dev
/dev/msdosfs/MSDOSBOOT     50M     25M     25M    49%    /boot/msdos
tmpfs                      50M    8,0K     50M     0%    /tmp
 

jammied

Member

Reaction score: 13
Messages: 33

$ zpool list
NAME SIZE ALLOC FREE CKPOINT EXPANDSZ FRAG CAP DEDUP HEALTH ALTROOT
zroot 236G 29.4G 207G - - 15% 12% 1.00x ONLINE -

CPU: AMD FX(tm)-6300 Six-Core Processor (3511.83-MHz K8-class CPU)
Origin="AuthenticAMD" Id=0x600f20 Family=0x15 Model=0x2 Stepping=0
Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
Features2=0x3e98320b<SSE3,PCLMULQDQ,MON,SSSE3,FMA,CX16,SSE4.1,SSE4.2,POPCNT,AESNI,XSAVE,OSXSAVE,AVX,F16C>
AMD Features=0x2e500800<SYSCALL,NX,MMX+,FFXSR,Page1GB,RDTSCP,LM>
AMD Features2=0x1ebbfff<LAHF,CMP,SVM,ExtAPIC,CR8,ABM,SSE4A,MAS,Prefetch,OSVW,IBS,XOP,SKINIT,WDT,LWP,FMA4,TCE,NodeId,TBM,Topology,PCXC,PNXC>
Structured Extended Features=0x8<BMI1>
SVM: NP,NRIP,VClean,AFlush,DAssist,NAsids=65536
TSC: P-state invariant, performance statistics
real memory = 25769803776 (24576 MB)
avail memory = 24876740608 (23724 MB)

nvidia0: <NVS 510> on vgapci0
 

mickey

Aspiring Daemon

Reaction score: 310
Messages: 754

Internet gateway / Wi-Fi AP / Proxy / PBX / NAS:
Code:
# sysctl hw.model hw.machine hw.ncpu
hw.model: Intel(R) Core(TM) i3 CPU         550  @ 3.20GHz
hw.machine: amd64
hw.ncpu: 4

# grep memory /var/run/dmesg.boot
real memory  = 8589934592 (8192 MB)
avail memory = 8293834752 (7909 MB)

# zpool list
NAME   SIZE  ALLOC   FREE  CKPOINT  EXPANDSZ   FRAG    CAP  DEDUP    HEALTH  ALTROOT
sys   1.80T   498G  1.31T        -         -     9%    27%  1.00x    ONLINE  -

# zfs list -H | wc -l
      25

# pciconf -lv | grep "Network"
    device     = '82576 Gigabit Network Connection'
    device     = '82576 Gigabit Network Connection'
    device     = 'AR93xx Wireless Network Adapter'

Desktop:
Code:
# sysctl hw.model hw.machine hw.ncpu
hw.model: Intel(R) Core(TM) i5-6600 CPU @ 3.30GHz
hw.machine: amd64
hw.ncpu: 4

# grep memory /var/run/dmesg.boot
real memory  = 17179869184 (16384 MB)
avail memory = 16499277824 (15734 MB)

# zfs list -H | wc -l
      11
 

freebuser

Active Member

Reaction score: 7
Messages: 105

Code:
hw.model: Intel(R) Xeon(R) CPU E5-2407 0 @ 2.20GHz
hw.machine: amd64
hw.ncpu: 8

real memory  = 68719476736 (65536 MB)
avail memory = 66800680960 (63706 MB)

zfs list -H | wc -l
       9

pciconf -lv | grep "Net"
    device     = 'NetXtreme BCM5720 Gigabit Ethernet PCIe'
    device     = 'NetXtreme BCM5720 Gigabit Ethernet PCIe'
    device     = 'NetXtreme BCM5719 Gigabit Ethernet PCIe'
    device     = 'NetXtreme BCM5719 Gigabit Ethernet PCIe'
    device     = 'NetXtreme BCM5719 Gigabit Ethernet PCIe'
    device     = 'NetXtreme BCM5719 Gigabit Ethernet PCIe'

zpool list -o size
 SIZE
8.98T
 

gpw928

Aspiring Daemon

Reaction score: 240
Messages: 552

All my FreeBSD systems are VMs these days, except for the ZFS server, which I just rebuilt with a new Motherboard, CPU, and memory, from otherwise existing parts after the old motherboard died:
Code:
[sherman.132] # zpool list
NAME    SIZE  ALLOC   FREE  CKPOINT  EXPANDSZ   FRAG    CAP  DEDUP    HEALTH  ALTROOT
tank   13.6T  9.30T  4.32T        -         -    34%    68%  1.00x    ONLINE  -
zroot   216G  21.9G   194G        -         -     7%    10%  1.00x    ONLINE  -

[sherman.133] # grep -i memory /var/run/dmesg.boot | egrep -v "TTM|drm"
real memory  = 17179869184 (16384 MB)
avail memory = 16537534464 (15771 MB)

[sherman.134] # sysctl hw.model hw.machine hw.ncpu
hw.model: AMD Ryzen 3 3300X 4-Core Processor
hw.machine: amd64
hw.ncpu: 8

[sherman.135] # zfs list -H | wc -l
      22

[sherman.136] # pciconf -lv | grep "Network"
    device     = '82575GB Gigabit Network Connection'
    device     = '82575GB Gigabit Network Connection'
    device     = '82575GB Gigabit Network Connection'
    device     = '82575GB Gigabit Network Connection'
    device     = 'I211 Gigabit Network Connection'

[sherman.137] $ grep "^ada.: Serial" /var/run/dmesg.boot | wc -l    # SSD zroot
       2
[sherman.138] $ grep "^da.: Serial" /var/run/dmesg.boot | wc -l     # Spinning tank
       7
The new motherboard has 2 x M2 sockets and 8 SATA ports, but I'm still using the old Avago Technologies (LSI) SAS2008 SAS/SATA controller for the tank.
 

astyle

Daemon

Reaction score: 467
Messages: 1,078

Active: Ryzen 5 1400 (3.4 GHz), Asus B350-Prime mobo, 32 GB RAM, Asus Raadeon RX 550 4 GB, two 240-GB SSD's (one is an ADATA, the other a Zheino, both with FreeBSD 13-RELEASE, and a 400W EVGA PSU. That one, I plan to use as a build/repo server, because it's been incredibly reliable, doesn't complain at overnight jobs. First rig I ever built from aftermarket parts, back in 2017.

Building in progress: Ryzen 7 5800x, Gigabyte x570 UD mobo, 32 GB RAM, Aorus RX 6900 XT 16 GB with a waterblock, a Gigabyte 240 GB SSD. Trying to mate a Be Quiet! cooler to the GPU, just ordered the fittings to connect the hoses. 😤 Oh, and the PSU is an 850W thingy by Gigabyte, as well. Hoping to finish building it before November, and start setting up FreeBSD on THAT. I know, there are water-cooled GPU's on the market that are complete systems (with pump/fans/radiators/reservoirs), but there was nothing from Gigabyte. I decided that's not gonna stop me, I'll come up with something.

I have to admit, I am jealous of forquare 's Epyc setup, but after pricing some builds, I realized I'd rather blow my money on SSD storage, and use FreeBSD to serve it up.
 
OP
roccobaroccoSC

roccobaroccoSC

Aspiring Daemon

Reaction score: 210
Messages: 722

I have to admit, I am jealous of forquare 's Epyc setup, but after pricing some builds, I realized I'd rather blow my money on SSD storage, and use FreeBSD to serve it up.
Let me ignite a little bit more jealosy then :). I am a proud owner of a ThreadRipper 16 core. :) I have to take a look into getting one of those 3-rd gen 64 core TRs. :)
 

forquare

Well-Known Member

Reaction score: 180
Messages: 329

I have to admit, I am jealous of [FONT=monospace]forquare[/FONT] 's Epyc setup, but after pricing some builds, I realized I'd rather blow my money on SSD storage, and use FreeBSD to serve it up.
😳

I'd probably best point out that the Supermicro not as impressive when you realise that all of the disks are old - which isn't very smart...
It was bought on a budget: in 2019 I sold my 2008 Mac Pro for around £600, and bought this system (from here, if anyone is interested) with the funds to have some fun with. Some disks I bought refurbished, other disks came out of an older NAS. The sticks of ECC RAM I saved from a skip, something like 256GB in all, about half of it had errors reported in memtest so got returned to a skip...
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,294
Messages: 38,811

The sticks of ECC RAM I saved from a skip
One of the often asked questions is, "how do you build a home lab?". Well, dumpster diving is a good way to get some descent equipment. You will find lots of duds but also some good stuff people just chucked away because it's "too old". Companies typically buy new hardware every 3-5 years and trash the old stuff. But enterprise grade hardware is usually built quite solidly and would probably last a lot longer than that. Not good enough for the company anymore but certainly good enough for a couple of more years in someone's home lab. When you actually work in IT it's a bit easier to get but if you're not working in IT you can just ask friends and family to keep an eye out and let them know you're willing to take some of their old stuff they're going to throw away. In all cases, ASK if it's ok if you take it home. Some companies I worked for were very strict when it came to removal of old equipment, that was always handled by specific rules. Other companies were very happy if you took away their "trash".
 

astyle

Daemon

Reaction score: 467
Messages: 1,078

The cheapest mobo for a Threadripper is around $300 USD.... For an Epyc, a compatible mobo is closer to $500 USD. A 64-core Treadripper goes for around $5k. I have to ask myself, "What am I doing that really demands the capabilities provided by a Threadripper setup that cannot be met by a recent AM4-compatible setup? A 1st-gen 8-core Threadripper goes for around $200 USD, but still commands a $300 and up mobo, and eats more power (180W) than a $400 8-core Ryzen 7 5800x (105W).

One reason I'd rather not go looking for discarded equipment - it's kind of a time sink to find it, test it for compatibility/durability (And discover it's a dud that needs tossing), keep an inventory, etc.
 
Top