Xorg: Failed to load module "amdgpu" on a box with IntelHD and AMD Radeon RX 550X

Hello everyone

I'm afraid I'm going to need some help. Please go easy on me, I'm new to this exciting world of FreeBSD :) I have a Lenovo E590 laptop with Intel HD graphics and AMD Radeon RX 550X and cannot start X.

Relevant section from the Xorg.0.log
Code:
(WW) Warning, couldn't open module amdgpu
(EE) Failed to load module "amdgpu" (module does not exist, 0)

What I've done
  • Followed the guide here (chose amdgpu)
  • In /etc/rc.conf I have kld_list="amdgpu"
With just this, the Xorg.0.log contained:
Code:
(WW) Warning, couldn't open module intel
(EE) Failed to load module "intel" (module does not exist, 0)

So I tried following this part of the handbook because it made sense that X doesn't know which device to use:
  • pciconf -lv | grep -B3 display showed me the BusID of my AMD card
  • I put this in /usr/local/etc/X11/xorg.conf.d/driver-amd.conf I created:
    Code:
    Section "Device"
        Identifier "Card0"
        Driver "amdgpu"
        BusID "PCI:3:0:0"
    EndSection
Some notes (relevance may vary)
  • hw.syscons.disable=1 prevented the OS from booting (I admit I still have no idea what it's for :D)
  • The user is member of the video group and I'm not starting X as root
  • Installed modules: drm-fbsd-13-kmod-5.4.144.g20220223 and drm-kmod-g20190710_1 - I understand the latter makes sure to install the right package, please correct me if I'm wrong
  • FreeBSD version 13.1-RELEASE
Any ideas please?
 
Remove that driver-amd.conf, you shouldn't need it. amdgpu is the name of the kernel module, not the name of the Xorg driver. Just let it try to autodetect it.

hw.sysconf.disable shouldn't be needed anymore either.
 
Aha, I see! But I tried to go back and remove it, and this is what I was getting from Xorg instead when I did that:

Code:
(WW) Warning, couldn't open module intel
(EE) Failed to load module "intel" (module does not exist, 0)

That's what puzzles me...
 
Not sure what you mean but to close this, I couldn't get it to work. Thank you anyway, I'll stick with Linux.
 
Not sure what you mean but to close this, I couldn't get it to work. Thank you anyway, I'll stick with Linux.

I have same laptop and I install FreeBSD with xfce.
The setup for this you must see what is your VGA not your other GPU by the command line:
Code:
sudo pciconf -lvbce
and the VGA for Lenovo Thinkpad E590 is WhiskeyLake-U GT2 [UHD Graphics 620].
So, the setting is by installing the Graphics Firmware intel and load it in /etc/rc.conf by adding line
Code:
kld_list="i915kms"
or by root command
Code:
# sysrc -f /etc/rc.conf kld_list+=i915kms
See FreeBSD wiki.
 

Attachments

  • Screenshot_2022-09-20_17-28-18.png
    Screenshot_2022-09-20_17-28-18.png
    157.5 KB · Views: 113
Back
Top