Xorg 7.4 upgrade - report

tingo

Son of Beastie

Reaction score: 643
Messages: 2,549

Interesting. I just did the Xorg 7.4 upgrade (from ports) and paying close attention to the relevant entry in /usr/ports/UPATING.
The xorg upgrade worked out fine (I had to run portupgrade several times, but that's no big issue).
Afterwards I had to edit my /etc/X11/xorg.conf in addition to removing the RgbPath line (documented) I also had to remove / comment out the following lines from the Module section:
Load "record"
Load "xtrap"
Load "type1"

I also had to reinstall (portupgrade -f) the radeonhd driver (xf86-video-radeonhd)

before the X server would start. After that 'startx' works, both as root and as my normal user.

I normally use Xfce, so I tried 'startxfce4' next. This also works - sort of. At first nothing but the grey X server screen comes up (that's right, no startup, no desktop, no wm, no panel etc). If I wait long enough xscreensaver kicks in. No error messages in /var/log/Xorg.0.log, nor in the console I started 'startxfce4' from.

The following xfce processes are running:
root@kg-vm# ps ax | grep -v grep | grep xfce
75822 v1 I+ 0:00.00 xinit /usr/local/etc/xdg/xfce4/xinitrc
75830 v1 I 0:00.00 sh /usr/local/etc/xdg/xfce4/xinitrc
75846 v1 I 0:00.02 /usr/local/bin/xfce4-session

I'll try to rebuild the xfce ports now.
Edit: yes, after doing a portupgrade -f for all xfce ports, XFce now starts.
Everything seems to work, with one small annoyance: the numlock led was lit after X startup, but the numlock function was off. So now the led indicates "numlock off" in X.

2009-01-25 update: today some ports go updated (libGL, a few video drivers ++). after upgrading them and restarting X, the num lock led now follows the state of numlock (in X).
There is still one odd issue left, which I noticed yesterday, but was too tired to understand: all key presses in X are delayed until I mouse the mouse. Example: if I have an xterm in focus and press 'pwd' no letters show up until I move the mouse. I press "ENTER", move the mouse and the command gets executed. Same thing if I press Ctrl-F2 to switch to workspace two. This issue is not constant; it is most noticable right after Xorg startup, when I have typed about 10-20 commands it is barely noticable for commands in xterms, but still noticable when starting programs etc.

2009-01-27: update 1: updated xorg-server, which fixed the "slow keyboard input" problem. Input from keyboard now works well.
 

ale

Daemon

Reaction score: 169
Messages: 1,059

This update is turning to be a real pain on the butt since yesterday.
I wonder how it has been tested before committing it.
 

jb_fvwm2

Daemon

Reaction score: 209
Messages: 1,843

edit ! build completed with rebuild of graphics/dri
after some more of its dependencies bumped.
............

so that line applies to an hour ago or so::

xorg-server build failing here on some GLXDRI (.h or function or
something) build problem. Only need an UPDATING-XORG (1)
file with..
........
the following are updated.
1... xtrans
...
100... xorg-server
..............
to save a few hours
(1).... annually
.................................................
 

hydra

Well-Known Member

Reaction score: 27
Messages: 272

I rather deleted all my ports and installed from scratch, however on amd64 with nvidia card (nv driver), I just got a black screen after startx, nothing happens, just a reboot helps. When I X -configure and X -config with that default config, I can move the mouse and exit properly. However startx doesn't work at all, not as root, not as user. It's a 7.1-p1 amd64 machine.
 

ale

Daemon

Reaction score: 169
Messages: 1,059

hydra said:
I rather deleted all my ports and installed from scratch, however on amd64 with nvidia card (nv driver), I just got a black screen after startx, nothing happens, just a reboot helps.
I had the same before some drivers has been bumped.
http://www.freebsd.org/cgi/getmsg.c...www/db/text/2009/cvs-ports/20090125.cvs-ports
Try upgrading x11-drivers/xorg-drivers.

I'm running on i386 with nvidia-driver and I'm unable to startx even using -ignoreABI like with the upgrade to xorg-7.3.

hydra said:
When I X -configure and X -config with that default config, I can move the mouse and exit properly. However startx doesn't work at all, not as root, not as user. It's a 7.1-p1 amd64 machine.
You are saying that it doesn't work with the configuration generated by # Xorg -configure ?
 

jb_fvwm2

Daemon

Reaction score: 209
Messages: 1,843

I upgraded the -nv- -keyboard- and -mouse x11-drivers,
the nvidia-driver, and that did not fix a "window manager loads
but not mouse not keyboard::" fsck-resultant freeze 3 times
in a row (that would've caused data loss in 5.x but in _7 I
routinely just boot as normal !, fsck is a yawner it seems);
the fix was in UPDATING, putting in ServerLayout the
Option "AllowEmptyInput" "off" (as far as I know).
.........
posting from the new xorg.
 

hydra

Well-Known Member

Reaction score: 27
Messages: 272

@ale
Well, after X -configure a new config is placed in /root, when I start X (X -config /root/xorg.conf...), it works, the mouse works ok, the keyboard also reacts, because I can switch to the console and exit the X session. However, startx locks up, nothing works, just a reboot... Some programs couldn't compile yesterday (dri for example, it requested some new version of an application that was just bumped in today), so I'll just wait I guess. Thanks for the tips.

@jb_fvwm2
Congratulations ;)I wasn't lucky even using AllowEmptyInput.
 

ale

Daemon

Reaction score: 169
Messages: 1,059

hydra said:
@ale
Well, after X -configure a new config is placed in /root, when I start X (X -config /root/xorg.conf...), it works, the mouse works ok, the keyboard also reacts, because I can switch to the console and exit the X session. However, startx locks up, nothing works, just a reboot...
Did you tried copying the generated /root/xorg.conf.new to /etc/X11/xorg.conf?
 

jb_fvwm2

Daemon

Reaction score: 209
Messages: 1,843

if you bumped xinit it replaces your xinitrc. I always backup
the latter.
..........
one of the many reasons I only bump xorg tediously one by one (so far).
.........
btw this browser looks at this forum, better than yesterday. and it
is the same browser!
maybe new improved fonts or colors
............
regarding the startx failure
for over a year I've not used startx but continue to use
a fix because it is easy in zsh (!xinit {tab]) which runs the:

#xinit /usr/local/lib/X11/xinit/xinitrc -- /usr/local/bin/Xorg
which before this week's upgrade I always tacked on the
" -ignoreABI " to the end. (or that is, zsh did with
the !xinit[tab] command, no way I could remember the line
without typing it daily).
...............
so if stuff is failing *now* even after UPDATING xorg.conf fixes,
that is one more thing to try.
.............
 

troberts

Member

Reaction score: 5
Messages: 79

My mouse does not work. After reading some posts I will reinstall Xorg to make sure I did not incorrectly update Xorg. xorg-server would error during its compile because of dri. Once I manually installed it then xorg-server was able to update, but I had already updated other ports so something might have gone wrong.
 

hydra

Well-Known Member

Reaction score: 27
Messages: 272

@ale
Yeah, I did copy the new config, but still nothing :) Seems like something is bad, because since I don't like hard-reboots, I logged on a second console as root, and used typed in:
sleep 30; reboot

Meanwhile I switch to another console, startx and nothing happened, not even after 30 seconds. I will inspect the X log... All ports are up to date btw.
 
B

barnster

Guest


Seems like anything having to do with gdm is pretty jacked up. Kinda sucks since I can't use gnome right now x(. And I actually installed kde4 and kdm just for the helluvit, and it worked, though dog slow for some reason on my Core 2. What I'm using now is fvwm-crystal, which is light and aight since I don't have any more time to troubleshoot this weekend. I think I've finally learned my lesson. Don't upgrade fresh packages that just came out...
 

gnezim

New Member


Messages: 1

Hi all,

I have latest ports, updated all everything that I could.
FreeBSD 7.1 Release
Xorg is 7.4
xorg-server is 1.5.3_1,1
x11/nvidia-driver

The problem is that I constantly get the next message if I do use "nvidia" driver
dlopen: /usr/local/lib/xorg/modules//libwfb.so: Undefined symbol
"miZeroLineScreenIndex"
(EE) Failed to load /usr/local/lib/modules//libfw.so
(EE) Failed to load module "wfb" (loader failed 7)
(EE) NVIDIA(0): Need libwfb but wfbScreenInit not found

If I use "nv" driver (+ AllowEmptyInput "off") I can load X and use it. But what for Nvidia driver?

Can anyone suggest anything?
 

trev

Daemon

Reaction score: 301
Messages: 1,026

hydra said:
I rather deleted all my ports and installed from scratch, however on amd64 with nvidia card (nv driver), I just got a black screen after startx, nothing happens, just a reboot helps. When I X -configure and X -config with that default config, I can move the mouse and exit properly. However startx doesn't work at all, not as root, not as user. It's a 7.1-p1 amd64 machine.

Same 7.1-p1 amd64 machine, but startx is fine. Unfortunately moving windows (I'm using twm :) now creates lots of screen artifacts in the moved window if it overlaps another window while being moved :( Xorg 7.3 was fine...
 

jb_fvwm2

Daemon

Reaction score: 209
Messages: 1,843

well, working OK here still. figured out how to upgrade xorg-apps:
.........
cd /usr/ports/x11/xorg-apps
make run-depends-list | xargs -J % portmaster -p %
..........
though that kills the !xinit
without a rehash
and without copying the backup /xinitrc back
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 3,217
Messages: 11,432

Had a lot of trouble on the X/Nvidia front last night (including those "miZeroLineScreenIndex" messages in libwfb and that annoying mouse/keyboard interaction / interrupt problem).

I did a massive recompile (portupgrade -rRf xorg-7.4), built the NVIDIA driver (from nvidia.com) all over again after that, and then put this in rc.conf:

Code:
moused_nondefault_enable="NO"
moused_enable="NO"

Leaving that first command to use its default value ("YES") resulted in moused starting, which interfered with X/hald. Killing it manually before starting X solved that, so using "NO" disabled moused completely at boot time and returned a normal X environment. I have no mouse in the console now, but who really needs that ..

I now have a normally functioning X, with Nvidia 3D/GLX, a normal mouse and keyboard (even thought they're on a USB KVM switch, so one single USB cable carries both).

Took lots of work (well, for the CPU), but I'm happy I did it on a rainy Sunday ;)
 

ale

Daemon

Reaction score: 169
Messages: 1,059

DutchDaemon said:
Had a lot of trouble on the X/Nvidia front last night (including those "miZeroLineScreenIndex" messages in libwfb and that annoying mouse/keyboard interaction / interrupt problem).

I did a massive recompile (portupgrade -rRf xorg-7.4), built the NVIDIA driver (from nvidia.com) all over again after that, and then put this in rc.conf:

Code:
moused_nondefault_enable="NO"
moused_enable="NO"

Leaving that first command to use its default value ("YES") resulted in moused starting, which interfered with X/hald. Killing it manually before starting X solved that, so using "NO" disabled moused completely at boot time and returned a normal X environment. I have no mouse in the console now, but who really needs that ..
I had no problem at all with mouse/kbd.
Maybe it's because I've always built xorg-server WITHOUT_HAL.
So the only thing I had to do is to add Option "AllowEmptyInput" "off" as in /usr/ports/UPDATING.
Oh, I do need mouse in console :)

DutchDaemon said:
I now have a normally functioning X, with Nvidia 3D/GLX
Can you confirm that switching the nvidia-driver from the one in ports to the latest works? Is this necessary? I tried it but it completely frozed my machine. Maybe I should retry.
I think that the ignoreABI option is required even with the 180.22 driver, isn't it?
There is also a pr with a patch for the port about 180.22, I wonder why there is always a big lag committing new versions of that port.
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 3,217
Messages: 11,432

I never used the one from ports, I've always used the one from nvidia.com. I do have these installed:

Code:
nvidia-settings-180.22 Display Control Panel for X NVidia driver
nvidia-xconfig-1.0_2 Tool to manipulate X configuration files for the NVidia dri
xf86-video-nv-2.1.12_1 X.Org nv display driver

The 'nv' driver only kicks in when I start X without /etc/X11/xorg.conf -- which results in a working X, but with limited graphical possibilities, of course.

I had to tweak Nvidia's Makefile though, because the afterinstall script froze the system during the kldunload/kldload command. All I had to do was 'kldunload nvidia' in the console, and comment out:

Code:
#       @${.CURDIR}/scripts/setup.sh
#       @${.CURDIR}/scripts/linux.sh

in the Makefile of the Nvidia 180.22 driver, before making and installing it. This means that you'll have to make sure for yourself that nvidia_enable="YES" is in /boot/loader.conf (which is basically what that first script does).

I haven't touched anything regarding to IgnoreABI, all I can see in the Nvidia build directory is:

Code:
~> strings obj/nvidia_drv.so | grep -i ignoreabi
LoaderShouldIgnoreABI
(EE) NVIDIA: Use the -ignoreABI option to override this check.

I haven't set that option while building anyway.
 

ale

Daemon

Reaction score: 169
Messages: 1,059

DutchDaemon said:
I never used the one from ports, I've always used the one from nvidia.com.
OK. I've always preferred the one from ports, unless it doesn't support my GPUs.

DutchDaemon said:
The 'nv' driver only kicks in when I start X without /etc/X11/xorg.conf -- which results in a working X, but with limited graphical possibilities, of course.
That sound strange to me. If I'm not wrong, running Xorg -configure with an installed nvidia-driver result in a xorg.conf.new with the nvidia driver, not the nv one.
But it's not a problem. That's fine.

DutchDaemon said:
I had to tweak Nvidia's Makefile though, because the afterinstall script froze the system during the kldunload/kldload command.
I had no freeze during kldload/kldunload, but running startx. But still that's fine.

DutchDaemon said:
I haven't touched anything regarding to IgnoreABI, all I can see in the Nvidia build directory is:

Code:
~> strings obj/nvidia_drv.so | grep -i ignoreabi
LoaderShouldIgnoreABI
(EE) NVIDIA: Use the -ignoreABI option to override this check.

I haven't set that option while building anyway.
This is not a nvidia build option, it's an Xorg option. You can find more in man Xorg.
Anyway thanks for the feedbacks!
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 3,217
Messages: 11,432

ale said:
That sound strange to me. If I'm not wrong, running Xorg -configure with an installed nvidia-driver result in a xorg.conf.new with the nvidia driver, not the nv one.

I was referring to running startx without any xorg.conf in place whatsoever. That starts X with the nv driver.

This is not a nvidia build option, it's an Xorg option. You can find more in man Xorg.

I have no complaints about (Ignore)ABI in my Xorg.log anyway, and I've built Xorg and its surroundings without overriding any options.
 

tobe

Member

Reaction score: 9
Messages: 92

Hi,

This update is really painful for me too.
Lots of troubles with portupgrade and pkgdb while upgrading xorg from ports. I still have some missing/ignored dependencies 'xphelloworld' and one driver, so i did use portupgrade with -k option in order to build as much as possible - it fixed lots of dependency troubles btw, except the two i've listed above.
I have the problem with xfce4 (grey X background), it seems it wasn't rebuilt despite the -r option passed to portupgrade.
I'm still in the process of fixing my box (i'm writing this message from my pc at work).
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 3,217
Messages: 11,432

Another thing that keeps biting my X/Nvidia.com configuration: just upgraded to xorg-server-1.5.3_1,1 and it overruled Nvidia's GLX library again, so the symlink libglx.so -> libglx.so.1 (the latter being nvidia's GLX lib) was replaced by Xorg's libglx.so. Just a hint if half of your Xscreensaver modules fail to render all of a sudden .. it's in /usr/local/lib/xorg/modules/extensions/.
 

ale

Daemon

Reaction score: 169
Messages: 1,059

Usually, after doing this kind of upgrade (xorg stuff, nvidia driver) I look at the output of glxinfo (glxinfo | grep vendor) and test glxgears.
This could help spotting which gl extension is being used.
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 3,217
Messages: 11,432

It's also in Xorg.log:

(II) Loading /usr/local/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"

(or "X.Org Foundation", of course ..)
 
Top