vbox XFCE4 does not launch on FreeBSD Virtualbox guest

yes, of course. This is standard option. However, it is difficult to imagine that linux or FreeBSD version of VirtualBox Manager has more options than Windows.

What happen if you click directly the word VMSVGA in the line "Graphic Controller" in the main window of VirtualBox Manager?
If I change from VMSVGA to VBoxSVGA it appears the invalid settings message:

2c1yzY6.png
 
this is not a bug as VB Manager is telling you exactly what is going to happen (hover mouse over icon warning "Invalid settings detected")
That's the same for me, however after clicking OK if you reopen it changes from VBoxSVGA to VMSVGA. Maybe it only happens on Windows host, you can try please?

OFTN9Mw.png


While "Enable 3D Acceleration" is ticked it will always take over the "Graphics Controller" setting. If I open FreeBSD.vbox after enabling VBoxSVGA and 3D it looks like this:
Code:
<Display controller="VMSVGA" VRAMSize="32" accelerate3D="true"/>

Please, try for yourself on Windows 10 64 bits host and you will see that happens the same to you. I will try later on Linux host if I have the chance.
 
this is not a bug as VB Manager is telling you exactly what is going to happen (hover mouse over icon warning "Invalid settings detected")

Ah, thanks!

An unfortunate side effect of learning to habitually ignore all warnings in that area: I ceased looking at details. My bad.

Still, it's a UX bug; if VBoxSVGA is selected it should be impossible to co-select an option that will not work with the selection.
 
this is not a bug as VB Manager is telling you exactly what is going to happen (hover mouse over icon warning "Invalid settings detected")
Yes, however if you select only VBoxSVGA and no 3D, still tells you that the virtual machine is "configured" to run on VMSVGA. It's true that with it FreeBSD runs faster, but doesn't have auto-resize for guest, so clearly the support for FreeBSD is not updated regarding the actual behavior.
 
Tried with Virtualbox client for Linux host, version 6.1.22, and behaves exactly like the Windows version. You can't have VBoxSVGA and 3D at the same time. You probably modified the .vbox file by hand otherwise doesn't make sense to me.
 
If I change from VMSVGA to VBoxSVGA it appears the invalid settings message:

2c1yzY6.png
you are relly not reading carefully what I posted, all information, how to enable VBoxSVGA/3D is in my previous posts. There is nothing else unfortunately that I can do.
 
Guido Falsi recommends on bug tracker to switch to lightdm. However I had two issues with it: first, it autocompletes username with "User&", and I have to actively change to Other. With SLiM I already have the two fields to enter and that's it. Also, on lightdm, the screen locked due to auto lock session enabled by default. When I entered again my username and password just didn't login, falls back to same login screen. With SLiM no issues.

I've installed this and working fine autoresize with VBoxSVGA:
Code:
emulators/virtualbox-ose-additions
virtualbox-ose

This is /etc/rc.conf:
Code:
hostname="freebsd"
ifconfig_DEFAULT="DHCP inet6 accept_rtadv"
growfs_enable="YES"
sendmail_enable=NONE
dbus_enable="yes"
hald_enable="yes"
slim_enable="yes"
lightdm_enable="no"
sound_load="yes"
snd_hda_load="yes"
vboxguest_enable="yes"
vboxservice_enable="yes"
devfs_system_ruleset="system"
 
Top