vbox XFCE4 does not launch on FreeBSD Virtualbox guest

Did some tests and this is actually not correct. The -x test fails because it doesn't receive a full path to the executable, apparently it did at some point because this was directly copied from a working system. Anyway, this should work better:
Code:
[ -n "$1" ] && [ -x "/usr/local/bin/$1" ] && exec "/usr/local/bin/$1"
I am assuming every WM or DE gets started from an executable in /usr/local/bin, but I believe that's a fairly safe assumption.
Thanks, tested and working. So my ~/.xinitrc looks like this now:
Code:
VBoxClient --display
[ -n "$1" ] && [ -x "/usr/local/bin/$1" ] && exec "/usr/local/bin/$1"
exec startxfce4

Then I've installed fluxbox (sudo pkg install fluxbox), however with F1 on SLiM it doesn't appear, only "Session: Xfce session". Even replacing "startxfce4" with "startfluxbox" on ~/.xinitrc didn't work. I have to edit it like this:
Code:
echo "exec startfluxbox" > ~/.xinitrc
Guest auto-resize is not working with fluxbox, only xfce4.
 
Maybe an assumption, by developers of VirtualBox, that most users of FreeBSD will not use X.org (will not require guest additions), and so on.



With which version of guest additions?
So they don't use desktop managers at all, only command line?
How do I get the version of guest additions?
 
Maybe an assumption, by developers of VirtualBox, that most users of FreeBSD will not use X.org (will not require guest additions), and so on.
FreeBSD isn't supported by the developers of VirtualBox at all:
https://www.virtualbox.org/manual/UserManual.html#hostossupport
https://www.virtualbox.org/manual/UserManual.html#guestossupport

(My experience with VirtualBox: It was great before Oracle came in. Some installations worked, some not - fun fact without fun: they were identical. Some file systems got crushed, and some VMs fell into a fairy tale sleep after a short time.)
 
I gather that FreeBSD developers are particularly vicious: I guess they provide each of FreeBSD potential users who want to run FBSD in VM with unique version of virtualbox-ose-additions for each user so each time are new unexpected problems.

Seriously: there are only few hardware variations provided by VirtualBox so if for some reason FBSD in VM will encounter problems with video setup it means that user made a mistake because all virtual hardware is really conservative.

Thanks a lot. The thing is, when you create a new Virtualbox FreeBSD 64-bit vm, it's configured with VMSVGA by default.
This is default Virtualbox setup for any client not only for FreeBSD. I guess VB developers assumed that user will read manual.
Yes you can change VMSVGA to VBoxSVGA and have 3D acceleration.

virtualbox-ose-additions-legacy-5.2.44_3
Why not to install the latest version (6.22)?
 
… you can change VMSVGA to VBoxSVGA and have 3D acceleration. …

This seems to be a bug in the GUI. If you OK the combination then review the settings, you'll find that enabling 3D acceleration disables VBoxSVGA.

Instead:
  1. disable 3D acceleration
  2. switch to VBoxSVGA
  3. OK the settings.
 
I gather that FreeBSD developers are particularly vicious: I guess they provide each of FreeBSD potential users who want to run FBSD in VM with unique version of virtualbox-ose-additions for each user so each time are new unexpected problems.

Seriously: there are only few hardware variations provided by VirtualBox so if for some reason FBSD in VM will encounter problems with video setup it means that user made a mistake because all virtual hardware is really conservative.


This is default Virtualbox setup for any client not only for FreeBSD. I guess VB developers assumed that user will read manual.
Yes you can change VMSVGA to VBoxSVGA and have 3D acceleration.


Why not to install the latest version (6.22)?
How do I install version 6.22?
 
This seems to be a bug in the GUI. If you OK the combination then review the settings, you'll find that enabling 3D acceleration disables VBoxSVGA.

Instead:
  1. disable 3D acceleration
  2. switch to VBoxSVGA
  3. OK the settings.
this is not a bug, this is by design setup.
It will always revert to VMSVGA if 3D acceleration is enabled.
Setting is modified from the main screen of VirtualBox Manager:
1) open settings -> Display -> check 3D acceleration
2) do NOT change VMSVGA.
3) press OK
4) in the main screen of VirtualBox Manager select:
Display -> click on Graphic Controller: VMSVGA from pulldown menu select VBoxSVGA

The same way you can change Video Memory size

Remamber: any changes with setup will revert the selection, so you will have to change VMSVGA again from to VBoxSVGA
This is not a big deal as once setup, Settings are rarely modified
 
this is not a bug, this is by design setup.
It will always revert to VMSVGA if 3D acceleration is enabled.
Setting is modified from the main screen of VirtualBox Manager:
1) open settings -> Display -> check 3D acceleration
2) do NOT change VMSVGA.
3) press OK
4) in the main screen of VirtualBox Manager select:
Display -> click on Graphic Controller: VMSVGA from pulldown menu select VBoxSVGA

The same way you can change Video Memory size

Remamber: any changes with setup will revert the selection, so you will have to change VMSVGA again from to VBoxSVGA
This is not a big deal as once setup, Settings are rarely modified
Yeah but it's weird that apparently allows you to select both and after you hit OK you come back and only one is enabled. It should disable it in front of you. I hope I explain myself...
 
Tried the same installation on Vmware Workstation and is even worse: guest does not auto-resize. Even the program tells you FreeBSD is not supported:

XFLyYV3.png

VMware Workstation
Perl script-based VMware Workstation Tools installation for FreeBSD has been discontinued. FreeBSD systems are supported only through the open-vm-tools packages directly available from FreeBSD package repositories.

Did this:

1- Clone the virtual disk from Virtualbox to Vmware Workstation (no snapshots):
Code:
& 'C:\Program Files\Oracle\VirtualBox\VBoxManage.exe' clonehd FreeBSD-13.0-RELEASE-amd64.vdi FreeBSD-13.0-RELEASE-amd64.vmdk --format VMDK -variant standard

2- Create a new vm on Vmware selecting Other --> FreeBSD 12 64bit, and choose as disk "FreeBSD-13.0-RELEASE-amd64.vmdk".

3- Launch the virtual machine, install "open-vm-tools", and edit "/etc/rc.conf":
Code:
vmware-guestd_enable="yes"
vboxguest_enable="no"
vboxservice_enable="no"

Even with that after reboot, XFCE4 and Fluxbox don't auto-resize. Also you can't enable 3D acceleration.

Guides:
 
Tried the same installation on Vmware Workstation and is even worse: guest does not auto-resize. Even the program tells you FreeBSD is not supported:

XFLyYV3.png

VMware Workstation
Perl script-based VMware Workstation Tools installation for FreeBSD has been discontinued. FreeBSD systems are supported only through the open-vm-tools packages directly available from FreeBSD package repositories.

Did this:

1- Clone the virtual disk from Virtualbox to Vmware Workstation (no snapshots):
Code:
& 'C:\Program Files\Oracle\VirtualBox\VBoxManage.exe' clonehd FreeBSD-13.0-RELEASE-amd64.vdi FreeBSD-13.0-RELEASE-amd64.vmdk --format VMDK -variant standard

2- Create a new vm on Vmware selecting Other --> FreeBSD 12 64bit, and choose as disk "FreeBSD-13.0-RELEASE-amd64.vmdk".

3- Launch the virtual machine, install "open-vm-tools", and edit "/etc/rc.conf":
Code:
vmware-guestd_enable="yes"
vboxguest_enable="no"
vboxservice_enable="no"

Even with that after reboot, XFCE4 and Fluxbox don't auto-resize. Also you can't enable 3D acceleration.

Guides:
FreeBSD with VboxSVGA and 3D.
There are only two instances when resizing does not work:
use of VMSVGA
or
VboxSVGA without virtualbox-ose-additions installed. In this case however, resizing is still possible by creating monitor definition.
 

Attachments

  • FreeBSD-VboxSVGA-3D.png
    FreeBSD-VboxSVGA-3D.png
    131.3 KB · Views: 46
FreeBSD with VboxSVGA and 3D.
There are only two instances when resizing does not work:
use of VMSVGA
or
VboxSVGA without virtualbox-ose-additions installed. In this case however, resizing is still possible by creating monitor definition.
I can't set VBoxSVGA and 3D at the same time. Maybe it's host related, since I'm on Windows 10. Can you try with that host if you can keep VBoxSVGA with 3D?
 
I can't set VBoxSVGA and 3D at the same time. Maybe it's host related, since I'm on Windows 10. Can you try with that host if you can keep VBoxSVGA with 3D?
Unfortunately I don't have windows installed, but this is how selection looks like (see picture). I would think that windows would has better support than FreeBSD or linux (my host is linux)
 

Attachments

  • FreeBSD-VboxSVGA-3Dv3.png
    FreeBSD-VboxSVGA-3Dv3.png
    142.7 KB · Views: 42
Unfortunately I don't have windows installed, but this is how selection looks like (see picture). I would think that windows would has better support than FreeBSD or linux (my host is linux)
Change the settings from the Settings wheel icon and hit OK.
 
Change the settings from the Settings wheel icon and hit OK.
yes, of course. This is standard option. However, it is difficult to imagine that linux or FreeBSD version of VirtualBox Manager has more options than Windows.

What happen if you click directly the word VMSVGA in the line "Graphic Controller" in the main window of VirtualBox Manager?
 
Top