XDM not allowing me to log in as any user

Hello,

I recently installed FreeBSD and am having problems with XDM not allowing me to log in as my set up user or root. XDM boots up fine but when I click into the password field nothing shows up as a I'm typing (first time using XDM this might be a feature?) and when I do type the password in it just reloads to another empty login screen prompting me to type in the user. I followed the instructions in the handbook outlined here https://www.freebsd.org/doc/handbook/x-xdm.html . I hope someone can help, I'd really appreciate it.

Thanks
 

SirDice

Administrator
Staff member
Administrator
Moderator
Turn off XDM and see if startx works as a user. Once that's fully working enable XDM again.
 
Sorry, I guess I should have checked that before posting. I'm doing this in a virtualmachine and trying to use/intall xfce.

startx does not work and gives an error. It's long and I'm unable to copy/paste it but I will include the lines that look like errors:
Code:
failed to set mtrr: Device not configured
/usr/local/bin/startxfce4: X server already running on display :0
Mar 9 03:29:10 freeBee ck-launch-session: error connecting to ConsoleKit
process 1367: D-Bus libary appears to be incorrectly set up ; failed to read machine uuid: Failed to open "/etc/machine-id": No such file or directory
xinit: connection to X server lost
Waiting for X server to shut down failed to unset mtrr: Device not configured
(II) Server terminated successfully (0). Closing log file.
xauth: (argv):1: bad display name "freeBee:0" in "remove" command
Thanks
 

jrm@

Developer
XDM boots up fine but when I click into the password field nothing shows up as a I'm typing (first time using XDM this might be a feature?)
No password echoing is indeed the default. To change this behaviour, add
Code:
xlogin.Login.echoPasswd: true
to /usr/local/lib/X11/xdm/Xresources. The default echo character is *. You can change this by setting
Code:
xlogin.Login.echoPasswdChar
 
Turn off XDM and see if startx works as a user. Once that's fully working enable XDM again.
Sorry to resurrect an old thread, but I am having the same issue. Unless I login as “root”, I am not able to log in as any other user.
 
Welcome to FreeBSD Forums.

xdm set in /etc/ttys is started as nodaemon.

That's normal, in my experience.

Code:
% tail -n 24 /etc/ttys
console none                            unknown off secure
#
ttyv0   "/usr/libexec/getty Pc"         xterm   onifexists secure
# Virtual terminals
ttyv1   "/usr/libexec/getty Pc"         xterm   onifexists secure
ttyv2   "/usr/libexec/getty Pc"         xterm   onifexists secure
ttyv3   "/usr/libexec/getty Pc"         xterm   onifexists secure
ttyv4   "/usr/libexec/getty Pc"         xterm   onifexists secure
ttyv5   "/usr/libexec/getty Pc"         xterm   onifexists secure
ttyv6   "/usr/libexec/getty Pc"         xterm   onifexists secure
ttyv7   "/usr/libexec/getty Pc"         xterm   onifexists secure
ttyv8   "/usr/local/bin/xdm -nodaemon"  xterm   off secure
# Serial terminals
# The 'dialup' keyword identifies dialin lines to login, fingerd etc.
ttyu0   "/usr/libexec/getty 3wire"      vt100   onifconsole secure
ttyu1   "/usr/libexec/getty 3wire"      vt100   onifconsole secure
ttyu2   "/usr/libexec/getty 3wire"      vt100   onifconsole secure
ttyu3   "/usr/libexec/getty 3wire"      vt100   onifconsole secure
# Dumb console
dcons   "/usr/libexec/getty std.9600"   vt100   off secure
# Xen Virtual console
xc0     "/usr/libexec/getty Pc"         xterm   onifconsole secure
# RISC-V HTIF console
rcons   "/usr/libexec/getty std.9600"   vt100   onifconsole secure
% uname -KU
1400051 1400051
%
 
I can not login even as root. Looks like xdm set in /etc/ttys is started as nodaemon.
Looks correct. But let us check the basics: Have you created your ~/.xsession file, and what's the content of it?
man xdm[Enter]/Xsession[Enter]
 
My first guess is that you are exiting from the ~/.xsession. If you do that, the window manager will die.

Reduce the ~/.xsession to an absolute minimum. Something like:
Code:
PATH="$HOME/bin:/usr/local/bin:$PATH"
export PATH
xterm &
exec twm >$HOME/.wmlog 2>&1
Then add complications a bit at a time.
 
Top